Connection to Modem Issues

  • Hi,

    Got an issue with the Amplifi Router where it won't establish an internet connection when connecting directly to the modem. I connect the DSL connection on the modem (BT UK), to the Router's "Internet port" and the Router displays "no internet connection" or words to that effect.

    Although, if I plug the DSL connection from the modem in to my Airport Extreme and then one of the ethernet ports off that into the Amplif Router's Internet port, it works right away.

    Is there an option I'm not selecting?

  • Sounds like a DHCP problem. Does one or more of your cable modem, Amplifi, or Airport have either bridge mode or static IP assigned? If so, switch off bridge mode and clear the static IP assignment, then try the cable modem and Amplifi again.

  • Hi

    Looks like the problem I had initially. It went away when I turned VLAN on on the Amplifi and set VLAN address to 101.

  • Cheers gents, I'll give that a go later.

  • I’m using BT infinity with an Openreach HG612 modem. The only settings you need are PPPoE as the network type, then PPPoE username: and password: bt

    Make sure VLAN ID is off, hardware NAT off, IPv6 off and it should work fine.

  • @andrew-moore

    VLAN ID should not be 101 that only applies to the VDSL modem.

  • Probably should have mentioned in my initial post I am using a Netgear modem. That was the only thing I found that would make it work with the Amplifi.
    If I need to reconfigure the modem, have you any suggestions?
    I should mention that I am a complete beginner to this, but had to replace a failing BT Homehub.

  • @andrew-moore

    Only the Netgear modem should need the VLAN 101. I assume you have it in bridge mode?

    Ideally you should ditch the Netgear and get an Openreach HG612 for £15 on eBay.

  • @peter-farrar

    Ah yes! The HG612, got one of those. After spending 48 hours of reconfiguring rebooting and swapping ethernet cables, while following instructions on YouTube and assorted other sources, I gave up.
    I then bought the Netgear DM200 because I'd used Netgear stuff before and usually the "wizard" assists in the setup.
    Just add user name and password, and it works.
    On this occasion it left me with no internet. Switching VLAN to "On" in the AmplifiHD was an act of desperation fuelled by a half read post on some forum or other. Bingo! It worked.
    So, bridge mode, is that bad? Please clarify.
    Just checked the modem and it is set to what Netgear call Bridge(Modem Only) Mode.

Log in to reply