How to set up 2nd router as a wireless mesh point?


  • My friend gave me a 2nd AMPLIFI router, and I would like to set it up as an additional wireless mesh device. I can’t work out how to do it. I read a post that all you need to do is connect to the 2nd router and “set up as a mesh device” - but can’t find any setting.

    It won’t be connected via Ethernet only wireless.

    Any advise will be super helpful.

    Thank you!


  • @jason-king it’s easy. When you set it up, it asks you if you want to set it up as a mesh device. I have four set upm(two wired, two wireless)


  • It's been a while...do you get to the setup menu using the 3-bar 'hamburger' menu in the upper left of the app and start a wizard?


  • Interesting. So when I start it up fresh, and connect to the “set up”WiFi network, all it asks is for me to set the Wireless Network name / password. Nothing about setting up as a mesh point.

    If I set it up as WiFi network, all it says is that there is not internet connected. I can’t find in any setting about creating it a mesh point for my main router.


  • Hi @jason-king - when you power up the second router near your main router does the main router LCD give you a notification that it has found the new device and ask if you want to add it to your mesh?


  • No -I don’t get any message or option to set up the 2nd router as a mesh point.


  • Hi @jason-king - was the router used before you received it?

    I would suggest doing a factory reset and then powering it on near your main router again.

    I believe it should be automatically detected and then the app or the LCD on your main router should ask if you want to add it to your mesh.


  • Thanks for your help. No -it was fresh out of the box. I have done a few factory resets on it already. I will give it another shot.


  • Hi @jason-king - sorry I can’t help more.

    You might try plugging its WAN port into your main router using an Ethernet cable and setting it up as a router in Bridge mode via the LCD interface so you can at least update it to the latest firmware.
    Then maybe try a factory reset again and see if you network detects it.


  • I reset it again —-and getting further. My main router found the device. Going through the step of setting up as a mesh point. After “Name Mesh Point” it says “oops. Something went wrong” grrrr. I agree, I may try to to connect via WAN and download any updates.

    Thanks again for your help


  • No firmware updates found. I reset again. I feel I get so close to adding the mesh point, but always says “Oops. Something went wrong”now.

    Maybe I should reset my main router, and start fresh. I don’t want to do that, but maybe something wrong with my main settings.

    0_1527868522506_E3D5783F-6C08-4F92-ABDC-9BF701182363.jpeg


  • @jason-king I had this issue too. Had to return the router and get a new one. It's not you, there is something in the amplifi that prevents new routers from being set as mesh points. I purchased a new router and tried it out and it set up right out of the box as a mesh point.


  • @arie-mark Thanks... yes, I reset all routers for a fresh start and still couldn’t get past the “oops” error message. I think I am going to give up now. Shouldn’t be this difficult or not knowing exactly what is wrong. Should be able to look in some log file for troubleshooting... but there are none.


  • @jason-king I had a similar problem when I bought an extra Amplifi router. There was no possible way to set it up as a mesh point through the app. It was possible to set it up through the web browser, but only as router and not as a mesh point. I rebooted it and I then realized that it shows up on the display of the main router in the same way as a normal mesh point and you can add it as a mesh point through the display of the main router. That did the trick for me. I hope this helps.


  • @stefan-du-toit Thanks. Are you saying that something shows up on the actual display/LED screen of the main router itself? In all my resettting & rebooting of the new router, nothing was displayed on the main router that related to adding it as a mesh point.


  • Hi @jason-king - normally, the way it should work, is when you power up the new router in close physical proximity to your main router, your main router should detect it.
    Once detected, your main router should show a notification on its LCD asking if you want to add the new router as a mesh point.

    The app should show the same notification on the main screen.

    For some reason your new router is not being detected.

    If your setup is not too complex, you might try installing the new router as your new main router, ensure everything is working, then factory reset your old router and try installing it as a mesh point and see if it is properly detected.

    That is a lot of work.
    But it sounds like you have invested a lot of time already.


  • @derek-saville I still hold to @Jason-King has a bad amplifi router. I went through everything he has tried and you have suggested so far. The situation seems similar. In fact I even asked @UBNT-Gunars how to connect 2 routers together way back in the day because I couldn't get it to connect on its own. After purchasing a new one and it connecting automatically, I realized the device was messed up, not me.


  • @jason-king The router you are adding to your existing setup, was it from an HD kit? The routers and mesh points are factory paired together in the kits and they cannot be merged with another kit. The error message you got sounds like this may be the case.
    Please let me know


  • @ubnt-brett It could be exactly this too. I assumed he ruled that option out.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.