Devices not connecting to closest mesh point


  • Network Setup: Amplifi router, 2 mesh points that are in “direct connection” mode to router, not “multi-hop”

    Firmware: 2.6.3

    Configuration: Hardware NAT enabled, DNS bypass enabled, /k/v switches on (but this doesn’t matter, this issue occurs no matter what combination I use). Band steering on, router steering off.

    Problem: If I cycle the router + mesh points, devices connect to the AP that comes up first (which is always the router) and will not connect to the mesh points until I force them to either by restarting them, toggling the wifi on them, etc. These are static devices in my living room, with a mesh point no farther than 15 feet away from any of them (the router is on the 2nd floor, about 80 feet away), as follows:

    • Pioneer Elite Receiver
    • Xbox One X
    • Nintendo Switch
    • Logitech Harmony Elite (the hub)
    • Amazon Echo
    • Samsung 8000 series flatscreen

    No matter what, ALL of these devices will connect to the router, even though the Mesh signal is about 95%, and the router signal is < 40%. So even with /k/v enabled, they are NOT finding the optimal AP to use. I’ve tried all the different combinations of /k/v switches, and nothing works.

    Why are these devices not switching over to the much stronger mesh point in the same room once they connect to the router, after the router has fully cycled? This is. big problem, b/c the speeds to the router at that range are very slow...so slow that modest streaming stutters, and streaming Plex is out of the question. It’s the same thing in my kitchen which also has its own mesh point now...everything wants to connect to the router, and stay connected to the router, until I make them connect to a mesh point. I realize the new SSID feature in 2.7 will fix this (hopefully?) but if it doesn’t, I’m selling all of my Amplifi equipment and finding a solution that works better.

    The new SSID feature for mesh points seems like a very complicated solution to a very simple problem though, and I’m not looking forward to setting it up. Being able to pin devices to a mesh point will be nice, but that solution shouldn’t even be needed, and seems like a horribly convoluted solution to a simple problem: Devices should just use the closest mesh point. I realize the /v switch might direct devices to a less “busy” AP, but if that AP has a much weaker signal, that should outweigh how many other devices are connected, especially if those devices aren’t high throughput.

    We’ll see how it goes with 2.7, but if that doesn’t fix this problem, I’m jumping ship. 2.7 is already going to complicate initial setups it sounds like, unless you provide some sort of wizard to pin devices to an AP. Personally, I’d like to be able to map Profiles to an AP, since I organize my profiles by room (I realize that not everyone will do this, and may instead have logical groupings for profiles like “laptops” or “kids” etc).

    Just fix this, please. I’ve talked to friends with other mesh systems, and this isn’t a problem with theirs.


  • I too have the same problem. I have a Beoplay wifi speaker standing next to the mesh point. The mesh point shows 100%, but the speaker insist on connecting to the router that shows 43%.


  • @Jayson-Knight - I've experienced the same frustration here with my standard HD system (no custom config) and could only solve the problem by turning off (not rebooting) all clients in our home office for example then shutting down the AP in the same office. I then power up the office AP and after its connection with the router stabilizes (all five lights solid on the AP), I power up each client in the office. In all cases the office clients now connect to my office AP instead of the weaker signal from our router located at the other side of the house.

    The good news is since firmware 2.7 (and also with 2.7.1) my "distant" clients are connecting with the expected (read nearest) AP without me power cycling devices and APs any longer to force the best connection.

    Hope this helps....

    Dave


  • @david-simpson I’ve gone the route of locking fixed devices to the closest mesh point via the new additional SSID feature in 2.7. I’d rather it work like it’s supposed to by finding the best mesh point, but this works fine, no more problems.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.