Additional SSIDs and IoT devices - still having issues


  • I have been fighting with Amplifi and my Chamberlain My-Q garage door opener for well over a year. It was so bad that I switched to other brands (which were returned for other reasons) and keep falling back to Amplifi.

    The thought was always that the mesh was creating the disconnect issues. With 2.7.x I was able to create non-mesh SSIDs and I thought this would finally solve everything. Not so fast.

    I created 2 additional SSIDs, one on a bridged HD and one on the primary router HD. I also had an extra D-Link router that I used as a control device. I connected the My-Q to each of the SSIDs for a day and checked the number of resets. Here are the results:

    With Amplifi mesh
    Security: WPA2-AES
    Security Value: 4
    Resets per day: 185

    With Amplifi standalone SSID (close)
    Security: WPA2-AES
    Security Value: 4
    Resets per day: 192

    With Amplifi standalone SSID (far)
    Security: WPA2-AES
    Security Value: 4
    Resets per day: 181

    With D-Link standalone
    Security: WPA2-Mixed
    Security Value: 6
    Resets per day: 1

    If you look at the resets per day, across the board, whether it is mesh or either additional SSID, basically it loses connectivity about every 6-8 minutes. But on a cheap D-Link it loses connectivity once a day.

    The biggest difference I can see is that the Amplifi security is WPA2-AES and for the D-Link it is WPA2-Mixed (meaning TKIP and AES).

    There is no setting (on either manufacturer) to manage this connection, only setting to WPA or WPA2.

    Any ideas on where to turn next?


  • Just created a guest network and set it to WPA (not WPA2) to see how that works. The problem is that while it is on the guest network I have no way to get at the console because the IP is on the other side of the “firewall”. Anyone have a good tip for accessing a client device on a guest network? I tried connecting to the guest network but I cannot access it via the IP address when I am connected.


  • @john-fruehe To my knowledge, you can’t. This is by design so that anyone connecting to your guest network cannot access any of your internal devices. Personally I’d like an option to have guest be routable to the main subnets...I have guests over all the time, and would like them to be able to control my Spotify devices (e.g. act as a DJ of sorts) without giving them my main SSID password.

    tl;dr it’s a security thing


  • Worked on the guest network and never had any outages but I could not tell whether there were disconnects because I could not get through the firewall.

    Then I put it back on the primary mesh, and ran that one with WPA (only) for a while, still saw disconnects

    Security: WPA2-AES
    Security Value: 4

    But then I reset the security to WPA2. Now I am not seeing resets and then checked on the status:

    Security Type: WPA2-MIXED
    Security Value: 6

    To me it looks like the reset issue is tied to how the device is connecting to the network on the security protocol.

    Any insights?


  • @john-fruehe could you post a screenshot of your AmpliFi SSID set-up? I may have a lead on the problem.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.