Router stuck on loading screen.


  • hello all

    this seems to be a common issue
    i have upgraded the firmware on my Amplifi router only for it to now be stuck on the start up screen i have tried a reset and a 40 sec press to go into recovery mode all to no avail
    i feel deeply upset that a company can distribute a firmware that seems to brick everyones unit
    is there a way of rectifying this
    can it be done by downgrading the firmware through the USB port on the rear
    i look forward to some help please
    take care
    stay safe
    tom


  • @tomdsew

    Did this just happen yesterday or today? As I said in a previous post I was able to get my unit working again, but mine just went back to its "stuck screen" mode last night or today.

    Not sure if it is connected, but I checked the version for the firmware and it updated to 3.4.4 (I had 3.4.3 working.)


  • Same thing just happened with my mother-in-law's Amplifi HD. She woke up this morning and couldn't get on the internet. When we got there to look at things, the Amplifi HD was just sitting there on the starting screen (Amplifi -- WiFi Perfected) with the 5 glowing dots below it just cycling through. Unplugging/re-plugging and unplugging it and letting it sit for a while doesn't help. Pushing the reset button on the bottom doesn't do a darn thing. The unit doesn't show up on the app at all. I don't know how old her unit is (1-2 years). Is it toast?

    EDIT 1: I saw an earlier post about Recovery Mode (remove the power from the router, hold down the reset pin, connect power and keep holding the reset pin for another 40 seconds until the LED starts flashing). I did that and got the flashing light on the bottom of the unit but, even though I can see its IP address on the network, I can't connect to it via a wired connection and it doesn't show up in the Amplifi app. Is there anything else I can try?

    EDIT 2: Did the Recovery Mode thing again and then connected to Amplifi directly to the cable modem and my computer directly to the Amplifi. It then showed up on my phone's wifi settings as "AFi-R-HD-[MACstuff] Recovery". But, connecting the phone to it gave no internet access. In Windows 10 PowerShell (admin), I did an ipconfig /release and /renew and it got an IP address and showed the address of the default gateway (192.168.1.20). I browsed there and got a screen showing the Amplifi and the options to "Select a file to upload" which, when clicked, gave me nothing but a File Explorer page asking for a local copy of the file. There was also an Upload button, but since no local file was available, all it said was "Invalid firmware file" when clicked. Again, the device did not show up in the Amplifi app. If I could find the firmware files, I could try again. But, I don't see them anywhere. Where are the links to the firmware files?

    FINAL EDIT: I think I've gotten this thing working again. I tried "chatting" with some of the Admins on the forum, be we crossed paths and nothing came of it. So, I emailed help@amplifi.com and asked them for the firmware link. They replied within a couple of hours (and it's Sunday, to boot) with a 3.4.3 firmware. The path looks similar to what Pavel provided, below, but some of the numbers are different. So, I think the firmware file has identifying information embedded. Anyway, downloaded and stored the firmware locally, got the Amplifi into Recovery Mode, hooked my computer directly to the Amplifi and the Amplifi directly to my cable modem, selected the local firmware file and Uploaded it. It took a while, but it finally booted up. After a bit, it even notified me that 3.4.4 was available. I tapped the screen to download and update that. Then, I connected via the app and set everything back up again. Everything appears to be working. So, I'm happy. Thanks.


  • @etterablient I had the same issue recently. Support guys sent me a link to direct download. I have only 3.4.3, maybe they push you to 3.5.0.

    3.4.3 Firmware


Log in to reply