Abysmal speed from Amplifi HD, as soon as I leave the same room as base router


  • I have tried everything, hasn't mattered how I have my Amplifi HD set up, I have the base router and two mesh points. I have given up on the system twice now and went to various other routers, but I like the range that the mesh points provide for my outdoor nest cameras, etc.

    I have 250/25mbps internet, I can never get more than 70mbps through the mesh points, or the base router unless I'm in the same room as it. I am basically only getting the full 250/25 from my wired devices in the office.
    Also, I frequently need to turn wifi on and off on my devices to get them to actually pull traffic, they will report full strength, but can't actually browse for anything. Macs, Windows PCs, iPhones, all affected the same.

    Also it seems that my mesh points have less "signal" as they did when I first got the system. Each one is reporting 68%, their location hasn't changed, they were reporting >90% when new, seems performance has degraded with every firmware update. I have a 2500 sq ft house, thick walls, but I am certainly not asking for much from this system. Main router is located in upstairs office, the two mesh points are in opposite sides of the house, one floor below the office. House is a basically square dutch colonial.

    Settings are as follows, but have been changed around many times, no real differences in performance:

    Band steering: On
    Router Steering: Off
    Single SSID WPA2 PSK

    I have tried splitting off SSIDs to 2.4ghz and 5ghz, but it doesn't seem to make a difference for the issues above.


  • @chris-eaton I have almost the exact same setup in my house (down to locations and size of house).

    Do you have the /k/v switches enabled in the WebUI? These help me out a lot, especially on my iThingie devices. Make sure your devices are hopping over to the 5ghz spectrum, though if you have thick walls, your devices might be hopping on the 2.4ghz since it penetrates walls better due to the longer wavelengths. Enable 20/40mhz as well for 2.4ghz, and also make sure you are on non-congested channels.


  • Yep, I have the k/v switches checked.

    As to be expected, when my devices connect to 5ghz, speed is faster, range much lower, as expected, but most devices are having no trouble latching on to 5ghz, but still impossible to get more than 100mbps unless I’m basically on top of the main router.

    I live in the middle of no where on 3 acres, so I have little to no congestion. 20/40 enabled on 2.4.

    I am running with band steering off, everything is more stable with it off, but, even slower.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.