Canon MG5220 Slow Wi-Fi


  • I have recently started having issues with a Canon multifunction (MG5220) having what appears to be very slow Wi-Fi connectivity. It takes a very long time for print jobs to stream to it. This is seen regardless of device that's submitting the print job. The print jobs do eventually succeed, but instead of it starting to print nearly instantly, it takes 3-5 minutes. I've tested with four different Windows 10 machines. All see same behavior. I am unable to use those machines to query the status of the printer. Constantly get the printer is not responding or is offline. This seems to have started with the last firmware update of the Amplifi router (2.7). But may also be related to the 1803 Windows 10 update as this had similar timing. I do have a Mac and it just occurred to me to try to print with it. 802.11k and 802.11v are enabled in the router settings. Nothing else. The printer is 2.4 GHz only. Interestingly, I see it connecting to the furthest Mesh Point (set for 2.4 GHz only) instead of connecting to the router, which it is very near. Is there a way to force it to connect to the router?


  • Pausing the furthest MP, which is what it was connecting to, seems to have resolved. It is now connecting directly with the router and printing starts immediately as before. Suggestions for forcing it to connect just to the router? It sits in the same room as the router.


  • @jamie-pearson Hi Jamie! You can create an additional SSID on any mesh node (including the router), and have your client connect directly to that.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.