Mesh Network VERY slow (75% drop), been told this is expected?

  • I've just brought one of these units and after testing it I have found that between a test of a file upload on the main unit and an upload on a mesh extender there is a 75% difference. What is even more interesting is that the OnlineChat staff have said this is expected.

    My setup is
    Main unit in living room running the same SSID on 2.4Ghz and 5Ghz bands
    The extender is in the far bedroom (small house) and is reporting 88% signal strength, backhaul is 5Ghz

    The test is a simple laptop that uploads a 400meg file on the 5Ghz band.

    In the lounge by the main unit I get approx. 20 MBps

    In the Bedroom when on the Mesh extender I get 5MBps (I get more turning the Mesh extender off)

    I can't understand why the speed drop is so much when the Signal strength is report 88%

    According to the specs the Mesh Extenders do full range ac so 40 Mpbs seems very low.

    Do other people see the same results I'm getting?

  • @john-ward 5 Mbps is too low. Let's try to debug!

    1. Keep your test devices connected after the test.
    2. Run Amplifi app, collect support info file and send it to me (😞

    App -> Router icon -> Support info

    1. Send me MAC or IP addresses of your test devices together with support info file - I need these pieces of information to identify your test devices in support info.

  • @john-ward That's not normal. We get better speed between two mesh points 1.6 km from each other than you get in the same room with the router, so something's wrong.

  • Hi guys, I've just restarted 🙂 just before I saw this as I've been doing other things over the last day.
    I've been keeping track of changes I've been doing over the last days as this problem occurs form 1 to 24 hours after a reboot.
    I thought I could have a bad mesh point so unplug one and it seemed ok but tonight it went bad again, reboot and fine again.
    My unit is only a couple of days old so wasn't going to try firmware yet in case I returned it but the supplier has said that is fine so signed up for the beta today to see if it is a software issue.

    I have a full list of speeds and location speeds that I did 2 nights ago but is on another computer at work so will provide that tomorrow.

    I have responded to Todd post as it seemed the same issue as mine and said happy to manually apply patches.

    Last changes I made before it became unstable (4 hours ago) was to enable both 802.11k and 802.11v.

    As this was the last change before it became unstable I have reversed them out and rebooted the unit.

    At this stage I still have one Mesh unit unplugged to reduce the amount of changes I have made.

    Dmitrijs I've sent you the support logs mac of the router is f0:9f:c2:d9:d5:80

  • Just in case any one else reads this 🙂
    The support team has reached out and we are trying 2.8 firmware.

  • Having similiar issues - about to return my Amplifi HD setup back to Amazon. Any chance I can get the 2.8 firmware?

  • @amplifi-hd I have just registered your devices on the beta program. Please check your system for updates.

    Please let us know how the beta firmware impacts your system so we can work on improving this with you.

    Thank you!

  • @amplifi-hd Can you give us more details about what you're experiencing? A firmware update won't solve mesh node positioning issues, or a very bad radio environment.

  • @UBNT-Brett - thanks....will give the beta a go later this evening once everyone is off the network.
    @UBNT-Gunars - I have two mesh nodes connected via 2.4GHz. One shows 100% connectivity, the best I can get with the other one is 84%. But even one room over from the main router by speeds never go over 100mb download (I have 300/35mb from Optimum/Altice One). Even in the same room it's closer to 200mb when on 5g. With the Optimum re-branded D-Link I get close to 300 in many spots in my house, but with the Amplifi I'm lucky if it's over 300 in any other room than the den where the main router is.

    I've setup separate SSID's on the mesh nodes, but connecting to those doesn't improve things, even if I'm 4 feet from the mesh node. Currently running 2.7.1, will try the 2.8.x.x beta later.

    @UBNT-Brett - for some reason only the Mesh nodes saw the updates, the main router doesn't show any pending updates, so it's still at 2.7.1. I upgraded the mesh nodes, but nothing for the main router. Thanks. Perhaps I provided the wrong MAC address, let me re-submit the Google Forms.

  • @dorqus Thank you for the quick response. I verified the MAC and it was the same as the first submission. Try these steps to have the device pull the update.

    • Launch the AmpliFi application>>Tap the router icon>>Select firmware update
    • If that doesn't prompt for an update try power cycling the router

    If it still doesn't prompt for the update, follow the manual update steps I will DM you.

    Or if you would like the router will search for an update at specific time intervals all on its own, so you can also wait for the prompt the next time it searches for an update.

  • @dorqus Also, to get true results we will need all device on the same FW Once its been updated please try to manually configure the mesh points to us 5GHz
    Launch the AmpliFi application>>Tap the mesh point icon>> Select mesh point band and change to 5GHz

    Let me know what connection percentage you receive running 5GHz, if its extremely low we may want to relocate the mesh point. I have found that a good mid way point between your dead zones and the router while maintaining >80% signal strength usually works best.

  • OK so I moved one of the mesh points, and both are configured @ 5G now. One is connected at 100%, the other at around 90%. I tried the steps you listed, not seeing any updates for the router - I power cycled it, and also tried picture -> update, no dice, it's still at 2.7.1
    I have one room that's a dead zone, and it's not much better after relocating the mesh point. I had a competitors product, and was getting 300mb all over the house - until the mesh device lost it's config, at which point I returned it. I don't feel that this Amplifi System is much of an improvement over my Optimum provided re-branded D-Link to be honest. I've spent more time mucking with WiFi then I ever did before.
    I'd like to get it working, but I'm traveling for work on and off next week, and I have until August 26th to request a return with Amazon. 😞
    I will say that you have been extremely helpful and I really appreciate it!

    EDIT: Was able to manually upgrade the router to 2.8.0rc4. Will do some more testing, but it's almost midnight and I need to get some rest...

  • @dorqus how have you positioned your mesh points? They are quite directional, with most of the gain at the front. I usually place them on outside walls, facing the router and all the clients. It should be possible to switch them to 5 GHz backhaul too.

  • @ubnt-gunars - Both meshpoints are on 5 GHz backhaul now. I don't have a ton of options for mounting due to outlet availability and layout of my house. Speedtests in some rooms are OK, but in the room where I really need the access It's still less then 50mb. I am not able to re-locate the router, or setup wired backhaul either - the room that really needs the WiFi is over a slab and there's no option to run cables without doing major work which we're not looking to do anytime soon.

  • @dorqus could you make a simple drawing of your house and where the AmpliFi devices are? You can send it in a private chat.

Log in to reply