Mesh Point Speed Issue


  • Hi guys

    I’m noticing that when connected to a mesh point my speed is around 50% slower compared to when I’m connected to either of the routers, is this expected behaviour as I’m wondering if my setup is corrrct?

    Would it be possible to examine the logs to see what is going on and if I have everything setup optimally?


  • I created a support ticket who advised to create a separate SSID with 5GHZ which helped as I’m getting more or less full speed, what I have noticed is that in the room I’m testing I have a mesh point however my device always connects to the main router (have additional router via Ethernet) even tho router steering is not enabled, would have thought the mesh point would have been the stronger connection especially as it’s in the same room.

    Also i have band steering enabled so would that not produce the same results as creating a separate SSID and forcing 5Ghz. I made sure with each test that my device was connected to 5Ghz, only factor I have noticed is that when connected to the mesh point I see the 50% lower speeds, connected to either router produces full speed.

    I also noticed that when connected to the SSID with only 5GHZ my device only connects to the main router even tho there is a mesh point or additional router closer, is this normal?


  • Hello @Daniel-Bertolone-0
    Thanks for reaching out! I'm glad that our support was able to help you create that additional SSID. With band steering enabled, the router and the mesh points try their best to help your wireless clients use the 5ghz band over the 2.4.

    In regards to your device choosing the main router to connect to over the mesh point, this can be the case if the mesh point and the main router are within reasonable proximity to each other. To better utilize your mesh point, we recommend playing around with the location of your mesh point. For example, unplug said mesh point, move it 10 ft farther, left or right, etc.
    (Tip: Make sure the mesh point is still communicating at a high percentage on a 5ghz backhaul band for best performance. This can be determined in our smartphone app.)

    If you have any additional questions about these above steps, reach out to us on our support channels HERE: help.amplifi.com Feel free to ask for me personally if you call in to our phone channel and I will gladly help you 🙂


  • What I find strange is that when connected to the default ssid with both bands enabled my device will roam between the mesh points & routers as expected.

    When connected to the separate ssid my device will only connect to the main router which is at the rear of my home, I have even stood in front of the secondary router which is upstairs at the the front of the house yet I’m still connected to the main router downstairs.

    Also is it normal when connected to to a mesh point that my speeds should be around 50% slower as I read this can happen is the mesh points are hopping off each other instead of connecting to the router?


  • Hi @daniel-bertolone-0 - “Also is it normal when connected to to a mesh point that my speeds should be around 50% slower as I read this can happen is the mesh points are hopping off each other instead of connecting to the router?”

    I would say yes if your client device is able to heavily utilize the bandwidth of the mesh point.

    The AmpliFi mesh points do not have dedicated backhaul radios.

    So if both your client device and the backhaul are on the same band, they have to share the maximum available bandwidth, potentially cutting it in half.

    That is why wired backhaul can be a very beneficial option if available.

    But it depends on your environment and client device capabilities.

    If your client devices are single stream, then wireless backhaul should be sufficient.


  • Thanks for the reply Derek, I do have wired backhaul on my upstairs router which if connected I see full speeds, it’s the wireless mesh points that I see a reduction in speed.

    Also as I mentioned when configuring a dedicated SSID with 5GHz my device will only connect to the main router located downstairs even if I’m stood infornt if the upstairs wired router, is this normal behaviour as I would have expected my device to roam to the strongest AP?


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.