Latest Update - Garage Door Opener is STILL Broken


  • OK, I am about to give up on this.

    I have had a problem with Amplifi going back several revs. It was working fine and then somewhere along the way, my Chamberlain My-Q garage door (wi-fi connected).

    When connected to Amplifi, about every 5-10 minutes, it drops and reconnects. Which means that I have to kill and relaunch the app. Sometimes it works, sometimes it doesn't. Total pain.

    Amplifi has been working with me for months, but then went M.I.A. The newest rev is out, I updated, and it still is broken. If I use separate SSIDs the problem goes away, but that means 4 SSIDs on my network (2 HD routers). Not acceptable.

    I am running an old, cheap D-Link in the meantime for the garage door opener, and the opener works flawlessly. But I am tiring of having to run 2 networks because Amplifi can't get its act together.

    Again tried running on the main network and the guest network. No dice. After 15 minutes I had 3 resets. Switched back to D-Link, 3 days and not a single lost connection.

    Clearly there is still an issue here and it needs to be dealt with.


  • @john-fruehe I have a Chamberlain My-Q system as well but I am using the MyQ Home Bridge that is compatible with Apple Homekit. My HD router is located in the living room and the Home bridge is in the garage, I have no issue with any connection. Its about 40-50 feet away.


  • Try enabling "Separate WiFi SSID". I had very similar issues with my smart sprinkler controller in the garage, and enabling this setting seems to have fixed it. This will cause the router to advertise a number of additional SSID's, but you don't need to use them. Just enabling the setting fixed the issue for me.


  • I did that and it solves the problem. But then I end up with 4SSIDs and a wife that goes crazy continually asking “which one am I supposed to be using.”
    Also you lose wireless handoff which was the whole reason for a mesh system.


  • @chris-shouts said in Latest Update - Garage Door Opener is STILL Broken:

    Try enabling "Separate WiFi SSID". I had very similar issues with my smart sprinkler controller in the garage, and enabling this setting seems to have fixed it. This will cause the router to advertise a number of additional SSID's, but you don't need to use them. Just enabling the setting fixed the issue for me.

    @Chris-Shouts: Are you saying that even with the additional SSIDs, the normal SSIDs are still meshed? I don't have any experience with the "Separate SSID" feature but I thought this would kill the mesh experience with AmpliFi. Am I wrong?


  • @shane-milton Yes, the mesh feature is retained for the original SSID. Worth trying; just turn the setting on and ignore the additional SSID's being broadcast. If it works, no more disconnects and you just have to remember to ignore the extra SSID's. If not, you can just turn it off again with no harm done.

    Edit: I should mention that I'm not very happy with this situation, but it does make the Amplifi liveable for me. Also turned off Band Steering and Router Steering, in case that makes a difference for you. In my case, the disconnects were not actual disconnects. The devices would still appear to be connected, but they could not actually send or receive any data (or were throttled to the point of being literally unusable).


  • @chris-shouts
    Hi Chris. Thanks for the help. I have tried enabling "Separate WiFi SSID". I am still having ongoing issues. If my cell phone connects to one of the mesh points and I walk back towards the main router, I still get a period of time where the device disconnects from the mesh point, connects to LTE and then eventually reconnects to the main router. If I walk from the main router to one of the mesh points, the roaming happens smoothly. I also found, like you stated, that everything seems to work better when band steering and router steering are switched off. I changed the DNS server to 8.8.8.8. This resolved the issue where browsers "froze" for now. I agree that I can at least use the system in this way, but I do not think this is acceptable and I hope there is some fix coming soon.


  • I would also like some clarification about "mesh" and "handoffs".

    Some people refer to mesh as the interconnect between the AP devices (routers and antennas) and some people refer to mesh as the connections that the clients make (i.e. any devices finds the closest connection at any time.)

    When I say mesh not working I am talking about the handoff. When I had separate SSIDs devices would not gravitate to the strongest signal as they moved around he house. They were "sticky".

    Enabling the guest network was no better, it just added more SSIDs. Additionally, having multiple SSIDs that you cannot name individually does not help.


  • @john-fruehe Not sure but for ease-of-use, can't you rename the unused SSID's to something like "NotThisONE" or equivalent? 🙂


  • Out of curiosity, do any of you have virtual machines on your network? I found that network stability improves greatly when I shut down my VMs.


  • The only VMs that I have are on my Macs via Parallels. I only fire them up occasionally to run Windows programs not available on the Mac (like quicken). They are only active for a few minutes and have never been active during network testing.


  • I spent an extensive amount of time documenting, detailing and working with Amplifi support.

    Last contact was more than 3 days ago. Nor have they responded to email inquiries. Pretty sure they either cannot fix this or don't care. Either way, not happy with how this is working out.


  • @john-fruehe

    Are you on the latest beta firmware ?


  • @john-fruehe Hi John, we're considering implementing a feature to create additional networks on specific mesh points or routers. It will have the same effect as the separate SSIDs, except it won't interfere with the main network, and you'll be able to name it, or hide it altogether.


  • @ubnt-gunars I would love that. I hate running extra APs simply because AMPLIFI can’t fix this problem.


  • @peter-farrar no, I do not run beta firmware, I don’t have patience these days to deal with that stuff


  • Well, roughly 6 months and still no answer. But I have found this: if you reboot enough and get everything on different channels, we seem to have it stable - for now.

    But here is the problem: You can't manually manage the bands of the devices nor the channels (other than the base). My gut says that this device, while sitting in one location and never moving is being "passed" between the different devices on the network. With 4 devices and only 3 non-overlapping channels, you end up with this situation. But with no way to manually manage, there is no way to troubleshoot and solve the issue.

    I would love to see the following capabilities:

    1. The ability to turn either band off on any device
    2. The ability to hard code the channel on any device
    3. The ability to set up a guest WiFi on only one device (and preferably one band) to use as an IoT gateway.

    As of now, while this is working, it is still not fixed permanently - all it takes is one channel change to drop me back into the world of not working again.

    As I told them early on, this is their problem, they own it. While they are very friendly when they respond and appear to want to fix it, the fix is not coming and I am not sure that they will ever fix it because this goes against the idea of just letting the system manage everything automatically. They believe "the system knows best" but there are times when it does not. And there is no way to recover from that other than luck.


  • @john-fruehe Hi John! This is what we're planning to do https://community.amplifi.com/post/1776. Let me know if this would work for you.


  • Well, this post might be pouring salt into your wound; but, here we go...

    I just started running Amplifi HD in my home (I went from an Asus RT-AC5300) and my Chamberlain My-Q garage door works perfectly. I had a NIGHTMARE of a time with it using my Asus router with current firmware. Getting it to connect to the Asus router took tinkering with the settings every time I rebooted the router. It was just awful. It wasn't Captain Pain, it was Major Pain!

    So, I was anxious to try the Amplifi HD router and see how it worked with that. As soon as the network came up, it connected and is working perfectly. I couldn't be happier.

    My Amplifi HD router is closer to the garage door than any of the meshpoints (so I'm assuming it is connected via the router???). I'm wondering how yours is set up?

    I'm assuming you have tried forcing the garage door to opener to go through the reconnection process (you press the button on it 3 times slowly)? I would erase the network settings, once connected, and then connect to Amplifi. I've done this soooooooooooo many times with my Asus router that I could do it in my sleep.


  • I'm waiting for my Amplifi to turn up tomorrow and replace my Asus RT-AC3200 Router which decides to go to 100% CPU every couple of days....

    Anyway one of the things I had to do with my AC3200 was turn off Band Steering for devices such as my Nest Protects, Ring Stick Up Cam, HP Printer, Wileyfox Swift 2 and a few other devices. That's because these are all only have 2.4GHz radios and the way the AC3200 was 'band steering' was disassociating the devices on the 2.4GHz radio to try and force them onto the 5GHz radios which they were not capable of connecting to so eventually they'd just give up and wouldn't connect at all.

    Does the Chamberlain My-Q only have a 2.4GHz radio?

    The first thing I did was turn off Band Steering, however it meant that on the AC3200 none of my devices that were capable of 802.11ac would ever connect at that rate because there was always a stronger 2.4GHz signal.

    In the end, I had to configure an SSID with 2.4GHz and 5GHz with no band steering and a separate SSID with 5GHz 802.11ac only for those devices that do support it. I'm hoping that I won't have to do the same with the Amplifi, because it sounds like that currently isn't possible!


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.