Amplifi Firmware v2.8.5

  • Hi

    I just upgraded the firmware of my Amplifi HD with 2 Mesh points from v2.7.1 to v2.8.5.

    There must something wrong with wireless/downstream.
    It dropped to 1/3 of the previous wireless speed (iPhone/Apple TV/iPad Pro).

    Before all my wireless devices hit the max. 300 downstream within 10 feet from the Amplifi.
    Now all the devices are around 100 even 1 feet from the Amplifi.
    There is no problem with the upstream.

    I made the test with a cable and got the max. 300 downstream every time.
    My internet speed is 300/60.

    I would like to downgrade to the previous firmware (v2.7.1) if it's possible or just a fix to this firmware.

    Otherwise I love the Amplifi. Normally it works like a charm.

    Others with this problem?


    Kim Tranberg

  • I too had the same thing but had to travel abroad for work so would have liked more time to test...

  • We have seen the same issues, previously we would see around 150-170mbps when connected to a mesh point, since the upgrade were are seeing a mixture of results with speeds usually around 50-80mbps

    When hardwired we see full 200mbps

  • This post is deleted!

  • I'm having the same issues. I'm seeing a major decrease in speed since the update. Seems to fluctuate big time.

  • Hi

    I’m in dialog with the helpdesk where we are trying to solve the problem.

    When we have a result I will post it here.

    They are very helpful and quick with the answers.

  • Same issues here. Connectivity and speeds are bad since update. Lets fix this people. Thanks

  • Hi

    Everybody who has the problem try this:



    My problem is that I don't have the last of the two settings (A-MSDU for wireless backbone) under my Advanced Settings 😞
    The first setting helped a little but not enough and the the speed is still very unstable.

    Helpdesk is still working on the problem.


  • First, where were these new settings documented? Ah! I know -- nowhere. For some reason, these deeply technical products are documented like they were a calculator app: hardly at all. How would one know to turn these settings on (or what they do) in a firmware update whose release notes are bullet points?

    Second, I happened to find the setting for wireless client during my own troubleshooting efforts and turned it on. It did nothing to solve the poor throughput and disconnects with 2.8.5. My router is in bridge mode, so it's clearly a WiFi issue since DHCP and routing are turned off. Unsurprisingly, ubnt shipped a release that can't do the basic thing one has a WiFi access point for: provide reliable WiFi.

    Falling back isn't pretty either. The fallback instructions were written by the same dude who documented the calculator app. I'm lucky I made it back to 2.7.1 on the router and the two mesh points I have.

    I'm staying there until it's clear ubnt fixes WiFi in some release beyond 2.8.5.

  • Wow...that’s exactly what I was looking for on the 2.8.5 firmware update..sorry you had to start over to get back to 2.7.1

    Their documentation is the absolute worst. We need the engineers who built the firmware to also write the material in technical detail how the new features work. I’m afraid to move off 2.7.1 as well cause my network runs great so why they keep messing with a good thing is beyond me...oh make it even better....only so much you can do to a WiFi network...we want a network to run like power...never go down...always there...perform well all the time!...what’s so hard about that? LOL!

  • @kim-tranberg let’s face it AMPLIFI doesn’t test...they use us to test so they can save money in dev testing....for the amount of money this mesh network costs better quality testing should be done before distributing out to the consumer.

  • @rich-sammon said in Amplifi Firmware v2.8.5:

    so why they keep messing with a good thing is beyond me...

    I think the issue has been what is stable for you is very much NOT stable for others, and vice-versa
    In my experience the AmpliFi firmware has degraded every release since 2.2.2 and especially since 2.4.3, which was intended to patch security issues, so hard to ignore

    For me, the best recent release had been 2.6.3, and I would not have upgraded had my Teleports not spontaneously failed on their own without any changes to the network

    So some of us are now in a constant search for stability and fixes for problems, and losing hope rapidly
    For me 2.7.0 and 2.7.1 were pretty bad
    2.8.5 seems more stable, but has not fixed my Teleport issues, although Teleport remains on 2.7.1 / Beta 2.8.0

    For us they are not 'messing with a good thing' but trying to fix a very very bad thing...

  • Hi all,

    I have been in touch with the support the last 1,5 weeks and they have solved the problem with speed.
    Have tested the v2.8.6-beta and my speed is back to "normal" and even a little better as it was with v2.7.1.

    I don't know when they will release v2.8.6 but it works in my case anyway 🙂

    When you get the new firmware I can recommend that you use a high bandwidth and a high canal on the 5 ghz.
    In my case I got a super result using bandwidth 80 and canal 48 (which is the highest in Denmark). Try using 149 instead in US.

    Have a good day 🙂


  • Thanks for the update Kim, looking forward to the release

  • Hi Kim,
    Just out of curiosity, did you test the speed on Apple mobile devices (iPhones or iPads)? When i installed v2.8.5 my only speed issues seemed to be with my mobile Apple devices (my download speed was literally half of what it had been on 2.7.1 when linked to the mesh point or directly to the router), everything else i tested was around the same as it had been on 2.7.1.

  • @christopher-tex: I have only Apple devises (iPhone, iPad, AppleTV) and they all dropped to more that the half of the normal speed at 5 GHz.
    I have a Laptop which only can connect to 2,4 GHz and therefore can not reach my max. speed. I think that problem is related to 5 GHz.
    I tested both the connections to the main router and the mech point. Same result. Less than the half speed.
    I had only problem with the downstream.

    Now all the devises run at max. speed again 🙂


  • Hi,

    The new firmware v2.8.6 is released 😊

    Have a good day ☀


  • I’m still seeing 2.8.5 but perhaps tomorrow?

  • Strange. It arrived yesterday here in Denmark.


Log in to reply