Band Steering and not connecting to nearest ap


  • Im using 3 Amplifi Routers with Ethernet backbone and very happy with speed (when connected to nearest AP) and stability.

    Only have two problems.

    1. Band steering is far from perfect. Amplifi router often move the clients from the 5 ghz band to 2.4 even if 5 ghz band still give 5-10x higher speeds. Looks like it only move client based on signal?
      It should be smarter to know which band gives best speed, or possibility to set custom like its on Asus Routers where its possible to choose signal where band switching will happen.

    I know separate 2.4/5 networks is possible but that is the old way of doing it. I think its better to have one SSID so the clients move between bands when needed without disconnecting.

    1. When I move around in the house the clients are often not redirected to the best and nearest AP. Example I go from living room and upstairs and sitting 1-2 meters from the upstairs AP. The client is never moved to the AP. Still hangs on the one downstairs. Speed is then only 150-200mbit. But if I turn off Wifi and on again it connects correctly to the AP upstairs and I get 430-480mbit.

    Running Fw 2.8.5 but this have been a issue since I did setup Amplifi 1 year ago.
    Tried different settings with 802.11k/v on and off. Still same.

    Using Android mobile devices (Galaxy S8, S9) and have a Linux and Windows PC. The problem is most often on the Android devices but happens on my Windows laptop sometimes to.


  • @dennis-horn enable r for roaming also what channel are you using on 5 GHz, I noticed before that it could be a little flaky with channel 40 make sure the device firmware is updated.


  • Same issue as Dennis here.. It seems to prefer 2.4 GHz when I roam to the other unit. How can I enable R for roaming? In my web interface the only options is K and V.


  • Still same issue on latest firmware and new devices since this post (galaxy S10) Is this a router issue or is it a Android problem so it will prefer 2.4 ghz band when 5ghz have less reception even if giving much better speed?

    Before I had a Asus router and I was able to adjust when clients where moved from 5 to 2.4 ghz band based on signal strength.

    @edward-dolezal
    Im using channel 36 and r is enabled.


  • @dennis-horn it's an android thing change it to 44 I believe there are certain channels that work better than others, I noticed my Oppo find X has less problems with band steering the. My galaxy tab S2.

    I have K/V/R enabled try with that.



Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.