Slow WiFi on Spectrum Gigabit


  • Spectrum recently upgraded my connection from their 300 megabit service to their new gigabit service. This entailed them giving me a new modem. On the old modem, the throughput to my AmpliFi was 100% of the bandwidth available to me. With the new modem, bandwidth through my AmpliFi is barely getting me 30 megabits. When I connect to the modem’s built-in WiFi, I get full gigabit speeds. Is there something I need to do to bring everything back up to speed? I tried putting the AmpliFi in bridge mode and that improved the throughput a bit, but it’s still slower than what I had with my old, slower modem. I’m connecting the AmpliFi to the modem in the same way as before, so I don’t understand why it’s much much slower with a much faster modem. Any help would be appreciated.


  • @roland-smash enable hardware nat?


  • @david-gotelli Enabling it didn’t result in a speed increase.


  • Is this the Technicolor modem? Reboot the modem & the amplifi system... Sometimes it takes a dip. I'm also having speed issues with spectrum Gig & my amplifi unit.


  • Rebooting everything hasn’t worked either.


  • @roland-smash next bet would be to maybe change your Ethernet cable from the modem to the router. The latest firmware for amplifi is having speed issues so that may be the case.


  • Do you mean I should replace the Ethernet cable? If so, I’ve already swapped it out a few times. I’ve also connected other devices directly to the Spectrum modem and not experienced any speed issues. Whatever is happening, it’s happening on the AmpliFi and it’s very frustrating. Up until now it’s been stellar.


  • @roland-smash @Tristan-Baptist could be correct about this being an issue with 2.8.5. We are seeing some strange behaviors currently. A few tests that would help us narrow this issue down would be to:

    1.) Change your modem back to the older device (if you still have it) and check performance. If you do not see an increase then chances are its something new with the FW we would need to look into.
    2.) If you no longer have the modem, we can roll back your routers FW and run similar tests like you already have on 2.7.1 and compare results.

    Unfortunately you have two recent changes to your network so we need to try and narrow down which change is causing it first then test possible solutions.
    If you need instructions on how to roll back reach out to me in DM and ill help you out 🙂

    thanks for posting and keeping us in the loop,


  • While the Spectrum technician was still in my home we noticed the degradation on the AmpliFi and we actually did reconnect it to the older modem just to make sure it wasn’t an infrastructure issue with Spectrum. Whatever the issue is, it seems to be with the AmpliFi. I really do hope it’s just the firmware. That at least sounds like a straightforward fix.


  • @roland-smash downgrading should hopefully fix it temporarily. Works for some members.


  • Downgrading fixed it for me. Hallelujah. It was driving me nuts. 🙂


  • we just switched out our spectrum 100mb service with gigabit service. Download speed tests are slower with gigabit than we we had before. Is there an update for AMPLIFI coming out soon?

    The cheapo spectrum router supplied full speed 940mb to a laptop. The AMPLIFI barely topped 100. ¯_(ツ)_/¯


  • Any update on the AMPLIFI-HD with Spectrum’s gigabit service. My old service delivered 100% of its 100mb. The new gigabit on the same everything else won’t even top 100mbs which slower run before.

    Tried the accompanying spectrum WiFi+router and everything was blazing fast. Definitely the problem is the AMPLIFI router.

    Updated to 2.8.9 yesterday and no bueno...still the same situation.

    For reference the modem is a Hitron Technologies MODEL }E31N2V1
    DOCSIS 3.1 eMTA


  • @richard-boone request the 2.6.3 firmware & downgrade it.... It will get you close to the speeds you're looking for. Mine hits about 930mb. When it's in bridge mode theres never a speed drop but for some reason it's not consistent at all while in pure router mode. Hopefully this helps.


  • @richard-boone So things worked for you on 2.6.3 after upgrading to their gigabit service. You updated to 2.8.9 and it was no longer working again. Do I have that correct?

    Can you generate support files from the application while you are on 2.8.9 and experiencing this issue, then I can help you roll back to 2.6.3.
    That will give us something to research because as you can see others are able to achieve gigabit speeds so there is something unique we need to find.

    When sending in the support files please reference this community post so the files are sent to me.


  • @ubnt-brett Anything after 2.6.3 while in router mode in my case shows speed dips (from 940mbs - anything under 219mbs) strictly using ethernet. I tried the 2.9 beta yesterday and after a good hour or 2 of perfect speeds it decreased. While using 2.6.3 it doesn't decrease or slow down at all even after a few users have joined. This might work in his case too...


  • I'm experiencing this same issue using FW 2.8.9 & Spectrum. Recently upgraded my modem from Spectrum, and now getting slower speeds. When I connect directly thru the modem, I' get around 150+MBps. Through ethernet/wifi w/Amplify, max is only 70MBps. Could you please help me downgrade firmware to 2.6.3 or diagnose another solution?


  • Are any of you using more than one ethernet connection when having this slow speed? I've been my device for 2 days now & it's only shown me a drop in speed whenever I have more than one ethernet connection. So far I've been just run one main cat6 cable to my mac & everything else on wifi & I haven't come across a speed dip yet. Hardwire speed to that single ethernet cable constantly above 900mbs... Once i plugged another back in the speed fell below 300mbs. This is using 2.9.1rc1 @UBNT-Brett


  • I’ve been having slow Wi-Fi speeds with my mesh points since these recent few updates as well. Used to have spectrum 100/10, but I updated to the 400/25 package about in July and I’ve noticed speeds changed with the mesh points and became really slow with it and so I did some of the basic stuff( moved the mesh points around, changed the channels etc..). The thing that’s confusing is that speeds have went bad on the mesh points only and on the main router (AmpliFi LR) are okay but nothing I’m supposed to be getting. Wondering if the change of firmware is the cause and seeing it helped people on this thread. Was hoping to get mine changed as well since as of currently it’s on the latest 2.8.9.

    Thanks


  • I've just installed two new Amplifi HD routers that are setup backhaul via ethernet.
    We've also got Charter Spectrum 200MB service. With our old Netgear R6300 we would get over 200MB wired and about 170MB wireless.
    Now I'm lucky to get 20-60MB wired or wireless. It fluctuates speed extremely bad.

    I'm currently on the latest 2.9.2 firmware.

    I did find another person who configured their clients for static IP and that helped. I added my laptop with a static lease and the speeds jumped from 20MB to 150MB wireless. I tried doing the same for my phone but it did not help the speeds any.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.