How do I force one meshpoint to connect to the other?


  • @jose-lopez Moving the router is an experiment, it might not be simple . But will likely yield better results. The more hops you use and the more material between the router and MeshPoints the worse the signal will be. I would recommend at least attempting to move the router to a better location as it is going to give you the best results. Just a software change will not make a difference in the amount of free space path loss and loss for drywall (4 dB), brick walls (8 dB), and concrete walls (10-15 dB). For most deployments a router that is located properly will allow the MeshPoints to connect directly to the router and use a path with the least amount of loss/obstructions, yielding higher overall throughput than a multihop with heavy loss.


  • @UI-JT This is reality.

    0_1580976880538_Captura de pantalla 2020-02-06 a las 9.08.32.png 0_1580976892386_Captura de pantalla 2020-02-06 a las 9.07.43.png

    If you could connect the item two to one by software, and one to the main we avoid these problems.
    It could be forced that the mesh point link to the main or another mesh point with a secondary ssid created for this


  • @UI-JT sorry, I didn’t include any details here, they were in another topic

    I have a mesh point in a basement garage, under a concrete slab. It can see the router and connects to it with 40-50% signal on 2.4 band. It can also see another mesh point that is half way between the router and the garage and sometime chooses to connect to it on 100% signal on 2.4 band (with no changes in settings or the environment). In the latter (multi-hop) scenario the throughput, as measured using iperf3 to a Mac wired to the router, is consistently about 4 times higher and more stable than the direct connection. Apparently the mesh point fails to choose the best throughput and simply prefers “good enough” connection to the router

    Now, for the best location and moving router/mesh points: I already placed them in best spots that are possible without demolishing walls and rebuilding the house. They are placed to provide the best coverage to my wifi devices and to serve my purpose. Moving devices to force them connecting differently is nonsense because they CAN connect perfectly well SOMETIMES in exact same locations where I mend them to be

    Right now I have to mechanically prevent the basement mesh point to hear the router while restarting to force it to prefer multi-hop and provide me with faster and more stable connection

    I’d rather have a software way to do that


  • @jose-lopez This issue would be very easily solved by proper placement.


  • @UI-JT i tried other emplazaments but dont Work fine and in my Home dont have one electric suport where i want.
    Is very easy, You can help us or not, but say change place is not a elegant solution.
    Thx


  • Oh, wow! Today I noticed that my downstairs mesh point decided to trade a direct 100% strong 5GHz link to the router upstairs for 20% super unstable 5 GHz (!) link to the basement mesh point through a concrete slab

    Yes, I wanted them to multi-hop but in the opposite order! 🙂


  • This post is deleted!

  • High density users (apartments, dorms, etc)

    Here's what I've learned after weeks of testing. I have an Edgerouter 10X dual wan setup. For my Wifi backbone I have Amplifi HD router in bridge mode and 3 HD mesh (2 came with the router) have 40+ IoT (bulbs and sensors), 20 2.4 Ghz cameras running. 10 5 Ghz consumer devices. I got 17 cameras running 30 fps 720p. 4 cameras running 15-30 fps 1080p. I have 2 Apple TVs steaming 8Mbps video feeds from the Internet. I run an IT business from home.

    My issue the whole time was interference, and the issue becomes more evident the more you tax the system. Since I live in a layout that is long and narrow, I found this worked for me. 1st update the firmware. Do not go beta on this. Don't turn anything advanced on until you get stable. Don't do router steering or band steering. Dumb it down.

    With a Mac or PC scan for channels that are not in use at each of the spots you want to place mesh points. Mac has wireless diagnostics. I'm sure there is a PC utility equvilent Start with the router spot, then do each mesh point. Find a common channel not in use for both 2.4 Ghz and 5 Ghz. Willing to bet your issue with 2.4 Ghz is interference and 5 Ghz is distance from end point to end point.

    Now, you disconnect all your mesh points. Hook the router in. Disable auto channel selection for 5 Ghz and 2.4 Ghz. Set those frequencies to channels not in use. Start plugging in each mesh point into the network. Check your signal back to the router (Use a lan or internet speed tester for bandwidth analysis).

    If you got 2.4 Ghz stationary devices on network, set up separate Wifi IDs for those. Pair them up. This keeps them locked in place to nearest access point. For 5 Ghz devices, let them roam for now.

    Rinse and repeat for each mesh point. Test then add clients. If the mesh point connects to the router before it piggybacks on the previous mesh point, reboot it using the app or unplug and replug as a work around. Anytime the power goes out or your make reboot required changes to the wifi, you will have to deal with this nagging issue. Reboot the offending mesh point via the app and let it reconnect.

    If everything goes right you'll have a good line of sight to the router and to the internet from the last mesh point. If your signal or bandwidth drops check what time of the day it is. Is there heavy use on it during the day, afternoon, night and from which access point? If you are lucky, move the access points together. I use one HD router, and 3 HD mesh points. The ones that detach are very sensitive to touch and vibration, and they lose connection by a door closing hard nearby.

    I don't know if the router factors the scans of other wifi networks from the reach of the other mesh points. I dont think it was the case in my scenario but I can assure that the main issue was interference.


  • I find this issue extraordinarily frustrating! In my case once i get multi hop working everything is great. The Internet is sable. I get 1 MB per sec download speeds from the far node. At a 2.4 Ghz connection all the nodes are healthy and the multi hop is great. If the power goes out the far node will almost always connect all the way back to the router and the connection between the two always is "poor". The ramification is that the far node is unstable and slow. Things like facetime are horrible in this configuration. I honestly could care less how fast my internet is. Stability is far more important in 99% of cases. If the power goes out or my 2 year old unplugs the far node i have to unplug and replug the nodes in for an hour or 2 and pray to the amplifi gods to get my muliti hop working again. Please please please ... honestly just please provide a configuration override to this algorithmic approach.


  • Still no solution.
    If I knew about this topic, I would never buy Amplify HD. It doesn't suits my needs due to a "smart" algorithm.
    I need serial connection (see AmpliFi user guide),0_1592904322548_need-this.png but the device keeps switching router to center.

    I don't need some unknown theoretical numbers that are important for the algorithm, I need stable usable connection. Usable 20 mbps is much better for me then unstable unusable 90 mbps. From time to time, I have even 3 mbps due to the "smart" algorithm. It is switching the router to the center though the app shows me that mesh point is too far and it tells me "Everything is great".0_1592904383421_it-is-not-great.png It is not!

    It is VERY annoying to have fast and reliable internet connection but not to be able to do video and voice calls in selected part of my house because of this "smart" algorithm.

    I would expect simply drag and drop devices in app to set desired order of my devices. Even the manual switching in devices' settings would be much better than nothing.
    Now we have to manualy trick the algortihm (by turning on/off mesh points in selected order, use foils, cans etc.) to have devices in useful order for a while.


  • @UI-JT I'm having the exact same issue in my house, where the router sits on the ground floor and is cabled to our 100/10Mbit modem. On the floor above is the first mesh point and above that, the second one. I've set the bands to 5GHz to force them to multihop as 5GHz is almost impossible from ground floor to top floor. Still, the network decides to try and connect top floor directly with router and provide approximately 10Mbit on that floor instead of the 70 it should be providing if it would multihop through the first floor.

    I really love your UniFi systems and we have hundreds of UniFi devices deployed at customers' offices, which is basically the no-brainer that made me buy AmpliFi for my home. But I'm starting to doubt that decision now.


  • @kriscoady Can you enable 802.11K and 802.11V as wells as A-MSDU? Then report the results?


  • @UI-JT have enabled all three just now, will keep you posted.


  • @UI-JT I am remote from the Amplifi. Is it possible to enable those features remotely? I don't see them visible anywhere via the App


  • @German-Martinez-0 If you have Teleport access to your home network, you could access the WebUI on a Teleported device.


  • @UI-JT Just received an additional AFI-P-HD that was trying to connect to the main router instead of the mesh point (closer). After upgrading to 3.4.1 and enabling 802.11K + 802.11V, it started working as expected.

    Thanks! 🙂

    alt text

    alt text


  • @Pablo-Alejandro-Fain Thanks for reporting!


  • How and where did you enable enabling 802.11K + 802.11V? I ask because I don't see it in the Android app. Thanks.


  • @marc3434 They are found in the web interface, you can find steps on how to access these settings here: https://help.amplifi.com/hc/en-us/articles/360025766954-Advanced-webUI-Backup-and-Restoration-of-Settings


  • Sadly the logic of mesh points choosing direct router connection over much better multi hop connection did not improve in the latest firmware

    My mesh point automatically connects to the router 2 floors and a concrete slab above. The signal over 2.4 band is around -68-72 dBm and is between “good” and “too far”. Iperf3 measures around 30 mbps with this connection

    If I shield the mesh point with a metal pot lid while it restarts it chooses to connect to another mesh point with “perfect” signal of -45dBm and gets 110 mbps throughput

    I’d love to have a setting in web UI so I can choose for each mesh point to prefer direct, multi-hop or auto choose connection


Log in to reply