Teleport With Mikrotik not working please help


  • I'm having a really hard time getting teleport to work

    First I enabled uPnP in the mikrotik but the teleport still did not work

    so I gave the amplifi a custom port and and opened in the firewall
    now the teleport was able to sync to the amplifi

    but when remote when the amplifi is trying to setup it gets all the way to the last part syncing with the router and fails

    I noticed The Teleport gives itself the same IP as the router gateway is that correct? seems like it would be an IP conflict and I don't see a way to change it

    My Setup Fiber - Mikrotik Router 172.16.x.x EOIP Tunnel to remote office - Charter Modem - Mikrotik 192.168.x.x - Amplifi in bridge mode

    anyone have any ideas how I can get this to work?

    leaving for the Philippines next month and I need this working

    Thanks


  • @timothy-steele A few follow up questions about you setup and i'm sure we can get this working for you. So far your configuration seems correct. You have the port declared in AmpliFi and it opened on your Mikrotik router, you have AmpliFi in bridge mode.

    • Do you have remote access enabled on your AmpliFi application?
    • Do you see the Teleport device in your application, just grayed out because its not connected?
    • What is the LED light on the Teleport device doing when its plugged in? Flashing half circle or flashing full circle?
    • Are you testing the connection with Teleport when you are away from your home network? testing on the same gateway as AmpliFi will result in either an error so be sure to leave the house when testing for best results.
      If you cannot leave, testing on a hotspot will suffice, just remember that your devices will jump back to your home network when Teleport is restarting, and you will have to manually connect back to the Teleport network to finalize the connection.

  • Hello timothy-steele

    I too am "working on" getting my Teleport working using MikroTik (MT).

    My AmpliFi Router is behind my MT. It using a custom port of 2048.

    My port 2048 is coded in the MikroTik like this if you can follow it.

    Router, Firewall, NAT, General, Chain: dstnat, Protocol: 6 (tcp), Dst. Port: 2048 Action: Action: dst-nat, To Address: XXX.XXX.XXX.XXX th X's are your AmpliFi router's IP", To Port: 2048

    So I got everything to work on my AmpliFi Router and Teleport by adding this 2048 port as shown above.

    But it must be in your AmpliFi Router also for the Teleport to use this port 2048. Then everything on your Home Network using your Teleport should be working when your test it. Everything should be green when test it on your "Home Network."

    It all worked for me to this point.

    But when I tried using this Teleport on a "Remote Network" it almost works as I will show below.

    Here is what you will get on your remote Teleport network end. Right up to the point where your will see all of this, as shown below. This is shown in your Teleport Screen remote web screens. When you are trying to connect to your "HOME NETWORK" remotely. You will do all of your Wi-Fi connections, passwords and reconnecting etc. etc. then you will see it all start to come together.

    At the last Teleport screen you will see if start checking everything off like:

    1. Local Connection (Green check mark)
    2. Internet (Green check mark)
    3. AmpliFi Router (Green check mark)
    4. Home Network (A Nice, BIG, RED X )

    I'm missing something to get this ( Nice Big RED X ). I'm betting it's in MikroTik but I don't know what it is just yet.

    /rk


  • @russell-kuck @UBNT-Brett

    I'm at the same point as @Russell-Kuck when I go to a remote site everything works but when it gets to the last home network I get a nice big red X
    Error
    Could not create connection (Router is not responding)

    teleport flashes full blue when I plug it in

    amplifi is in bridge mode with remote access enabled

    the teleport is grayed not connected but I was able to get it to sync

    I have a slight fear it synced to one of the other Amplifi HD's in my account but I don't see how that would be possible as this was a teleport kit

    I'm running on custom port 1050 as upnp is not working

    I only see a custom port setting for the Amplifi not the teleport its self

    is there an IP range to allow for UBNT servers? maybe that is the missing key?

    I'm pretty shocked at how hard this thing is to set-up


  • @UBNT-Brett still nothing on this?


  • @timothy-steele I do not have an update for you yet. Is this something you would be willing to call into our support channel so we can go through this with you? Its a unique case and though I feel like we might be able to make progress through this forum I would really like to see a resolution sooner rather than later since you are leaving on a trip soon.


  • Old topic but a new customer and I also have a similar setup using the Amplifi Alien I'm bridge mode with a Mikrotik router (no Upnp). What ports are needed to forward to the Amplifi device? I don't see any configuration for the Teleport listening port that is being used.


  • Hi @vincent-ngo - sounds similar to what some other users were experiencing in bridge mode behind EdgeRouters recently in Teleport also works when in Bridge Mode?

    You might want to post in that thread and see if @UI-Brett or @UI-Karlis have on update on what's needed to get it working


  • @vincent-ngo This topic was related to the Teleport hardware, which currently is not compatible with AmpliFi Alien. Are you using the Teleport hardware, Teleport app or Teleport router to router feature?


  • @ui-brett Teleport app using the Alien Router in bridge mode.


  • @vincent-ngo With the new Alien router, are you seeing the same issue with the Teleport app? If so, could you generate support files for me after a failed connection?