Amazon. Co. Uk, twitter and few other site not loading


  • Hi

    I am having issues when trying to access some websites. In particular, amazon.Co.Uk and twitter don't load when I try accessing them on my phone. I don't have this issue when I use my mobile providers Internet connection and it always happens when connecting WiFi via amplifi hd. Any ideas?

    Thanks


  • @wasim-akbar Check your DNS settings, it sounds like it may be an issue with your modem or service provider. AmpliFi does not block any specific websites.


  • I have set the DNS to my isp provider, in this case BT, and I have also tried the open DNS settings. The issue keeps occurring on both.


  • @wasim-akbar Is this only occurring on your mobile phone or other devices connected to the AmpliFi network as well?


  • I've having the same issue with Twitter and Amazon US on my Pixel 3 XL. I'm on a gigabit fiber connection with the Amplifi HD connected to the ONT with PPPoE. I've tried both the ISP DNS and Google Open DNS. Same issue.

    I do not have the issue with my laptop or PC however.


  • I'm still having this issue. My Chromebook and PC work with these sites, but my Android phone does not. Some of the sites (and their corresponding apps) I've found that do not load are: Twitter, Amazon, Zillow, Android Central.

    I've tried several DNS servers. I've tried toggling Hardware NAT on and off, but nothing seems to work. I'm guessing this is a DNS or Firewall issue, but I can't seem to pinpoint the problem. Any ideas would be helpful.


  • @steve-secor Have you tried resetting your phones network settings and clearing any cookies or cache saved?


  • @ubnt-jt Yep. I tried a factory reset is well.

    I've found this issue only happens with my Pixel 3 XL and my wife's Pixel 3. My PC, Chromebooks, iPad and Pixel C tablet work fine. I think it is a problem specific to either Android 9 or The Pixel 3.

    I've found a few resources on Reddit and XDA talking about this problem so I don't think it's AmpliFi specific. It has something to do with PPPoE, MTU and fragmented packets. Someone posted router settings to fix the problem, but I don't believe the AmpliFi has those user facing options, but perhaps the info could be useful to the engineers. Link below.

    XDA Post

    I'm happy to do any testing if I can help in any way.

    Thanks!


  • @steve-secor Can you post the settings?


  • @ubnt-jt These were the custom iptable settings that were posted:

    iptables -t mangle -A FORWARD -i pppoe-wan -p tcp -m tcp --tcp-flags SYN,RST SYN -j TCPMSS --clamp-mss-to-pmtu

    Others using a Ubiquiti Edge Router were able to use the TCP MSS clamping wizard and set that to 1452.


  • This post is deleted!

  • @steve-secor Pixel 3 users with PPPoE connection are having problems accessing resources like Netflix also with other router makes. It seems that Google is informed about issues and might fix it with the February software update.


  • @ubnt-jt Thanks for the info. I guess I'll just have to wait a few more weeks.


  • @ubnt-jt I just installed the February update on my Pixel 3 XL and it did not fix the problem. Is there anything in the Amplifi settings that can help resolve this problem like a user definable MTU?


  • @steve-secor We currently don't have any configuration settings for MTU size.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.