Wifi latency every 18-21 hours and a reboot of the ampli router fixes it.

  • I purchased the Amplifi in August of this year and it's worked great until about November's Firmware update. Since about November's firmware update, I've been noticing this problem where the wifi latency (from devices to the router) changes from an average about about 10-20ms to 200ms+. This issue occurred every 3 days but lately it is about every 18-21 hours after the last reboot of the router. Ethernet attached devices do not see the latency. Rebooting the router fixes it every time.

    When this issue occurs, I have tried to swap the wifi channels via the app in an effort to narrow down the cause and rule out channel noise. I have scanned my house to confirm there isn't any channel noise and the channels the amplifi is selecting is the best channel ( matches the least used channel; which is often times completely free). The only fix seems to be either to reboot the router using the app ( which can take a few minutes as it finally connects to the router's admin interface), or pulling the power cord and plugging it back in. As soon as the router boots up everything returns to normal wifi latency.

    Has anyone else experience this issue or have any further suggestions of things to try to help narrow the issue down?

  • @scott-benjamin How are you testing the latency?

  • I am running PeakHour4 on my Macbook, it ping's the router's private IP and the router's public IP every second and records latency and then graphs it for me.

  • @scott-benjamin Can you PM the ping graph?

  • @ubnt-jt I have the same issue. What can I do to make this work?

  • @fredrik-morris-michaelsen You might be facing some interference, if you have a spectrum analyzer check for channels with the least congestion and operate the AmpliFi on the best channel.

  • I'm having the same issue the router is brand new and every 10 to 60 seconds the latency goes to upper 100 and sometimes higher causing my games to freeze. switching back to my apple extreme the problem is resolved any fix on this?

Log in to reply