IPhones not staying connected


  • We have multiple iPhones that will not stay connected to our Amplifi system. However, when they do get disconnected from the network, they then are able to connect to the guest wifi network, but refuse to connect to the main network. Any ideas? This has been happening on and off since the system was installed, and seems to be getting worse.


  • Hi @aj-brown - are you iPhones running the latest iOS?

    Are you on the latest AmpliFi firmware release?

    How many mesh points do you have?

    Do you have Band Steering on or off?

    Do you have Router Steering on or off?

    Do you have 802.11k, 802.11v or A-MSDU enabled in the web UI?

    If you turn off the WiFi on your iPhone and then back on again, do you see you main network SSID ‘bounce’ where it tries to connect for a split second and then disconnects again?

    Can you see you main network SSID in the available WiFI list?

    If it is in the list, have you tried to “Forget This Network” and then select again, re-entering the password?

    What happens if you turn off the guest network?

    Have you tried “Forget This Network” for the guest SSID?

    Sorry for all of the questions, but it helps to know your setup and what you have tried


  • Hi, my iPhone XS temporarily loses the connection to AmpliFi in standby mode and switches to LTE. That happens only sometimes, but it is still very annoying. With other Apple devices I do not have this problem.
    The iPhone XS has the latest iOS (12.1.4) and AmpliFi the latest firmware (2.9.3). I have two mesh points and Band Steering & Router Steering is off.

    2.4 GHz: channel 6 (bandwidth 20 MHz)
    5 GHz: channel 48 (bandwidth 40 MHz)

    Enabled in the Web UI:
    Bypass DNS cache, 802.11k and 802.11v.
    "Forget this network" and "reset network settings" unfortunately did not help.

    Only a router restart brings improvement for a few days.

    Could a setting cause the problems? I am grateful for every solution.


  • Derek,

    Thanks for the reply. I'll check your questions and get back to you.


  • @markus-schmitt are they any WiFi settings like android to turn off WiFi when in standby mode?


  • Hi, @edward-dolezal – no, in iOS there are no such settings. My other iOS devices are permanently connected.


  • If I create an additional 5 GHz network, the iPhone XS remains connected without any problems.
    In mesh mode I unfortunately have disconnections after waking up from standby or rarely even during use.


  • @markus-schmitt question have you tried a different said name instead might work.


  • @edward-dolezal you mean a new SSID name for the mesh network?
    No, as SSID I have from the beginning "AmpliFi".
    The connection problems have started with the iPhone XS...
    Before, I had an iPhone 7, which had no connection problems.


  • @markus-schmitt I can confirm - I previously had no issues with my 8 Plus, however, my XR frequently refuses to do anything even though it’s connected to the network. Cycling Wifi on the phone fixes it. Seems to mostly happen when first connecting to the network (getting home.) Best guess is that the garage is right between the BS and the mesh point, and something breaks while roaming between as I settle in.


  • @chris-dunlop Nice, that I am not alone with the problem.
    What you have described, that the iPhone does not connect to the network, when you come home, I had already, but rarely.
    Setting DNS to 8.8.8.8 and 8.8.4.4 has brought some improvement and disconnections have become less but unfortunately not complete.


  • Have you tried changing channels? Maybe there is some interference causing disconnections and the iPhone sees the guest and connects because guest has no interference.


  • @markus-schmitt I wonder if bypassing DNS caching may improve your situation? I might give it a shot this weekend.


  • @ubnt-jt Yes, I have already experimented with the channels. To search for non-overlapping channels I use the onboard OS X Scanning App. Do you have more tips or tools to find the perfect channels? With AmpliFi you can not do a wifi scan, right?


  • @chris-dunlop I tried so many settings, in the hope of getting better performance. I had the impression that "bypass DNS cache" has brought some improvement.


  • @markus-schmitt If you perform a factory reset the AmpliFi will scan for the best channels and automatically choose the best channels.


  • @ubnt-jt If I activate automatic channel selection in the settings, it probably has the same effect?


  • @markus-schmitt No you need to perform the factory reset to trigger a new scan.


  • @ubnt-jt Out of curiosity what’s the purpose of that toggle then? If the unit only does a new channel scan after a factory reset, it seems the only thing it does is prevent the user from selecting a channel?


  • @ubnt-jt It's not satisfactory that factory reset is the only way to get a network scan done by AmpliFi.
    But in order to get my problem solved, I did a factory reset last night.
    AmpliFi has selected the following channels: 2.4 GHz: Channel 1 and 5 GHz: Channel 36.
    Since all settings are now reset, I would like to know what settings the AmpliFi team recommends. All my older iOS devices are running smoothly.
    My new iPhone XS has connection problems, mostly with the automatic change from 5 GHz to 2.4 GHz or from 2.4 GHz to 5 GHz, which I was able to observe last. At this band change, it occasionally connects for a short moment (half second) with 3G or LTE and sometimes it stays connected to 3G or LTE instead of AmpliFi.
    Which "normal" settings could help here? Band Steering & Router Steering "Off"?
    Which "advanced" settings should I activate? After reset, only "A-MSDU for wireless backbone" is enabled.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.