IPhones not staying connected


  • @markus-schmitt router steering keeps devices connected to the router and not to the mesh points band steering allows for a nudge to capable devices to hit the 5ghz band
    I'd leave the back bone setting enabled.


  • @chris-dunlop have you tested it with band steering off if it's on sometimes devices might auto connect to 5ghz.


  • If it's a DNS issue then the amplifi should ping back the ISP DNS not the servers it pings currently the google ones.


  • Hi @markus-schmitt - you might want to sign up for the 2.9.4rc1 beta firmware and see if it solves your issue

    There is a roll back option in the web ui in case it creates other problems

    Note that A-MDSU has been reported as not working properly with Ethernet backhaul

    Other things to consider - are your mesh points too close together?
    Depending on your environment 5GHz might be ok but 2.4GHz too close

    Maybe unplug the wired backhaul and see how roaming behaves

    Create unique 5Ghz only SSIDs on the mesh points, forget the main SSID, and see how roaming behaves

    Try the same with 2.4GHz

    Last resort - try to disable any sources of potential interference / noise - essentially power down the entire environment except your internet and WiFi and go through manual channel selections

    On the phone - Settings - General - Reset - Reset Network Connections to try and clear it out if it isn’t too much trouble to re-enable the networks you use, but can be a pain if you have a lot of them, so consider carefully


  • @edward-dolezal Before the reset Band & Router Steering was deactivated. I adjust that again.


  • @edward-dolezal How can I test if there is a DNS problem?


  • @markus-schmitt change the DNS server that you are using to cloud flare or open DNS.


  • Hi @derek-saville, on my router, I have already run the beta firmware 2.9.4rc1, unfortunately without improvement in my case.

    After factory reset, "A-MSDU for wireless backbone" was automatically enabled in advanced settings. I do not have Ethernet backhaul, I only have the router and two mesh points.
    I have already tried this with static "5 GHz only" SSID. Thus there are no connection problems.

    My problem is not roaming when I move around the house, that actually works pretty well.
    My main problem is when, for example, I spend some time on the couch and use the iPhone. Then I can watch how the iPhone jumps from 5GHz to 2.4GHz every few minutes and back again. Then it can happen as described above that the connection breaks off completely. How can I prevent this? With any settings?


  • @markus-schmitt said in IPhones not staying connected:

    Then I can watch how the iPhone jumps from 5GHz to 2.4GHz every few minutes and back again

    When this happens, what is the connection strength of your 5GHz? Devices should start searching for another connection around ~-75 to -78 dBm which is ~50-45% connection strength. This could be part of it because you said a 5GHz only SSID works great. Try Disabling A-MSDU for wireless backbone as a test. (you probably have done this before, but there are reports that apple devices have struggled with A-MSDU in the past).


  • Hi @ubnt-brett, as connection strength with 5 GHZ I have about 60-65% if that happens.
    OK, A-MSDU is now disabled again.
    Unfortunately, it came again tonight to some disconnects while using and also when waking iPhone up from standby. I send the support file and a short video to you and your team.


  • @markus-schmitt Have you created an additional ssid and det it to 5ghz or 2.4, it may offer some more stability.


  • I am observing the same behavior with my iphones.

    Disconnections becoming more frequently over the days, have to power cycle my amplifi router every 10 days or so.


  • @ubnt-jt yes, as described above, I have no connection issues with an additional static 5GHz network, but then seamless roaming will no longer work through the house. Which is not the sense of a mesh.
    Unfortunately, I have not received any feedback on the support file I sent 5 days ago. 😞


  • @markus-schmitt If you add the static 5Ghz to your meshpoints as well, with exactly the same name, you’ll roam. Not ideal, but you’ll get the additional coverage.


  • Just as a reminder if you setup a dedicated 5GHz SSID network on all of the mesh points then make sure you disable the main network SSID on the clients that you want to use it so they don’t get sometimes confused again


  • @markus-schmitt Do you have router or band steering enabled. If you can connect to an additional ssid on 5ghz would try turning band steering off and router steering off if you have MeshPoints.


Log in to reply