Backhauled Amplifi HD router has slower wifi speed


  • I am using two Amplifi HD routers via wired backhaul.

    I have enabled A-MSDU om the main router and immediately saw better wifi speeds, but only on the main router. It is not possible to enable A-MSDU on the backhauled router as this is diabled and according to Amplifi support it should only be necessary on the main router. However I was still seeing worse wifi speeds on the backhauled router.

    Today I tried setting up the backhauled router in bridge mode instead, allowing me to enable A-MSDU on the backhauled/bridged router and voila better wifi speeds on this one too.

    So i guess we need an option/setting to enable A-MSDU for Amplifi routers that are connected via ethernet backhaul?


  • @jacob-rudolph Thank you for your suggestion! I will add it to the list of feature requests for future consideration.


  • Same situation here, I think it’s kind of a bug after auto firmware update, backbone AMPLIFI HD ‘s WiFi speed get significantly slower! Is there any bug fix will be applied though the next firmware update?


  • @Kaxir-Hoi Are you using 2.9.4?


  • @joe-johal it’s 2.9.3


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.