Incorrect password Wi-Fi issue


  • Hi there! Ten days ago bought AmpliFi HD (AFI-HD). First time everything was okay, it upgraded firmware to the latest version, mesh antennas connected to the router, speed & coverage was incredible. But then we noticed that in the dining room all Apple WiFi devices suddenly disconnects and when we try to reconnect devices we get error message that password is incorrect. At the same time we don’t have same WiFi SSID in our neighborhood or other network devices. I tried to change encryption technology but had same effect. Signal strength in the dining room is about 80% Please help me 🙂


  • Hello @ivan-sokol. We have heard a few reports of this strange behavior and we are currently researching it. We have found that if you power cycle your network the devices will automatically connect with no further action on your part. Others have reported that a single reboot fixes this issue and it has never resurfaced. Please let me know if this fixes it for you as well.


  • Hello, I just purchased the same product and finally got it setup mostly. I haven't added the mesh points yet due to a login issue.

    I first tried setting up the device with the Android app on a Pixel 3a and it kept failing. I grabbed the iPhone XR installed the iOS app and tried to complete the setup and it worked.

    I now have WiFi working, but the iPhone is the only device that can log into the admin settings of the router. I can't get logged in using the Pixel or my laptop. I've changed the password using the iPhone and tried on the Pixel and the laptop but keep getting an "incorrect password" message.

    The router is on v2.9.5 firmware which I updated after initial setup.


  • @jj-satkowski Did you create a different password for admin access over the wireless password? I have never seen this behavior before. Are the devices you are testing able to access the wireless network and internet?


  • @ubnt-brett Yes, it's a different password for admin than it is for WiFi.

    Everything works fine, devices can connect to the system and operate. but I can't log into the admin page from anything except the iPhone app I used to set it up. My Android app won't log in and neither can I log in from a web browser on any computer, Mac or Linux.

    Edit: Well, now I don't what to believe. I just changed the password AGAIN from the iOS app and now I can get into the admin settings from the Android phone and the web page. very weird.


  • I had this issue just now. Possible steps to reproduce:

    1. Using Amplifi app on iPhone
    2. Trying to allocate a static lease for one of Ethernet ports
    3. Then decided not to, because it may reset ongoing transfers
    4. Leave configuration page - do not save changes

    After this the connection was lost. Was unable to reconnect to WiFi, although I am 100% sure that password was correct. Then, eventually, WiFi restored by itself, after couple minutes.


  • @UI-Brett has this been rectified? This users post is dated Mar 6, 2019. I’m getting the same incorrect password error. Any luck solving this users issue?

    I purchased an Amplifi Alien router Jan 2021. After a firmware update end Feb 2021, the 12 devices that were working previously have lost connection to the router and get a password error. I’ve even gone back to factory settings 3 times since.


  • This post is deleted!

  • @UI-Brett has this been rectified? I have 2 Amplifi Aliens and similar to IyeQ, I have been getting disconnects and then 'incorrect password' error on my devices. This started happening after a firmware update.

    It's really frustrating because the router was so hands off for a long while and then after a firmware update I have had this disconnecting and forgetting password issue several times. It would be nice to know if someone is looking into this.


  • I have the same problem. Bought the router a couple of weeks ago. Firmware upgrade was promoted immediately after initial setup. And now I keep getting "incorrect password" prompts on several devices. A full reset did not fix the issue either.

    On the app, unless the phone is connected to the wifi, the device is not even recognized. I get "Unable to locate device" naturally because my phone cannot connect to the wifi due to the "incorrect password" problem even though I'm 100% I'm entering the same password I've used on the computer that is connected via which I'm writing this message.

    This is rather frustrating. Any progress on fixing the issue by the @AmpliFi-Router team?


  • Hi @molood,

    Sorry to hear that you have problem with your system.

    I had the same issue with my Apple devices but I solved it by changing channel and bandwidth on my Amplifi HD router.

    The issue for me was interfering wifi networks in my area.

    Please see below support articles to change this settings:

    https://help.amplifi.com/hc/en-us/articles/360039339174-Changing-Wireless-Broadcast-Channels-

    In the above settings you can also change your bandwidth.

    I use a tool called Netspot to identify the free channels in my area. Use the free version as it is adequate for this purpose.

    https://www.netspotapp.com

    I hope this will work out for you.

    Information is as is.

    All the best,

    ///Mike


  • Thanks Mikael for the response. Although you're assuming I'm able to use the app when in reality the app is completely useless when the phone cannot connect to the wifi due to "incorrect password". The app itself goes into detection mode for the device and shows "Unable to locate device"

    I am not willing to change my bandwidth either. Right now I have 968 UL and 984 DL. I have paid for and would like to use the highest bandwidth possible, so changing it would mean lowering the quality of my connection which doesn't work for me.


  • Hi again @molood

    The application, Netspot, you run that on your computer. Windows or Mac.

    Regarding the bandwidth - I'm referring to the routers bandwidth for the Wifi network. Not the bandwidth from your ISP (that I assume you refer to).

    All the best,

    ///Mike


Log in to reply