Tivo Mini

  • I did a Google search on this topic and found one thread on Reddit, but have not seen any answers to it.

    I tried to use a Tivo Mini while at a remote site, connected via an Ethernet cable to the Teleport (the Mini has no wifi, so using a hard wire is the easiest solution, anyway). I thought it was "money" when I could browse both of my Tivo boxes at home with Mini. However, when I tried to play anything, it commented that I was not on my home network and could not stream.

    Of course, I was not "officially" on my home network, I was on the Teleport. But the whole point of the Teleport is to mimic your home network from a remote site, which for the most part I was accomplishing here (could access the two Tivo Bolts at home and view their directories). However, the "last mile" of actually playing something would not work.

    Has anyone had any success with the Teleport and a Tivo Mini? More importantly, is there something I can do to make my Tivo really think it is on my home network when connected to the Teleport?

  • Hi @david-koehler - I don't have experience with TiVo Mini, but barring any hardware locks like comparing GPS signals, two things come to mind...UDP & latency
    If TiVo uses UDP, Teleport currently tunnels UDP traffic over TCP = not good for video streaming
    The Teleport's VPN is also very hard on the router's cpu, so it all adds up to high latency

    If TiVo Mini expects low latency very high bandwidth availability, it's possible it senses these anomalies and figures out you are not at your home network

    AmpliFi has been working on improvements for these issues for a while (~1 year) but we are all still waiting

    Even with the improvements, your home and remote networks may not BOTH be robust enough to fully replicate a true "home network" away from home experience to satisfy a device like the TiVo Mini

  • @david-koehler When you have the Tivo Mini connected can you see what IP address its getting assigned? It should show in your AmpliFi app under the family tab when connected to Teleport. Thats going to be the easiest way to see if its making the connection back to your home network and we can test from there.

  • I suspect the problem is largely involved around latency and throughput. The TiVo Mini has an ethernet port only (no wifi) not to save money but because at the time, most WiFi networks provided insufficient bandwidth for the video streams they wanted to push through (720p/1080i) with whatever encoding they use (I used to know when I had my TiVo system, I forget now). So the latency may be a pretty big issue but I suspect the even larger issue is bandwidth - I don't think the Teleport can simply push enough bytes fast enough for the TiVo system to be happy. If local WiFi wasn't good enough, then the ~15mbps that Teleport can push certainly isn't good enough either.

    Perhaps something else is at play, but that's what first jumps out in my mind.

  • Hi @ubnt-brett - I have made many similar trials with very similar devices, although not a TiVo Mini specifically

    If the remote TiVo Mini is browsing the other home network based TiVo Bolts I would be pretty certain the Teleport is making a proper connection

    Other similar devices have very similar results with Teleport
    You can access the home based directories and browse, but as soon as you initiate a video stream it goes very wrong - video never plays, or starts and locks up, devices lock up / crash out of playing, or you get error messages saying the video cannot be played, is not accessible or it says you are not on your home network...etc

    @UBNT-Gunars concluded in the past that since Teleport is tunneling UDP traffic over TCP and the current userspace VPN takes up a lot of CPU cycles (on both the router and the Teleport) it couldn't maintain a proper remote video stream

    For other devices (maybe not a TiVo Mini), raw bandwidth was not an issue as you can monitor them at the home network and they fell below what a dedicated HD router in bridge mode could serve a Teleport remotely
    A video stream over WiFi on the same device at the home network would be 8 to 10 Mbps
    Move the device to the Teleport remote location and same video won't play even though the Teleport is able to maintain up to 18 Mbps

    Gunars indicated that a beta firmware release with improved UDP handling (specifically for streaming video) and a move to a kernel mode VPN, should perpetually "land in beta within the next two weeks" going on about a year now

    The result of implementing these improvements should also increase the bandwidth capacity of the Teleport, according to Gunars
    Numbers such as a "3X" improvement were even thrown around

    Any updates on the Teleport firmware beta with UDP improvements and kernel mode VPN would be greatly appreciated

  • @derek-saville I vaguely remember that discussion. Now we are still working on teleport which is why we suggested everyone roll back to FW 2.7.1 on Teleport, But I feel like this instance is most likely device related. Like you said, on similar devices this has been reported but for most devices its not an issue. I myself use Teleport to stream movies and TV remotely using different mediums and have never ran into this error. I would suggest that @David-Koehler gather support files from Teleport after this error occurs and we can see exactly why the Tivo Mini still thinks it's away from the home network.

  • Thanks @ubnt-brett - can you comment on which multi-room extenders you have been successful with over a Teleport connection?

    I can get mobile device / app based streaming to work fine

    Hardware extenders have always failed to stream, but I haven’t tried any recent platforms over the last year

    If you know the TiVo Mini should work now then I will pick one up the next time I am stateside

    The previous generation TiVo did not work and multi-room extenders directly from content service providers have not worked

  • @derek-saville Mine were mostly app based connections as well. Xbox using multiple TV service apps via Xfinity service, Phone and computer apps including their website, and Plex through these devices as well.
    I have never used any TiVo devices in the past so I cannot confirm that they work.

  • Hi @ubnt-brett - multi-room extenders seem to have issues that app based streaming is able to avoid

    TiVo devices need to be on the same subnet and generally crave high QoS (low latency high bandwidth)

    I am not sure about the TiVo Mini that @David-Koehler is using, but a previous model (Roomio or something like that) would exhibit similar symptoms when failing to stream over Teleport

    Internet discussion of TiVo revolved around using L2TP (Teleport?) and their then alleged custom UDP

    If you are on the Xfinity X1 platform, and if you are willing to try it out, I will gladly donate towards an X5 WiFi multi-room extender so you can take one into a lab for evaluation ☺

  • @derek-saville I actually don't have their X1 platform. I couldn't justify it just for sports 😁

  • @ubnt-brett Do you guys need some TiVo equipment? I have some collecting dust that I was going to throw on ebay "some day" (I have a box of "ebay it some day" items that seems to get fuller rather than emptier). To be clear, mine is a Roamio OTA + TiVo Mini setup. So no cable card, just free antenna-based OTA.

  • Guys, I didn't check this forum for a couple days after posting because I wasn't expecting too much of a response. I'm so impressed with the number (and quality!) of responses. Hopefully we can get to the bottom of this.

    I have not had an opportunity to replicate this problem but might have a chance this weekend. If not, it will be a couple weeks before I am at that same location again.

    I have used the Teleport to stream other video sources--the Xfinity (beta) app on the Roku comes to mind. This app "requires" you to be on your "home" network to work (Xfinity doesn't want people to stream service outside the home on the Roku, though they do allow outside of the home streaming for many channels on the iPad, for example). I'm certainly not an expert on this stuff, but the quality of the feed I get from the Xfinity/Roku app seems like it would match that of the Tivo...

    In response to UBNT-Brett, I'll check what the IP address the Mini is assigned next time I get a chance to experiment. But as Derek Saville states, I'm fully browsing the two Bolts on my home network--looking exactly as it would look if the Mini was attached via an Ethernet cable to my home network. It is only when I try to stream something that I get an error message. I'll take a picture of this error next time so I can more specifically repeat here what it states.

    Thanks so much for the interest in this topic.

  • Hi @ubnt-brett - I totally understand

    If AmpliFi cannot, or no longer has realistic plans for improving Teleport's bandwidth / VPN latency / UDP streaming capabilities, please just come out and state it

    A year ago @ubnt-gunars said in Some basic information about teleport...

    All UDP traffic is currently wrapped in TCP, which could as well be the reason for the numbers you're seeing. The update that addresses this should land in beta within the next two weeks.

    ...and @ubnt-gunars said in My Teleport Review: Mostly Good, But Some Downfalls

    there's two things that limit performance now:
    we're tunneling UDP traffic over TCP
    current userspace VPN takes up a lot of CPU cycles (both on the router and the Teleport)
    Both will be addressed by the upcoming firmware updates.

    We understand things don't go as planned, priorities are changed, resources are redirected...etc
    Maybe you think Teleport is sufficient as it is

    By now you should probably know the status of this legendary mythical beta firmware

    So please, just tell us

  • So, I was visiting my daughter at her apartment in college, so took the opportunity to try the experiment again. Teleport set up without a hitch, connected the Mini via Ethernet, and browsed seamlessly--although I noticed that I could only see ONE of the two Bolts on my network at home. Looking back, I honestly don't know if this was true last time--maybe I just assume I could see both, since the Family Room Bolt is the "main" one that we record most of our programs on, so that is the one I was looking for.

    Once again, using the Mini, I could browse the Bolt in my home. It showed that PGA Golf was currently recording (the TPC), along with some other program, along with all of the previously recorded programs. However, when I tried to play the golf from the Mini (now located about 75 miles from home), I got the error message shown in the attachment.


    As far as the message goes:

    1. The whole point of the Teleport is replicate my home network. For the most part, it does that in this case (can browse the directory of recorded shows live), but cannot stream. So, in response to "Please make sure that both the Tivo box and Family Room Bolt Tivo are on the same network, and that the home network is working", I think we can definitively state that the home network is "working".

    2. As far as making sure these boxes are on the same account, this is definitely the case, and, more definitively, this message goes away when I return home, attach the Mini via Ethernet to my network, and attempt the same maneuvers.

    3. The V112 error appears to be displayed if the latency is too high, as @Derek-Saville suggested earlier in this thread.

  • @david-koehler - I have a Tivo Bolt and Tivo Minis at home. I cannot address your question about using a Mini remotely, because I have never tried it, but I will explain how I use the Teleport to successfully watch any content that my Tivo can provide. My Amplifi and Teleport are both using 2.9.5 firmware.

    When I am away from home, I am able to use the online.tivo.com web site on a laptop and connect the HDMI output of the laptop to a TV. The laptop becomes similar to a Tivo Mini when I am connected to my home network with a Teleport which gives me an IP address on my home LAN. My home internet connection only has a 12 mbps upload speed, but that is usually OK for me to stream from the Tivo at home to my laptop when I am away from home. Of course that is assuming that the network at my remote location has decent bandwidth that is at least 10 mbps up and down.

    If I am remote and I am not using the Teleport, the online.tivo.com web site lets me see the guide and a list of "My Shows", and let me select which shows to record etc, but it will not stream shows because I do not have an IP address on my home LAN.

  • @bruce-cole --Thanks for your suggestion. Yes, your solution would work, as would another one, using the Tivo app on an iPad and then using a lightning to HDMI cable to get it into the TV. Same issue as you describe, which is that out of home streaming can be limited if you are not on your "home" network, which the Teleport can solve.

Log in to reply