Release info on 2.9.5?

  • Hi there team,
    I just got (and performed) the 2.9.5 release. Any info on it?

  • This was posted in the firmware updates help article:
    v2.9.5 (13-Mar-19)

    Improved multicast IPTV performance
    Band steering enhancements
    Security updates
    Guest network enhancements
    Firmware rollback feature added to web portal
    Additional minor improvements

  • Thanks 🙏🏻, looks like I have missed that !

  • Source where (I think) @Donte-Hymon found that: -> Documentation -> Firmware Release Notes

  • @shane-milton thanks 🙏🏻. I guess I was just hoping to see some official information in here, too 🤷🏻♂

  • @ubnt-brett Any love for the Teleport?

  • How long should the update take AMPLIFI off-line? Mine has been “updating” for 3 hours.


  • @bill-richardson ~5 minutes. It is ok at this point to power cycle the device. Please let me know what happens after you power cycle the device. I have seen this before and for some reason it just was "stuck" and had no further issues after a power cycle.

  • @ubnt-brett Is there an ETA on an update for Teleport?

  • @carmine-granucci No ETA as of yet, we are still currently working on the firmware.

  • Hi @ubnt-brett - Teleport firmware for UI, performance, or both?

  • @virgil-nicolae was your upgrade experience? is performance? all your features you're using still work properly? still sitting on 2.6.3 which runs/performs perfect and hesitate to move up...i have 2 routers (via backbone) plus 3 antennas in my mesh network...appreciate any technical insight 🙂

  • @rich-sammon Hi there,
    Update process was smooth, without any particular issues (that I could notice, at least).
    I haven't actually post much, but I'll take this opportunity to raise up some good and bad things, as much as I could see after approximately 6 month of usage.
    Good things (and the main reason of purchase):

    • good coverage of WiFi inside and outside of the house (basement, ground floor and 1st floor home, mainly wood and concrete)
    • I'm using 2 AFI-HD units (ethernet linked) plus 2 Mesh points antennas (from which 1 router and Mesh points are enrolled in the Beta program)
    • second router is used in the basement where I needed some "hardwired" connections

    The system is performing generally ok with around 20 devices connected:

    • Apple devices: 2 iPhones X, 2 AppleTV's, 1 iMac, 2 MacBooks, 1 HomePod and 1 iPad
    • 2 Samsung TV's
    • 2 printes
    • 1 Syno NAS
    • some Wifi speakers
    • other IoT devices (Webcams, lights, etc)

    I must honestly say that I haven't had any (or most) of the issues other people are raising in here, my system works pretty much ok (at least for my needs).

    I'm having a fiber connection with 500 down / 50 up
    ISP router is set in Bridge mode full (no interference there and no other limitations).

    As speeds: I am mostly getting my ISP advertised speed (including via Wifi when I'm closed to any of the 2 AFI-HD's). Speed is considerably dropping when my phone is switched to a Mesh point (still connected as 2x2 - and sometimes just 1x1 my Tx is going down to some 6-7Mbit and sometime even Rx).

    But, as somebody else mentioned in another post, Apple's devices are "hard" to please 🙂

    Last week, my wife was complaining about that problem and I've decided to disconnect most of the Ethernet connections (for iMac, AppleTv's and MacBooks). Ever since that, Wifi connectivity and speeds have drastically improved without major (or visible) problems any longer.

    I suspect that since QoS is prioritising the Ethernet connections over Wifi (and all hardwired devices were "eating" a lot of my bandwidth) that could be the reason.

    Right now I have:

    • k/v/A-MSDU enabled
    • Hardware NAT disabled

    Both routers and Mesh points are running the 2.9.5 firmware.


  • The 2.9.5 and now I have confirmed 2.9.3 seem to not work with Plex Remote Access. I have enabled all the correct setting however at this point nothing is working. When I go into plex setting and enable remote access I can see it comes on for 5 seconds and then goes off. Prior to 2.9.3 I never had this problem and everything worked great. I have also tried to forward the ports. 32400 <- 50000 . That does not work either.

    Can you help.

    The base configuration is Xfinity Cable modem configured in Bridge Mode


  • @rich-sammon rolling the firmware is now built into the webUI, so if you upgrade to 2.9.5 and face issues it is simple to go back.

  • @michael-rymkiewicz Do you recall which FW you were on when Plex was last working properly?

  • @ubnt-brett I don’t remember because everything is updated automatically. It seems that even with 2.9.3 it’s broken as well.

    The remote access keep going back to not allowing me have a remote access. It switches on and off automatically.

    I made sure the Comcast router was in bridge mode however it keep saying that I have NAT issues wirj both routers being on the network.

    Funny part is it’s been fine all along.

  • @michael-rymkiewicz I can help you roll back and see if an older FW is the solution and we can do more research from there. Most running Plex did not face this issue from the update but thats a good starting point. I will send you the files to roll back, If you can remember or take a guess at what the last FW that worked we will start from there.

Log in to reply