Devices Rx and Tx rates dropping

  • I have an Amplifi HD set with two mesh points. I am experiencing throughput drops which render devices unusable- hoping for help!

    Throughput on Wi-fi devices keeps on dropping, causing internet to crawl. This appears to mostly be happening with apple devices, an Apple TV and iPhone Xs’s.

    These devices connect normally at 500mb+ Rx and Tx. However, when experiencing issues the Rx and Tx drop down to 6.50mb. This results in crawling internet speeds, rendering the devices unusable. A restart on the device and/or the amplifi HD resolves the problem, until the next time it happens.

    I have tried:

    • Factory reset
    • Hardware NAT
    • Various firmwares
    • Changing channels
    • Band steering on / off

    Before I chuck it out the window, any ideas?

  • @jamie-vague I understand that the r/k/v, A-MSDU, band/router steering, and some other settings give Apple devices problems when they're enabled because of their custom (wonky) implementation of a lot of WiFi things. I would suggest starting out with just stock settings (enable Hardware NAT if your ISP is over 400mbps), and troubleshoot from that configuration.

    1. Does this happen regardless of which node the device is connected to or does this only happen on the mesh nodes?
    2. When you roam from one mesh node to another, does it resolve things or are speeds essentially "pickup up where they left off" from the previous mesh node?
    3. Have you tried hitting your phone with a hammer to see if it fixes it? (I can tell you right now, pretty much every WiFi appliance manufacturer hates dealing with Apple devices.)

  • @jamie-vague This article instructs you on how to navigate to the WebUI :
    That is where the 802.11 r/k/v and A-MSDU settings are located that @Shane-Milton was referencing.
    P.S. I do not recommend step 3 in Shane's list 😆

  • @shane-milton Thank you for your help, much appreciated.

    I will try disabling A-MSDU and see if any improvement. What does A-MSDU do?

    It is defiantly not an issue isolated to a particular access point. I happens when connected to any AP, including the base router.

    Will monitor if roaming has an impact next time I have the problem.

  • @jamie-vague how many hours or days does it last before the issue hits because I think this warrants my feature request for clearing the cache or memory of both mesh points and router, and user set reboot schedule.

  • This post is deleted!

Log in to reply