Firmware v2.9.5

  • @edward-dolezal I must say that was odd. There was a prompt on the router, so I clicked OK and it updated. Then I started to have issues so I went into the app to check the status, and was then prompted about a new update. The web page suggested the update was published today, and hence I assumed they had withdrawn it and then re-issued. Anyway, it looks like this is not the case, so I´m not sure why I had to update twice in a few days time.

  • @joakim-lundberg It's possible that you just had a mesh node down that didn't update but it came back online after the firmware update reboots, therefore triggering another firmware update for that mesh node only. I'm only speculating but this has happened to me before.

  • @joakim-lundberg The firmware release is a rollout so thats why it can take up to 24 hours for some customers to see the update after we announce it. We did not recall, The only thing I can think that could have happened is one of your meshpoints or routers was not online when the update was started so it had to update again once it came back online.

  • I'm hoping the next firmware will enable the wan port as a useable LAN port, as well as bringing back Msdu for mesh points and giving the option to disable wifi bands, and possibly the option to have a Mesh point act as a client that doesn't reapeat the signal that would be great.

    I seen to have had better performance with Mesh point Msdu enabled, it it possible to add an automatic reboot option also?

    Thanks in advance.

    I'm finding that without Mesh point msdu there seems to be a slight preformace degradation I would like to see it back because preformace with both msdus enabled is alot better in my personal case.

  • Also please bring back the full K/V/R because R is missing the roaming setting is gone as well as Msdu for mesh points.

  • @edward-dolezal 802.11 r is in beta not public FW, this is why you are no longer seeing it at this time.

  • @ubnt-brett Hello,

    After upgrading to v2.9.5, I have been seeing issues with my Amplifi app speed tests. I have a 200Mbps download connection and the Amplifi app usually shows 170-190Mbps, which is acceptable. However,...

    I am noticing those speed tests dropping to 10-50Mbps. I have attempted to reboot my cable modem, with no affect. But, when I reboot the Amplifi router, the test scores go back to 170-190Mbps.

    I have seen this issue twice since upgrading. I did not see this problem with previous firmware versions.

  • @ubnt-brett so in the next beta we should be able to see it again along with Mesh point msdu?

  • @kilgry-kilgry have you tried changing DNS servers form your ISP to open DNS for example.

  • @edward-dolezal I should have mentioned I'm setup in bridge mode, so no DNS settings to change.

  • @kilgry-kilgry I'm guessing the cable modem is in bridge mode, if the amplifi is in router mode, I was suggesting to change the DNS server that it is using.

  • @UBNT-Brett Does the fact that you liked/thumbs up'd the unraid DNS cache exception request have any indication on whether or not it will be making it into the next release or any upcoming release?

  • Hey @jack-platten, I actually don't recall where I liked that post. but no, I use the upvote to show appreciation and recognition of the request. We value and encourage all feedback, and even though we can't always share future plans, we do consider all requests that come from our community.

  • @edward-dolezal Not sure if we are misunderstanding each other, but I have a stand alone cable modem --> stand alone DD-WRT router --> Amplifi running in bridge mode to provide mesh WiFi only. I also have second Amplifi hub (not mesh antenna) running as another mesh access point (WiFi connected, not ethernet backhaul).

    I prefer not having Amplifi running as my main router because of its lack of administration features.

    BTW, my issues with the 2.9.5 firmware had become severe enough as to require me to reboot the Amplifi device every day or two. I have decided to rollback the firmware for now.

  • @kilgry-kilgry Curious, but have you tested AmpliFi not in bridge mode and replacing your primary stand alone router? Please let me know how it is functioning now that you have rolled it back to the previous version.

  • @kilgry-kilgry you only just mentioned the ddwrt router, from what I can see the issues might lie with in it can you test it using the amplifi as the main router to see if the issue still persists.

    I my self use an Asus RT-AC88U Infront of my amplifi units my setup is alot more complex, I noticed that after a factory reset on my Asus router my amplifi has issues with dropping out and issues to set up.

  • @UBNT-Brett client msdu settings affects both 2.4 and 5ghz or just 5ghz?

  • AmpliFi firmware v2.9.5 has been released.
    Release notes:

    "Improved multicast IPTV performance"

    I don't know what the above statement for the latest firmware means, but my set top box could not sync back to the ISP. I also own one of the Ubiquiti routers, the edgemax edge router 8 port. I had to tweak that router to accept IPTV stream. Below is one of the configs I used to allow the igmp to push thru to that router. Anyway, I'm trying to eliminate the edgerouter and use it for another data purpose, and so I want to use the amplifi HD for my video services on both wired and wireless set top boxes. I looked and searched about the amplifi hd, but no result indicating this router has the capability to do IGMP snooping and multicasting. So when I saw this firmware version 2.9.5 mentioned "Improved multicast IPTV performance". I thought i would give this amplifi hd a try again, after i upgraded to this version, still no go. So the statement "Improved multicast IPTV performance" for this firmware is false as i looked at the info on previous firmwares and none mentioned about multicast IPTV. I am very disappointed so far about this amplifi hd router that has no support igmp and and multicast yet. Even my old D-Link 605L router supported the igmp and multicast and it worked fine but wireless range is small. See attached image of the router gui settings for the Dlink. I wish amplifi hd has that simple setting. I can understand the edgemax router has to be tweaked as it's more of an advanced user or IT profession purpose.

    ubnt@ubnt# show protocols
    igmp-proxy {
    interface eth1 {
    role upstream
    threshold 1
    interface eth2 {
    role downstream
    threshold 1


  • @noah-leech which isp since some ISPs required a specific profiles or configuration to work eg Movstar.

    The lack of igmp can be fixed in an update, since some ISPs need it inroder to work.

    The improvement in multicast preformace would be for ISPs like mine who don't need igmp for IPTV.

  • Hi @noah-leech - are you using PPPoE mode for internet access?

    If so, see this post from @UBNT-Brett

Log in to reply