IGMP Proxy Bug?


  • Hi there!

    To explain my problem, I will explain my network topology.
    Please note before I start: This has been working succesfully since I bought the Amplifi HD over a month ago.

    I have a 200/200 fiber plan -> Modem/Router from ISP (can't sadly put it into bridge mode, so everything is turned off, especially DHCP and only 1 static address which is the Amp).
    -> Switch 1, port 1: Cat 6 cable from ISP modem to switch
    -> Switch 1, port 2: Cat 6 cable to Switch 2
    -> Switch 1, port 3: Ikea Tradfi (like Philiphs Hue Hub)
    -> Switch 1, port 4: To bed-room wall-outlet -> TV

    Switch 2, port 1: Cat 6 cable from ISP modem.
    Switch 2, port 2: Cat 6 cable to WAN AmpliFi
    Switch 2, port 3,4,5: TV / PS4 / Soundbar
    Switch 2, Port 6: AmpliFi LAN port 1. *

    AmpliFi:
    WAN: to Switch 2, port 1.
    Amp switch, port 1: IPTV
    Amp switch, port 2: to port 6 of Switch 2. *
    *I know this may seen I'm looping my network, but it doesn't, even the Ikea Hub get's an IP address from the Amplifi.

    Note: Both switches are 'non-IMGP snooping'

    My issues:
    Once I installed FW update 2.9.5, the IPTV is eating all the bandwidth on my network. The dials on the AmpliFi's touchscreen, the download goes to 250-280MBPS (while my subscription is 200).

    After a while the network times out, dropping everything and resets itself and going over and over again.
    During the 'bottlekneck', it's impossible to browse the internet, watch tv (stutters).

    What I checked:
    If I remove the Switch 2 'loop', it's fine, looks to me it won't send the Multicast packets anymore.

    I have been in touch with the support of AmpliFi, they will check if it's a bug.
    Per today, I know my 2 switches may need to be IGMP Snooping enabled.

    But it's odd to me that this worked fine for 3.5-4 weeks, until yesterday's update.

    I'm planning to quickly swap the AmpliFi for another Router with the exact same Switch / cable setup and post my results below.


  • Hi @jeroen-osnabrug - you might check wiith @ubnt-brett about the update in Firmware v2.9.5 which included:

    Improved multicast IPTV performance

    Whatever they implemented may not work in your topology

    Firmware v2.9.5 also added a firmware rollback feature to the web portal
    You might want to go back to v2.9.3 until you know what is going on


  • @derek-saville Hi! Thanks for replying.

    I noticed the firmware change log too..

    However, I did the rollback for the Router, not the Mesh points and it didn’t work sadly.
    @UBNT-Brett I hope you can help out. Support (Presila) already received my configuration files.

    Cheers!


  • Found the issue, the loop was the problem after all.
    But it's quite odd that it didn't show up since I start using AmpliFi and as said before, I know I was looping the switch but it worked and never showed problems until the FW update to 2.9.5, reverting back to 2.9.3 didn't go back to the working situation, so I guess it was something else..

    The AmpliFi was placed in the living room on the 2nd switch, due the fact I loved the design and the live-speed view.
    Now, working again, it's directly behind in the ISP router in the 'maintenance room' with a closed door.

    I could use Bridge Mode, but I don't want to use the functionalities of the AmpliFi such as Guest Mode.

    Other than that, IGMP is not bugged as I could see the packets in WireShark.


  • If it's looping with a switch you need spanning tree protocol enabled or an option for it.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.