DHCP option 61

  • @Scuzzy-Mac
    You are probably right - I saw you mention the draytek in a previous post.

    I might pop on to ebay and nab me one or else a BT Openreach modem.

    Thanks again - whatever happens next at least I'm learning some useful stuff as I go.

  • @Brian-Cade exactly that, yes. Select DHCP and enter you HEX value in to the DHCP Client ID text field directly underneath the drop down.

  • @Brian-Cade I have a Draytek Vigor 130 in bridge mode. The Draytek has no info related to Sky login, that is all done via the Amplifi HD set up, by entering the hex value in to DHCP Client ID.

    I’d suggest if you have your modem in bridge mode it should perform correctly, but I’d be unable to confirm that for sure. I’ve heard good things about the BT Openreach modems and can confirm that a Draytek would work 🙂

  • @syphon123 That's perfect. Thank you very much.

  • @syphon123 Thanks. Understood. I suspect then that I do not have my modem router correctly configured and I am operating in somewhat of a half-way house setup. I will research some more as to putting the Archer VR400 in true modem only mode and if I fail that test, will invest in the draytek or bt modem as yourself and scuzzy have suggested.

    Thanks again for all your help. It's great to have this community to lean on. 👍

    EDIT. I have the Amp Instant finally working correctly with my TP-Link Archer VR400 Modem. Success! 😎 I purchased a BT modem off ebay (£15) and hooked this up to the Amp Instant (with DHCP client ID field populated with the hex sky id) rebooted the Instant and it worked straight away - slightly slower speeds and ping times than I had previously but working nonetheless. So I took another look at the VR400 setup. Did a factory reset (forces it into bridge mode), connected to it via a browser, entered date and region on the TP-Link quick setup screen (necessary in order to progress), set the Internet Connection Setup to Sky(MER)_VDSL left the username and password fields empty and then saved the config. Rebooted both router and Instant and all is well.

    Many thanks to everyone that helped me get this point. I really appreciate it.

  • @syphon123


    Struggling to my HD hooked up using the Vigor 130. For the HEX string what format is it entered as before conversion






    Also would you recommend using the hex converter in the AMPLIFI web app or an external one?

  • @Ashok2429

    None of them are in the correct format,

    It should look like this;


  • @Scuzzy-Mac

    Thanks for that. Finally managed to resolve as Vigor wasn’t in bridge mode out of the box. Working like a dream now.

  • @Ashok2429 Sounds like you're all sorted now! Once you have the format of the string in the correct format, and have it converted, it's a pretty quick process to get setup.

    First, get the Vigor 130 in to Bridge Mode
    Then once connected to the Amplifi router, enter your hex value in to DCHP Client ID.

    I wasn't aware that the Amplifi app had a hex converter, so I'd use a separate app for that...

  • Hey, following this link with much interest, having frustrating issues with Sky Q and Amplifi! How do I get my details to enter into the DHCP client ID?? Thanks in advance

  • @hayleyalewis This setting can be modified on the Web Interface, found under DHCP CLIENT ID

  • @hayleyalewis I don’t think the username or password matters for Sky. Just the correct format with dummy data converted to hex.

  • Sorry to resurrect this thread.
    Getting my Vigor 130 delivered tomorrow. Do I need to enable DHCP IPv6 also? And if I do, I'm assuming it's the same hex code as for normal DHCP client ID?

  • I can’t seem to get it working I have followed the guide to turning bridge mode on my draytek vigor 130.
    I set my AmpliFi he to dhcp and used the client ID that someone posted on here in hex value however I get no internet connection.
    I factory reset both devices and tried a couple more times.
    The only thing I don’t know is if I need to find my username and password to convert to hex for the client I’d?

    Please hope someone can help iv been on this for days with no joy I can’t run with this stupid sky router anymore!

  • @Scuzzy-Mac said in DHCP option 61:

    None of them are in the correct format,
    It should look like this;

    Sorry to resurrect an old thread, I am on sky fiber and having thoughput issues along with lots of other niggles, so would like to get my hd running with the white open reach modem.
    will the string you quoted work for me or does it have to be calculated from my details in any way?
    thanks for any responses in advance.

  • @Philip-Boydell I have the same setup as you & was able to get it working today. It seems it doesn't have to be calculated from your specific details.

    I used this website to encode 12345678@skydsl|1234567890asdfgh as a hex string, the output being: 313233343536373840736b7964736c7c31323334353637383930617364666768

  • @Max-Tayler Thank you for that, I will give that a go when the internet is not needed and I can have a play. Do you have the VOIP service? I was wondering if that could be kept by connecting back to the sky router via lan port 4 from my switch and hove the sky router only do voip? I will give it a try if you have not played with it.

Log in to reply