New router giving iPv4 configuration error


  • I have an Amplifi HD (and two mesh points; all have 2.9.5 firmware) set up with a Belkin ADSL modem between it and my phone line. My ISP connection info is stored in the Belkin and the Belkin has its own wifi network switched off. All the devices in the house are connected to the Amplifi's wifi network. There's a DHCP server running on the Belkin, the only connection to it is from the Amplifi. Everything works brilliantly with this setup.

    My home broadband connection is being switched from ADSL to fibre later this week. My ISP have sent me a Fritz!box 7530 which can cope with ADSL or fibre connections. I'm trying to set this up to replace the Belkin. I can connect direct via the Fritz!box (i.e. not from the Amplifi's wifi) to the internet and it seems to work ok, though I haven't tested extensively.

    When I connect the Amplifi to the Fritz!box however it reports "please verify iPv4 configuration". I've tried rebooting everything in different orders; forgetting and reconnecting wifi connections from devices and putting the Amplifi into Bridge Mode. None of those have removed the error message about iPv4 configuration. Internet connections from devices connected to the Amplifi wifi in this setup work some of the time, but we ran into a lot of hanging connections.

    For now I've switched back to the Belkin but I'd like to get this sorted before my connection switches over to fibre later in the week as the Belkin will only work with an ADSL line.

    Any ideas what I can do to persuade the Amplifi and the Fritz!box to play nicely together? Thanks.


  • Hi @kirsty-darbyshire - consider using a paperclip to factory reset the AmpliFi HD and go through the full setup process again with the Fritz!box

    If you have a lot of customized settings, you may want to use it as a last resort, but if your Fritz!box is a DHCP server and properly working with direct connections, your AmpliFi HD should at least work in Bridge mode

    It sounds like you were Double NAT'ng with the Belkin and there might be something AmpliFi doesn't now like about the Fritz!box configuration

    Once you have Bridge mode working with the Fritz!box you can then explore a double NAT setup if you need the additional AmpliFi features (i.e. Guest Mode, QoS, etc.)


  • Thanks Derek. That makes sense. I'll have another go at getting the Fritz!box to work before resorting to the paperclip but a factory reset probably makes sense.

    The Amplifi has its external IP address set to 192.168 by the Belkin, I guess that is double NAT though since it hadn't caused a problem before I hadn't looked into it. I'll have a careful look through the Belkin settings and see if there is anything obvious I need to transfer to the Fritz!box too, but I suspect factory reset is a better idea.


  • Hi @kirsty-darbyshire - if you search the forum for “Fritz!” a couple people are using them in Bridge mode with older 6490 models, so I would expect you can at least get Bridge mode going

    Let us know if you still run into problems...


  • Well, my line got regraded from ADSL to fibre and I connected up the Fritz!Box, and switched over the connection in the back of the Amplifi... and everything just worked! No error this time. Which is good. So I don't know what the problem was but as long as it stays away I don't really care either!

    Thanks very much for your advice, it's much appreciated!


  • I have been having the same issue with a different ISP. Amplifi HD + 2 mesh points, all running 2.9.5. Optimum Online with an Arris TM1602G modem. I've had the Amplifi for about 3-4 weeks. Initially no problems. Then, over the past two days suddenly I lose external (WAN) IP and internet config. Rebooting modem/router (in various combinations) doesn't work. The first two times it happened the Amplifi eventually recovered spontaneously. Third time (today), it didn't. I changed ethernet cable between the router and modem -> no luck. Factory reset -> no luck. I then downgraded to 2.8.2 firmware on the main router (not the mesh points - app won't let me) and that seemed to work. I'm not convinced however that the downgrade actually fixed the problem. Posting here for the paper trail.


  • @m-levin Then next time you face this issue, can you please use the app and select the diagnose tab and let me know what the WAN status is? If it is a WAN failure the diagnostic screen will indicate a red X on the Wan link (it doesn't detect a cable) If it is green, it could be the modem not providing the connection. Please keep me posted so I can help you find a solution.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.