No Multicast TV Channels after Router Swap

  • UK user.
    Set up below:-
    Copper line in -> Vigor130 VDSL Modem set as bridge with VLAN of 101 -> Amplifi router set as PPPoE -> Internal LAN cable to Netgear 8port managed switch -> ISPs IPTV box.
    ISP is BT
    I've just purchased 2 stand alone Amplifi mesh routers and an Amplifi mesh point. After configuring the main router as PPPoE , the other one as a wireless mesh with ethernet backhaul through the 8 port switch and the Amplifi mesh point in another room meshed with the main router.

    Everything works brilliantly except for the multicast TV channels. Even when the ISPs IPTV box is connected directly into the back of the router I don't get any multicast channels. The IPTV box shows it has an IP address and I can use the built in apps, eg Netflix

    My setup had worked before I swapped out my Draytek 2860ac router. I bought the Amplifi as I needed the higher WiFi coverage that it gives. I am after some guidance on what the issue is and can it be corrected with a firmware update. It doesn't help with the IGMP settings not showing in the app so you can't even check as it's a required setting for the UK. I've been on to support but everything they've suggested hasn't worked.

    Thank You

  • @jon-nicholls - are you already working with the AmpliFi support team, or BT support?

    If AmpliFi, I assume they have confirmed you are on latest firmware 2.9.5 with the IPTV multicast improvements and maybe even tried a prior firmware release, along with all the other usual suspects, including resetting the modem?

    If you take the managed Netgear switch out of the topology and connect an IPTV box directly to an HD LAN port, what happens?
    Is IGMP snooping enabled or disabled on the managed switch?

    If you place your AmpliFi HD in bridge mode between your old Draytek 2860 AC router and the Netgear switch, does IPTV still work?
    From that you might know if the HD's IGMP proxy is working

    I believe your Vigor modem can also function as a DHCP router?
    If yes, and you take your modem out of bridge mode and place the HD in bridge mode, does IPTV work?

    Someone else mentioned successfully using WireShark to analyze network traffic to try and debug IGMP multicasting issues, so it might be something you want to look into as a suggestion

  • @derek-saville Dealing with Amplifi.
    So AmplifiHD in bridge mode between Draytek router, which has IGMP proxy/snooping/fast leave set, and Netgear switch, Internet and multicast channels work.

    So does this mean that the HDs IGMP proxy is not working?

    If this is the case then it needs to go back to Amplifi to deal with the firmware issue.


  • @jon-nicholls said in No Multicast TV Channels after Router Swap:

    So does this mean that the HDs IGMP proxy is not working?

    I believe that depends on if the AmpliFi HD in bridge mode is simply flooding the multicast packets to the Netgear switch or if HD's proxy is active in bridge mode and properly joined the multicast group for LAN clients

    Hi @UBNT-Brett - can you clarify how an HD handles multicast traffic in bridge mode vs router mode, and comment on why multicast IPTV would be working in bridge mode and not as router?

  • Hi @derek-saville The only activity lights showing on the switch are the ports that are connected to the network socket and the IPTV box whilst watching multicast TV. I take this to mean it is not flooding the network as all activity lights would blink in that case. I have seen this happen before. UK Internet and multicast come from two different paths.

  • Hi @jon-nicholls - that would indicate the IGMP Proxy is working in Bridge mode and they need to fix it

    I don’t know if multicasting works under double NAT, but if you now switch the HD to DHCP router mode behind your old Draytek router, what happens with IPTV?

    If your Vigor modem can also act as a router, does IPTV work when the HD is in Bridge directly behind it?

    You mention 2 different paths for the internet & multicast IPTV

    It may be in PPPoE mode the HD is filtering / blocking reception of the IGMP multicast packets or something like that

    Really hoping @UBNT-Brett, @UBNT-KARLIS (if he’s still around) or one of the AmpliFi folks can help...

  • @jon-nicholls Could you send support info, I would like to look further in to the issue. Thanks.

  • @ubnt-jt Updated download support file sent to

    The support file is as the equipment is connected at present.
    ISP modem -> Draytek2860ac PPPoE -> AmplifiHD Bridge Mode -> Netgear 8port managed switch -> IPTV box

    I do not want it connected like this as I bought the AmplifiHD to do away with the Draytek.


  • @jon-nicholls Can you eliminate they Draytek and set it up how you wish, then send another support file. Thanks again.

  • @ubnt-jt Updated download support file sent to

    The support file is as the equipment is connected at present.
    ISP modem -> AmplifiHD PPPoE Mode -> Netgear 8port managed switch -> IPTV box

    Internet is available to the built in apps on the IPTV box but still no multicast TV channels.

    Unable to configure Vigor130 to act as router as this device is a modem only in the UK.


  • @jon-nicholls said in No Multicast TV Channels after Router Swap:

    nfigure Vigor130 to act as router as this device is a modem only in the UK.

    Thanks I will get back to you.

  • @ubnt-jt Thanks for your assistance


  • @jon-nicholls it can be set as a router it's just met for bridge mode also what switch are you using, is the firmware update to date ?

  • Hi @edward-dolezal NETGEAR GS108E 8port managed switch - Firmware up-to-date

    BT FTTC requires Vigor130 to be in PPPoE pass through, MPoA enabled (when this option is enabled for multicast, bridge mode is already set and cannot be unset), to pass PPPoE and multicast to the router. The router is then configured as PPPoE (as stated in Draytek set up docs). This allows PPPoE & IPoE to be sent to the network. IGMP proxy/snooping/fast leave must also be enabled to avoid flooding the network.

    From the setup guide:-
    The Vigor 130 is a pre-configured VDSL2 / ADSL2+ modem that takes a VDSL2 or ADSL2+ connection and performs PPPoE pass-through to the LAN / Ethernet port, which can then be used by a device such as a router to connect directly to the internet.

    If required, the Vigor 130 can be easily reconfigured into Bridge Mode so that it behaves in a similar way to the Openreach FTTC (Fiber To The Cabinet) modem.

    This configuration can sometimes be more suitable if the Internet connection is also being used for IPTV services such as YouView or BT TV with a connected router .When configuring a connected router to use IPTV, it will be necessary to enable your router manufacturer's equivalent of IGMP Proxy.

    This is required as I am having FTTP installed in three weeks and will have no access to the ONT, which will feed the Amplifi WAN port via a cat7 network cable.


  • @jon-nicholls I have the vigor 130 on my VDSL 2 connection, though I'm using DHCP from the ISP opposed to pppoe, before it's bridged there is options for using it to connect to the ISP via ppoe.

    And you are lucky for getting fiber to the premises are you sure you haven't missed a vlan tag or something I know certain ISPs have specific profiles for multi cast eg Movstar.

  • @edward-dolezal

    VLAN tag is already set in the Vigor130

    Yes. They were up the pole opposite my house six weeks ago putting the fibre DP on it. Two weeks ago they were taking orders.

    I am currently having issues with the modem spontaneously rebooting a couple of times a week. No noise on line and as I work for Openreach I can fully test the line but find no problems, although I've now got access to an internal specialised network health website and it shows REIN issues at various times.

    The availability of FTTP has now prompted me to remove the last length of copper on my line and go full fibre with VOIP.


  • Hi @jon-nicholls - have you tired rolling the firmware back to 2.9.3?
    I assume you are on 2.9.5 and there should be an option in the web UI Support page to go back to the previous release

    If you could place your HD in a different mode other than PPPoE it might indicate if it is a PPPoE specific bug blocking the multicast packets
    Does your Draytek router have a DMZ where you could place the HD in Static mode with an assigned IP address?

  • @jon-nicholls lucky I'm subject to random dropouts because of the ancient copper lines, I have no choice but to be stuck with it or fork out an exorbitant amount of money for a fiber line, with the dreyteck I'd check which firmware version you are running since there is 8 and each has a specific connection type it's intended for or localisation if I remember correctly.

  • @derek-saville In bridge mode, multicast traffic flows naturally from WAN to LAN side of the router. In NAT mode, IGMP proxy assistance is required. However, PPPoE is a special case which is not handled by our IGMP proxy at this moment.

  • Hi @ubnt-jt
    Any update on the progress to rectify this issue? Or a guesstimate on a firmware fix.


Log in to reply