No Multicast TV Channels after Router Swap


  • This issue has still not been rectified even with the latest firmware v3.0.0

    I now have FTTP.
    Ethernet from ONT to Amplifi in PPPoE mode still won't pass IPTV, although iPlayer etc.. works. Only way to use the Amplifi is to place it in bridge mode after a Draytek 2860ac.

    IGMP not working in PPPoE mode although internet connection is available to the built-in apps on the IPTV box.


  • @jon-nicholls

    Hi Jon. Have you tried the 3.1.0 update? I have BT TV like you and am hoping for some progress before I pull the trigger on an Amplifi HD!


  • @simon-brushett

    Latest firmware still does not work v3.1.0 This is turning out to be an expensive mistake. I bought all separate units so that I wasn't tied to a kit, so I basically have a £385 pile of junk. The engineers have been notified months ago this was an issue for UK users but nothing seems to have been done to fix it. The addition of new features seems to take precedence over important issues being fixed.

    We need IGMP to work through a PPPoE connection.


  • update

    Latest firmware v3.1.1 still does not allow IPTV packets through in PPPoE mode.


  • @jon-nicholls said in No Multicast TV Channels after Router Swap:

    Latest firmware v3.1.1 still does not allow IPTV packets thr

    Not sure if you've tried this (I've just skimmed the thread).. I spent weeks trying to diagnose why Sky On Demand wasn't working for my boss using a Draytek 130 modem, in a similar setup to yours (using a Fortigate instead of an AmpliFi) and I changed the VC-Mux setting to LLU, and this instantly resolved.

    Not sure if it will make a difference in your scenario, but worth a try?


  • @martin-adams

    I'm now connected to FTTP, not FTTC and have NO access to the fibre ONT settings.
    Because I'm now on FTTP, a copper modem like the Draytek 130 won't work.

    The only way to rectify this is for the techs to fix the firmware to allow IGMP through a PPPoE connection as the inbuilt internet apps on the Youview box work fine.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.