Unreliable wifi issue


  • Hi,

    I have an AmpliFi AFi-HD Multiroom wifi kit which I bought a few weeks ago.
    I live in a house with 3 floors: ground floor, 1st floor and 2nd floor.

    The router is placed on the middle floor of the house (1st floor). The antennas are on the ground floor and top floor. Everything is nicely covered and I get good signal everywhere. Using the speedtest app I get about 60-70Mbps. Which is ok for me. Not great, but fast enough to do all what I want.
    My PC is connected by cable and I get 195Mbps, internet is capped at 200Mbps. Which is ideal.

    But when I move from one floor to another, it feels like I have less reliable internet. Sometimes I even get disconnected from a game I am playing (in this cas a supercell game called clash royale). It happens on all my devices: tablet and both phones. I get the feeling that my device stays connected to the antenna instead of switching to the router when I am closer to the router or vice versa. As if there is no mesh.

    I just ran a test in the amplifi app and I get 159,9Mbps down en 18,4Mbps up 13ms ping
    app says everything is great, connected for 21 days, 3 hours, 11 minutes

    Not sure if I am doing something wrong. Which is certainly possible, but the options are very limited. Its a plug & play solution.
    What can I do? unplug the antennas and only use the modem? Defeats the purpose of buying this system ofcourse.

    Many thanks


  • Is there an support service whom I can contact for this?
    Its becoming very annoying. Just lost connection again while in the middle of a game.


  • Hello @hung-tran This could be a roaming issue you are facing. If your mesh points have to great of a signal, the connection percentage to each point will be too high for devices to roam properly. Might I recommenced testing the connection through your entire house without the mesh points being plugged in. From there we can better test locations for performance. Also, another feature I would consider turning on and testing is router steering when you have the mesh points in the proper place.


  • Hi Brett,

    Is it not possible to tell the router/mesh points to take over faster? Because why would it wait until I have such a bad connection, up to the point I lose it before witching to a better connection point?

    I will do some testing and get back to you. Thanks for replying


  • Hi @hung-tran - it is the client device that decides when to roam and move to a different access point
    The mesh access points cannot actually tell a client device where to go or what to do
    The mesh access points can help try to influence clients using various methods and tricks, but every client device reacts differently to those tricks
    That is why having mesh points too close together can be a problem - if a client sees two very strong signals it may have a hard time deciding when to switch

    There are some options in the advanced web UI (amplifi.lan) that you can try if you have not already:

    • 802.11k
    • 802.11v
    • A-MSDU

    Not all client devices are compatible with these settings, so you need to check them one at a time with every client to be sure you do not have any incompatibilities and they actually help your situation and not degrade performance

    Finally, and this is just my opinion, if you are still within the return period, you might consider exchanging your HD Mesh System with 2 standalone HD routers, especially if there is a possibility that you can run a wired Ethernet backhaul line between them
    Two standalone HD routers can usually provide better coverage than a single HD router + 2 MeshPoints, but it really depends on the construction and layout of your home, so it is impossible to predict
    But it sounds like you have pretty strong signals with the MeshPoints, so that bodes well for a 2 HD router setup
    Wired Ethernet backhaul can improve roaming because it reduces the hand-off latency compared to the shared radios of the MeshPoints doing both client access and backhaul duty
    Just a thought to consider...


  • Hi Brett, Derek,

    Thanks for taking the time to help.

    I am confused now.
    I thought mesh wifi would create one big network, no matter where you are. I know very little about network etc. But why can't all three points just overlap a bit more. Lets say, I am connected to the router. I start walking down to the ground floor. While I walk down, why cant I take a little from the router and a little from the connection point? Why does it needs to be one or the other?

    I already had wifi issues before. First I thought it was because I was using the old non mesh version of devolo dlan 1200 + wifi. I bought a new set, the lattest one: devolo magic 2. But that didn't solve the random disconnects. Then I thought it was my phone (samsung s9), so I bought a new phone (samsung s10).

    In my local shop they recommended the AmpliFi AFi-HD Multiroom because it is currently one of the best on the market.

    I just want stable and good wifi everywhere in my house. My house is not even that big. 3 floors, 60m2 each.

    I have unplugged the antennas. And I just had a random disconnect again.
    On my computer, which is wired internet, everything works perfectly. I have googled for a solution and did some tests on speedtest by ookla and also pings through command. I have no package loss.

    I wouldn't mind buying a 2nd standalone router, if that would solve my problem. I have wired ethernet on each floor in the house. I would even buy 3 stand alone routers if that would solve my problem. If I knew anything about installing a proper network, I would even go for the corporate ubiquity solution. But I think what I have is already overkill.

    How can I test if my wifi is working properly? Because I just had a disconnect without the antennas plugged in and the router is 6 meter behind me in the corner of a room.

    I was thinking, maybe I have too much wifi stuff? I use Sonos, philips hue and have several tables, phones, computers etc.


  • Hi @hung-tran - sorry for creating confusion

    Mesh WiFi does indeed create one big single SSID network simultaneously on both the 5 GHz and 2.4 GHz bands
    A client device, like a phone or tablet, can only connect to one access point at a time, on one band
    (there may be some exceptional devices, but this is the general rule)
    Ultimately, each client device decides for itself which access point to connect to and on which band - that is the nature of WiFi
    The mesh network can give the client device advice (i.e. 802.11k) and play tricks (i.e. Band Steering) to try and influence the client to choose a particular access point, but it cannot control what the client does

    In theory, you can set up a mesh of independent access points, all with the same SSID and password, and it will work
    But a mesh system allows the network to influence clients, and "self heal" by re-routing traffic around a failed access point if needed

    Random disconnects can be hard to diagnose
    It is unlikely you have too much WiFi stuff
    AmpliFi HD's can handle a lot of devices
    You may not have enough total bandwidth to support a lot of devices under heavy load (i.e. multiple video streams), but you still should not be seeing disconnections

    There is a possibility of radio interference in your environment too
    Things like fluorescent lights, microwaves, or poor quality power bricks can cause interference and WiFi to temporarily drop
    You can create a Support Info file from the web UI support page and send it to @UBNT-Brett to check interference

    When the disconnects happen, is it during a roam when your client switches from one access point to the other?
    You might see the WiFi indicator drop or blink off as a hand-off occurs

    How can I test if my wifi is working properly?

    Remember, your client device is deciding which access point to connect to, and on which band
    If it has too many options, like it can see all 3 access points and a very strong 2.4 GHz signal from one AP versus a weaker 5 GHz signal, it may have trouble deciding which one to connect to, causing a pause and disconnect

    Here is what I would do (FWIW)...first start with the HD router, by itself (no MeshPoints plugged in)
    Centrally locate the HD router as best as you can, in the middle of the middle floor (1st floor in between ground & 2nd floor)
    Make sure Band Steering is enabled in the app (remember to always hit the check mark to save changes)
    Don't turn on any options in the web UI
    Turn off every WiFi and wired Ethernet client that you can, except the one WiFi device you want to test with, like your Samsung phone
    Turn off as many lighting and electrical appliances that you can as well - you want the cleanest radio frequency environment possible

    Now go around the house and check your WiFi signal and performance
    Pay attention to when you see your WiFi signal drop as you move away from the HD router, and then jump back up again, noting the location
    This is telling you when and where the client device is switching from 5 GHz to 2.4 GHz (which has more range, but less bandwidth)

    Create a map of your house to see how far the 5 GHz band is reaching and how far the 2.4 GHz band is reaching from the main router

    You may find that you have total WiFi coverage already, but your client device just doesn't like the hand-off switch from 5 GHz to 2.4 GHz and that is why you are seeing a disconnect during your usage

    Now go into the app and create a new Separate SSID, 5 GHz ONLY, and tell you client device to connect to it and forget the main SSID (you don't want your client to jump from the new SSID to the old one during testing)
    Walk around again and see if the WiFi coverage matches your previous map for 5 GHz

    Now go into the app and change the Separate SSID to 2.4 GHz ONLY, and repeat the check again for 2.4 GHz

    (If your reported disconnect issue is just related to switching bands between 5 GHz & 2.4 GHz there might be some other suggestions to try and fix it)

    You should now have a pretty good idea of how well the HD router can cover your house for both bands in ideal conditions

    Maybe the HD router isn't in an ideal position, or you have some dead spots (signal is weak on one side of the house, stronger on the other)
    Now move your HD router to where you might want it to actually be and provide the best coverage
    Then you have to go through the checking process again as building construction can greatly influence performance

    From here you have to make some judgement calls
    Do you for sure need additional mesh points to provide total coverage, especially for 5 GHz?
    Do you think you will need maybe just one or two additional mesh points?

    Your goal is to achieve total 5 GHz WiFi coverage where you need it with only a little bit of overlap
    2.4 GHz will then almost always overlap more, but Band Steering should prevent issues with switching

    I personally then recommend getting a 2nd HD router for additional coverage (if needed) - they just perform better overall
    And if you can use wired Ethernet backhaul, they perform fantastic because it is like an extension of the main router

    You only want enough mesh access points to get the coverage you need with a minimal amount of 5 GHz overlap - more is not always better

    If you need a 3rd mesh point, I would again recommend another HD router if cost isn't an issue
    Otherwise you can start placing additional MeshPoints or standalone Instant routers into the environment for additional coverage

    But you have to keep testing and checking as you go along

    Remember to set your client back to the main SSID and you can turn off the other Separate SSID's used for testing
    (you can also keep the Separate SSID's for devices that don't roam, like IoT, but note that you have to create Separate SSID's for each mesh point separately in the app!)

    As you build up the mesh you can turn on the rest of your devices and keep checking if anything changes
    If something starts breaking you need to try and identify what the cause is and then work around it

    You can also start to turn on the other options in the web UI as noted before and see if they improve performance and do not cause any incompatibilities:

    • 802.11k
    • 802.11v
    • A-MSDU

    Unfortunately it can take a lot of trial and testing to really get your mesh set up well, but it is worth the effort
    If you run into issues, report back here and @UBNT-Brett can help
    There are more options to look at and play with, like manually setting the channels, but hopefully that won't be necessary

    Sorry for the long post & good luck...


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.