Here we go again... year 2 of Teleport crashing

  • "Running into problems using AmpliFi Teleport? We're here to help"

    A year ago, days after the 2018 Australian F1 GP, my Teleports spontaneously failed into total bricks with blinky blue LEDs
    Attempts to fix them with Support, sending support files, and asking for help on this forum resulted in over 6 months of futile frustration
    By accident I noticed that the MAC address for the HD router had flipped (from the WAN to LAN)
    This resulted in killing UPnP, which I was originally using for Teleport
    It also killed the port forwarding rule that I had attempted to fix Teleport with
    The MAC address issue has been reported by multiple people, but AmpliFi still refuses to acknowledge it or fix it
    Eventually I just learned to live with using 2 port forwarding rules (one for each MAC) and having someone login and change which rule is active when these MAC flips randomly occur

    Now just over a year later (one week after the Azerbaijan F1 GP for the record) I once again have a blinky blue LED brick
    Teleport went offline while in use, which usually means a MAC address flip
    But this wasn't the case
    Checked everything and decided to unplug the Teleport and plug it back in

    From there things just got worse
    The Teleport SSID now would no longer appear
    Finally resorted to hitting the Reset button
    After connecting to the default SSID and going through the setup process - Teleport stays BROKEN
    After telling it what SSID to connect to, the portal says it will reboot and it never does - just sits there with a full circle blink

    Tried setting it to use an Ethernet connection, and it fails at Step-2 Internet
    I have many other devices working via Ethernet, but not Telepoort
    Its setup just fails over and over again

    I have done a Reset 20+ times attempting different SSID's on both 2.4 & 5 GHz
    Every time it fails to reboot and establish a connection

    If you unplug the Teleport, no SSID ever appears
    Only hitting the Reset button will bring back the default SSID

    Hi @UBNT-Brett - what can I do?
    Especially while remote away from the main HD router?
    Did you guys do something again with your certificate exchange backend servers?

    "It’s simple: connect your AmpliFi Router at your home and take the AmpliFi Teleport device with you wherever you go."
    "Teleport allows you easy access while you are away from the most important place – your home."

    You guys claim Teleport is supposed to be easy to use...well it's not

    "Whether you travel for business or pleasure, use AmpliFi Teleport and feel secure knowing you can still connect to your home."

    No, I can't

    "AmpliFi Teleport works with Wi-Fi or wired Ethernet setup."

    No, it doesn't

    When is Teleport going to be fixed?

  • This is sad news since I actually want to get one especially since. I head about a firmware re write, but I can't get one here in Australia sadly.

    Your unit sounds bricked sadly.

  • Hi @UBNT-Brett - please explain what I am doing wrong...

    Press & Hold the Teleport reset switch until it resets
    Wait for Teleport to reboot
    Connect to default Teleport SSID and enter configuration portal:
    Create new Teleport SSID & Password
    Continue Setup
    Select a Local WiFi SSID:
    Enter Lcoal WiFi SSID Password:

    From here Teleport NEVER restarts
    It does nothing but sit and blink a full blue circle - tested for 24 hours

    Unplugging Teleport and plugging back in results in the same full blue circle blink with no SSID broadcast
    It never goes through the rapid circular motion pattern

    Try with Ethernet cable connection instead:
    Plug in the cable:

    It never completes Step 2 - Checking internet

    This is plugged into the same remote location HD router that all other Ethernet devices and WiFi devices are using and working properly
    I have tried rebooting modems and routers
    I have tried with other WiFi connections in the building and cellular hotspots
    The home internet connection is working properly and I have rebooted the home modem and HD router the Teleport is paired with

    If I go the Support tab and generate a Support Info file it saves a zero byte ZIP file called

    What's next?


  • Hi @edward-dolezal - when Teleport works it is in my top 3 best tech products of all time
    When it doesn't work, it is tied at the bottom as one of the two worst tech products I have ever owned
    And it is has not worked...a lot

  • @derek-saville tour non reboot issue I've had that before with a router in bridge mode, where it and the mesh points would the entire network I know it's something to to with a more recent firmware it seed that the connection would only become stable if I factory reset the main router, I was wondering if you already tested that just wondering that's all.

  • @edward-dolezal - thanks for the advice

    The home HD router is still on 2.9.3 as I have not seen any need to update it and there have been too many issues reported with 2.9.5
    And there is no way I can factory reset it while traveling

    Teleport has remained on 2.7.1 for a long time

  • @derek-saville ahh I see, I had no issues with 2.9.5 some people have issues that are from other hardware that they connect, is the same story on the Asus side of things, I'd upgrade and see if it works.

  • Hi @edward-dolezal - I don’t believe in updating working firmware unless there is a compelling reason or need

    Both AmpliFi networks at home and abroad have been rebooted and are working flawlessly

    I don’t know what actually happens during the Checking Internet step, only that it is before the connection to the home HD router based on the descriptions

    AmpliFi must have a backend server which allows Teleport to find its paired HD router server (their own home brew DDNS) and exchange certificates / keys for Teleport to work

    I have suspected failures of their backend Teleport servers in the past when Teleport won’t connect or exhibits strange behavior

    So I am going to assume something happened to my Teleport’s connection to their servers, or a certificate / key has been revoked or corrupted

    So will wait impatiently, not watching NBA or NHL playoff games, until @UBNT-Brett says to try something different

    I sure hope it isn’t an unpair / re-pair as that isn’t possible with the current firmware and 6,000+ miles between devices

    But based on last year’s Teleport failures, my expectations remain skeptical

  • @derek-saville I am currently looking into issues if any that we have had on our end. My personal device worked over the weekend but thats not conclusive. Your experience with Teleport leaves me no doubt that you have done everything correctly, the next steps would include re-pairing as a test which means being in the proximity of the home network, or as @Edward-Dolezal stated you may have a malfunctioning device.

  • Thanks @ubnt-brett - I was only watching the Milwaukee Bucks game live on the Xfinity app when the picture froze and I looked over to see a blue blinking circle

    This usually means I have to change the port forward rule to the other MAC, but not this time

    Can you send me links to the last couple Teleport firmware releases so I can see if it somehow corrects?

    Will manually updating Teleport’s firmware break the pairing?

    I would like to try before FedEx’ng the thing back and forth to the US

  • Hi @ubnt-brett - I reapplied firmware 2.7.1 to the Teleport, but the problem still exists
    However, I was now able to generate a proper Support Info file, instead a zero byte file
    I have sent the support file to your UBNT email address
    Please let me know if you have any further advice - thanks

  • Wow I thought my device getting stuck at the third step was bad haha. I have actually switched away from this, great idea but not very intuitive. The inability to see logs and troubleshoot ourselves is also a pretty glaring sticking point.

  • Hi @michaele - I hope they eventually realize that “local proximity re-pairing” is not an acceptable repair solution to fix a product inherently meant to be used far (at times very very far) apart from each another

    I just haven’t had the time to set up a couple of Netgate’s to replace the Teleport...

  • Thank you for the support info file. It helped us to identify the root cause:

    NTP servers were not white listed in Teleport configuration and Teleport could not synchronize time. Correct time was needed for SSL connection that is used to get the router connection details.

    The fix is planned to be released today. I'll keep you posted.

  • Teleport firmware version 2.7.3 has been released. Update notification should appear near the Support button.


  • Teleport firmware successfully updated to 2.7.3 and everything appears to be working properly.

  • Thank you @ubnt-karlis!
    Can you please send a link to the 2.7.3 firmware so I can do a manual update?
    My teleport is now stuck "offline" and won't receive the update notification

  • @derek-saville - I don't have a link to the update. I have not used the Teleport since upgrading the Apmlifi HD to 2.9.5 a couple of months ago and decided to test the Teleport with the HD prior to a trip next week. I couldn't connect the Teleport to the internet so I performed a paper-clip reset and the 2.7.3 update appeared, so I performed the update and tested with the HD firmware v2.9.5 and have no apparent problems. I suggest you try the paper-clip reset, you have nothing to lose.

  • @derek-saville I sent you the link to the firmware download privately.

  • Hi @ubnt-karlis - I can confirm that manually applying firmware 2.7.3 corrected the problem

    Thank you for following up!

Log in to reply