Terrible WiFi speeds


  • Well, as the title says, I get miserable WiFi speeds on this thing. I have tried both the AmpliFi Mesh Wi-Fi System and the AmpliFi Mesh Wi-Fi System Gamer's Edition. I am currently using the Gamer's Edition.

    I am subscribed to 400mb/s download speed from Comcast, which works perfectly fine when hardwired to my SBG6782-AC or the AmpliFi Mesh Router. I get my speeds of 400mb/s and sometimes above. I have the WiFi disabled on the SBG6782-AC, and only use WiFi on the AmpliFi Mesh System, getting a MAX of 80mb/s at any given time, but it's generally around 50-60, occasionally dropping lower. These issues are AmpliFied if more than one device is downloading something at the same time, causing the WiFi to basically stop working.

    I have enabled hardware NAT.
    I tried both the Latency and Throughput settings on the Gamer's Edition, and it is much better on Latency (speeds and ping).
    I logged into http://amplifi.lan and made sure my download speeds are correct and tried A-MSDU with no changes.
    I've tried static IPs, all three different optimization and port forwarding for devices.
    I set my DNS servers to static addresses.
    My devices is completely up to date.
    I've tried with both Band and Router steering off and on.
    I tried to use bridged mode.
    I've tried adjusting the channels.
    I can turn on WiFi on my SBG6782-AC and get speeds over 200mb/s easily.
    I've tried multiple Ethernet cables coming from various ports on my modem.
    I've moved the MeshPoints to various different locations, as well as tried using just 1 instead of 2.

    This has been an on-going issue for almost a year now, and I've tried just about every thing I can think of, including submitting a support ticket, and they told me that it's just as fast as these terrible devices can go, but reading the forums, that's obviously not true.


  • @timothy-henderson said in Terrible WiFi speeds:

    I have the WiFi disabled on the SBG6782-AC, and only use WiFi on the AmpliFi Mesh System

    You said you tried using bridge mode, but some modem/router combos have the ability to simply disable wireless not DHCP functionality and that can create a double NAT. In your testing have you left AmpliFi in DHCP mode and then placed the surfboard into full bridge mode?

    Also, please begin speed tests with the mesh points disconnected and only pulling data from the router, this will help us narrow down where the performance drop is coming from. Use a 3rd party speed test over the built in AmpliFi speed test as well.


  • I received a download speed of 73mb/s with only the Router, 87mb/s with the router and furthest mesh point, 79mb/s with router and closest mesh point, 103mb/s with all on, which is probably the highest speed I have ever seen this thing do.

    I have put the modem in full bridge mode and tested it, but I will do it again when I can to verify speed when I get a chance.


  • @timothy-henderson Very unique results with the performance getting better the further away you get from the main router including mesh hops. We know AmpliFi is delivering full speeds based on wired tests, so wirelessly from the main router with all Meshpoints disconnected should yield greater speeds than 73 mbps.

    On the Gamer's Edition, you will have additional settings in the WebUI while in Latency mode. Will you be limiting bandwidth on devices in Latency mode, and default is 100 mbps (See photo) Testing on Latency mode will yield these results so to test peak performance lets switch back to throughput mode and test again.
    0_1557329170787_Screen Shot 2019-05-08 at 9.22.19 AM.png


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.