Why port forward not works?


  • Hi,
    I've this configuration on my WDSL connection.

    An antenna with DHCP disabled and an Amplifi router connected via LAN with a static ip address:

    • Ip Address: 192.168.0.100
    • Network mask: 255.255.255.0
    • Gateway: 192.168.0.251 (Antenna)
    • Primary DNS: 8.8.8.8

    I've purchased a static ip address, my purpuse is to expose a simple SSH server of my raspberry in this way:
    ssh <ip>:222

    So, I've configured the antenna port forward:

    • Interface: PPP
    • Private IP: 192.168.0.100 (the amplifi router)
    • Private Port: 222
    • Type: TCP
    • Source IP/Mask: 0.0.0.0/0
    • Public IP/Mask: 0.0.0.0/0
    • Public Port: 222

    And in the Amplifi router, I've set the port forward:

    • IP Address: 192.168.1.102 (My raspberry)
    • Source port: 222
    • Dest post: 22
    • Protocol: TCP

    Now, if I execute a nmap command:
    nmap -p 222 -sV -P0 <ip>

    I always receive:
    PORT STATE SERVICE VERSION
    222/tcp filtered

    If I remove the 222 rule on the antenna, the nmap returns "Closed".
    I think that the problem is on the Amplifi that doesn't route the traffic.
    How I can solve?

    UPDATE
    I've request the access to ssh server of my antenna.
    When in, I try to connect (always through SSH) to raspberry passing by amplifi router:

    • ssh <ip_antenna>
    • $ ssh -p 222 192.168.1.100
      but I have "Connection timeout".
      Same issue if I remove the rule into Port Forward options of Amplifi. Seems that the rule isn't considered.
      At the end, with rule or without rule the result is the same.
      I suppose that this shows that the antenna Port Forward works and there are some issues with amplifi port forwarding feature.

    The Amplifi settings
    0_1557907858361_photo_2019-05-15_10-10-37.jpg


  • @francesco-pace I believe support has provided a few possible solutions after reviewing the support files you provided. Thank you for reaching out and providing those! Can you please update me on the current status so I can assist further if needed.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.