Amplifi instant mesh point not connecting

  • Hi All!

    I've purchased an amplifi instant router and mesh point combo. The router works beautifully but i cannot get the mesh point to connect. When i plug it in, nothing shows in the app. It is about 2 meters away, so it cannot be a wifi range issue.

    I ran through all troubleshooting with AmpliFi helpdesk (i.e., using paperclip to reset router / mesh point and starting setup from scratch). This has not worked. And i've done it 3 or 4 times.

    So i returned my mesh point and have just received a replacement under warranty. The new mesh point also will not connect! and i've again tried the full paperclip reset routine and this also has not worked.

    Any suggestions greatly appreciated!


  • Hi @daniel-murphy-0 - just to check, do you have Bluetooth enabled on the your device running the app?

    How did you purchase the original Instant System? 3rd party or new in box from a store or online?

    I believe the Instant MeshPoint in the System should also have two MAC addresses on them, one the MeshPoint and one that matches the Instant Router it is paired to - can you confirm?

    When you sent the mesh point back under warranty, did you send back both the Instant Router and the Instant MeshPoint?

    The Router and MeshPoint are factory paired together, so they have to be replaced in pairs together.
    It wouldn't work just to have the MeshPoint replaced...unless they somehow repaired it and sent the same unit back (check the MAC address labels)

    Your original Instant MeshPoint may have been defective, or it may have been a store return that somehow got mixed up and not properly matched the router

    And your replacement MeshPoint now may not be correctly matched to the Router with the hard coded pairing

    If you have an Ethernet cable you could try plugging it in to Router & MeshPoint to see if it will enable wired backhaul or throw up some other sort of error code
    In theory this should not work because you are supposed to wirelessly pair the MeshPoint first before enabling Ethernet backhaul, but it wouldn't hurt anything either to see what happens

  • Right. I think i get what's happening. The original MeshPoint didn't work. So i returned only the MeshPoint, and kept the router. Then the retailer has sent me a new MeshPoint only (they definitely did not repair it). So it won't be matched with the router anymore. Guess i will have to return everything then!


  • I have been having this same problem. I purchased my kit back in Dec 2018 and the second Mesh Point wasn't needed until lately. Now when I try to set it up - it never connects with the Amplifi Router no matter how close I connect it. I have tried completely factory resetting the three pieces in the correct procession together with the support chat guys, but it just never connects. Unfortunately I didn't see this issue until after my warranty ended (typical). Is there an underlying issue here, can the mesh point be defective? Can I just by a standalone mesh point or second router to widen the WiFi reach?

    Thanks for any solutions.

  • Hi @Tyrel-Gidinski - the MeshPoints from the kit should have a bar-code label on the back listing two MAC for the MeshPoint and one for the HD Router it is bonded too
    alt text

    If you can confirm that the MeshPoint that will not connect is NOT hard coded to your router then will know they will never connect

    can the mesh point be defective?

    Yes, but it is usually the power supply that goes out
    If LED's are lighting up when you plug the MeshPoint in then you can rule that out

    Can I just by a standalone mesh point or second router to widen the WiFi reach?

    Yes, you can add any standalone device (other than an Alien) to an HD kit mesh

  • Hi Derek,
    I bought an amplifihd kit some time ago and only one of the mesh points managed to connect it to the router.
    The other, despite the appearance of a wifi network "AFi-P-HD-F61326 Recovery", the application doesn't detect this mesh point. What can I do more?

    I've tried to reset all devices and still won't turn on.

  • Hi @André-Silva - if you have a MeshPoint from a kit broadcasting an SSID with ‘Recovery’ in the name then it sounds like it has been placed in Recovery Mode, which allows you to update firmware or restore the device from an unstable condition

    Can you connect to the “Recovery” SSID and use a web browser to go to amplifi.lan to see what options are there to restore it?

    I suggest you contact AmpliFi Support via email or chat and tell them you have a mesh point in Recovery mode and need to ensure you have the correct firmware to match the rest of your system and ask for instructions to get it back online

    @UI-AmpliFi may be able to help as well if you send them a direct chat message

Log in to reply