Slow wifi speed on Macbook after wake


  • I've got some issues that I can easily get rid of, but it's very annoying.

    Every time I open up my MacBook (both MacBook Pro and MacBook), the wifi is super slow even though I see I'm connected in the exact same way (option+click the WiFi symbol in status bar) as usual.
    Instead of the regular 4-500 MBit/s, I get like 10-15 MBit/s. I can easily fix this with a manual disable wifi/enable wifi. Connect the exact same way again, and the speed is 4-500 MBit/s once again.

    And yes, I've tried to disable Apple Watch unlock for the MacBooks. I read somewhere that this could be the issue, but it doesn't change anything.

    This is kind of annoying though. Am I alone with this issue?

    MacBook Pro (2017)
    MacBook (2016)
    Amplifi Firmware version 2.9.5 (I haven't created any groups for my connections in the Amplifi app)


  • I have the same issue on MacBook Pro (2017).
    Amplifi FW 2.9.5


  • Here is something to try: open a browser and go to http://amplifi.lan . This page will show an extra set of settings for your router. Log on using your router password and check the settings. In the advanced settings section there should be three 802.11 options. Make sure the r-fast BSS transition option is disabled. The other two 802.11 options (k and v) can be on but the r option causes all kinds of slowness issues on Apple devices I have found.


  • @jao-van-de-lagemaat I’m afraid this is already disabled.

    Looks like this (I’ve tried to disable everything also, without any success).

    0_1558892736863_74A3C6CA-11F0-43FD-95A5-A4DC67B84D5B.png


  • @david-svensson I currently am not having these issues with my 2016 MacBook Pro. The next time you experiencing this issue and disconnect then reconnect to return performance will you generate support files from your AmpliFi App and reference this community post so we can research this further?

    @YI-Cam If you can do this as well that would be great so we can see what exactly is going on.


  • I'm having the same issue on my 2017 MBP running Mojave. Disabling sleep resolves it, but that is not a long term solution. I'll collect a support file and submit in the next day or so.


  • Support file just sent. Thanks for the review.

    Mark


  • Looks like the new 3.1.0 firmware solved the problem for me.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.