Teleport's SSID disappears when WiFi source is off


  • I have had the problem of my teleport's SSID completely vanishing into thin air when the wifi sourse it is connected to is gone or turned off. I am then unable to connect the Teleport to my laptop to hook it up with a new wifi source and it would only work with the original one which is useless if I am away from my initial wifi connection. The only way to get it back is to do a hard reset of the device which is really a bit of a PITA. Is this a known issue and is there a solution for this problem?


  • @ali-hadi This is not a known issue that has been reported to me as of yet. Can you let me know what firmware versions both your AmpliFi and Teleport are currently running?


  • @ubnt-brett Thank you. Both are running the latest 3.0.0 firmware (hardware versions 19 and 5 respectively). Fully updated a few days ago when I got my Teleport. I am in a way glad to know that this is not how it should be but I am eager to know if my problem could be solved. Tried another reset followed by unlinking both on router and teleport and then relinking to no avail.


  • @ali-hadi After you experience the issue, can you generate support files from both AmpliFi as well as the Teleport so we can research this further. After that, let's test to see if it was caused by the update and have you roll back the FW to 2.9.5 on both devices as well.



  • @ubnt-brett Not sure if attaching the files as I did was the right way to sending you the support files. I again appreciate you looking into this. If I end up downgrading the firmware, will I lose any important featues?


  • @ali-hadi As long as your on the HD kit and not Instant or Gamer's Edition you will be ok to downgrade without sacrificing any features.


  • Further testing: Mobile hotspot from my mobile phone is on and is connected to Teleport = Teleport's showing up on the Amplifi app and SSID broadcast and seen everywhere. Switch hotspot off and Teleport will obviously disconnect and appears greyed out on the app but also SSID completely disappears and cannot connect to device again (without a reset). Switch the phone's hotspot back on and everything is working as normal again with the device showing up on as connected on the app and the SSID broadcasting again to all. This bug I am encountering on the latest firmware installed on my router and the teleport is so blooming consistent. Do you people think that I have got a faulty unit here?


  • Hi @ali-hadi - what does the Teleport blue LED do when the source is turned off?

    Is anything connected to the Teleport’s LAN port?


  • @derek-saville Thanks Derek. I was really waiting for your input as you seem to have gone through all sorts looking at the various threads on these fora. The LED is blinking in full circle mode when wifi source is turned off and no LAN port is free throughout.


  • Going through the various threads here, I have stumbled across at least two that describe my exact same problem with no clear soltion identified.

    https://community.amplifi.com/topic/1675/teleport-from-different-locations

    https://community.amplifi.com/topic/1595/is-the-teleport-software-broken

    It seems I am not alone here!


  • Hi @ali-hadi - I will replicate your failure mode and see what happens on my setup

    I have gone through situations where I can’t see a Teleport SSID, but not specifically from the host WiFi dropping

    When you get into that situation, what happens if you unplug the Teleport and plug it back in to reboot it?


  • Thank you again Derek. When I reboot the device, if the host wifi is available, then everything works as expected straight away but if the host wifi is unavailable then all I get is the blinking blue circle with no SSID from the teleport to be able to connect to it and choose a different wifi source. Are you also running the latest firmware and if not then what firmware versions have you found to work best on your Amplifi router and your teleport? The fact that everything else works perfectly and that I have no issues when the host wifi remains available and unchanged makes me suspect that this is a software rather than a hardware issue. I have, however, initialted a return process for the device to Amazon as it is still within the return period and will proceed with this if there is even the slightest possibility that this is hardware-related.


  • Hi @ali-hadi - I recently updated to v3.0.0 on all devices
    I can confirm the same behavior as you are experiencing

    @UBNT-Brett should be able replicate very easily

    When the host WiFi goes down, after a slight pause Teleport stops broadcasting its SSID
    Teleport then does a slow clockwise LED pattern (not the faster one at the end of a connection setup)
    Then Teleport has a blinking full circle with no SSID ever broadcast for setup

    Unplug the Teleport to reboot and it does the up-down pattern before the full circle blink and no SSID is broadcast for setup

    If you really feel like troubleshooting you could try manually installing Teleport Firmware v2.7.3 which was the last stable firmware for me that I was using...or just leave it to the AmpliFi guys


  • @derek-saville you are a star. Thank for confirming the error and the link for the older firmware. I have downloaded the 2.7.3 and will keep it as a backup for troubleshooting but would be hopeful that the team could work on a fix quite soon. Will I need to downgrade the router's firmware as well? Thanks again.


  • Will I need to downgrade the router's firmware as well?

    HI @ali-hadi - no, you can rollback the Teleport firmware separately from its Web UI Setup page and leave the router on v3.0.0 unless you are using a GE or Instant router
    Teleport support was only officially implemented for the GE & Instant with v3.0.0, so results of other combinations may be unstable


  • @derek-saville Thanks for the info. I am using the AmpliFi HD mesh kit and have just recently decided to import one of the Teleport devices to the UK to give it a try. All I have to say is "was a kickstarter and should have stayed a kickstarter".......... Really disappointing for a device that claims to be able to penetrate the great firewall of China not to be able to penetrate my own modem without manually setting portforwarding! This is so not ready for prime time after such a huge length of time since it has been released. There are some very basic things that could be done to improve its functionality like using its bluetooth or wifi to allow it to be set up using the app rather going through all the palaver of using the web UI which may or may not work. One would also need a PhD in IT and networking for a device that was meant to be a travel companion to solve all your networking woes. As for captive portal issues that I have been reading about on these fora, then don't even get me started. I will unfortunately continue to carry my trusty Gl.iNet router with me on my travels when I was hoping that this one device could rule them all.


  • Hi @ali-hadi - maybe someday...

    PS: I have carried a travel router and Bridged an Ethernet connection to the Teleport in the past
    A kluge solution, but it works in circumstances where the Teleport cannot be set up but a travel router can


  • Banned
    This post is deleted!

  • Banned
    This post is deleted!

Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.