upnp error 500


  • I have the router behind the ISP modem in a DMZ zone. I disabled the upnp handing in the operator router and enabled it in the amplifi. But each time I am trying to add a port mapping I get an error 500:

    <s:Envelope xmlns:s=\"http://schemas.xmlsoap.org/soap/envelope/\" s:encodingStyle=\"http://schemas.xmlsoap.org/soap/encoding/\">
        <s:Body>
            <s:Fault>
                <faultcode>s:Client</faultcode>
                <faultstring>UPnPError</faultstring>
                <detail>
                    <UPnPError xmlns=\"urn:schemas-upnp-org:control-1-0\">
                        <errorCode>501</errorCode>
                        <errorDescription>Action Failed</errorDescription>
                    </UPnPError>
                </detail>
            </s:Fault>
        </s:Body>
    </s:Envelope>
    

    I'm sending:

    <?xml version=\"1.0\"?>
    <s:Envelope xmlns:s=\"http://schemas.xmlsoap.org/soap/envelope/\" s:encodingStyle=\"http://schemas.xmlsoap.org/soap/encoding/\">
        <s:Body>
            <u:AddAnyPortMapping xmlns:u=\"urn:schemas-upnp-org:service:WANIPConnection:2\">
                <NewRemoteHost></NewRemoteHost>
                <NewExternalPort>8333</NewExternalPort>
                <NewProtocol>TCP</NewProtocol>
                <NewInternalPort>8333</NewInternalPort>
                <NewInternalClient>192.168.145.213</NewInternalClient>
                <NewEnabled>1</NewEnabled>
                <NewPortMappingDescription>192.168.145.213_TCP_8333</NewPortMappingDescription>
                <NewLeaseDuration>3600</NewLeaseDuration>
            </u:AddPortMapping>
        </s:Body>
    </s:Envelope>
    

    Any idea why? How can i get the error on the router? It seems it is answering to v1 and v2 but v2 doesn't work.


  • Hi @benoit-chesneau - this may have nothing to do with your case but worth a quick investigation

    AmpliFi routers have separate MAC addresses for the WAN & LAN connections

    There have been issues in the past where the MAC address reported to an upstream router flips between the 2 breaking UPnP and/or port forwarding rules

    It originated with the implementation of HW NAT code and affecting Bridge mode (which ironically doesn’t NAT) and changing back & forth between the options


  • hrm interresting, i just switched from bridge to router mode.... I will check. How did you fixed it?


  • so i'm not sure what's the issue but upnp v1 works but not upnp v2 so it may be a bug in the implementation 😕


  • i tried with the upnpc client and got the same error as my own client:

    ○ → upnpc -n 192.168.145.2 8000 8080 tcp
    upnpc : miniupnpc library test client, version 2.1.
     (c) 2005-2018 Thomas Bernard.
    Go to http://miniupnp.free.fr/ or https://miniupnp.tuxfamily.org/
    for more information.
    List of UPNP devices found on the network :
     desc: http://192.168.145.1:5000/rootDesc.xml
     st: urn:schemas-upnp-org:device:InternetGatewayDevice:1
    
    Found a (not connected?) IGD : http://192.168.145.1:5000/ctl/IPConn
    Trying to continue anyway
    Local LAN ip address : 192.168.145.2
    GetExternalIPAddress failed.
    AddAnyPortMapping(8080, 8000, 192.168.145.2) failed with code 501 (Action Failed)
    GetSpecificPortMappingEntry() failed with code 714 (NoSuchEntryInArray)
    

  • @benoit-chesneau Thank you for reporting this! We have now addressed this issue and a fix will be released in the next beta firmware. Are you enrolled in the beta program?


  • @ui-brett yes 🙂 I will test when the update is available 🙂


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.