Slow amplifi HD WiFi (resolved)


  • Just wanted to share my story after having issues with my Amplifi HD WiFi speeds after moving house.

    So before moving I always had about 250-300mbps from the app speed test, which was acceptable, in my office at my old apartment with a 600mbps fiber connection from my ISP, Movistar, in Barcelona.

    After moving to a new apartment the WiFi speed dropped significantly, at first I was getting about 30-50mbps via a speed test in the app and then a bit better with speedtest.net around 80-90mbps. I tested the connection via LAN and got the full 600mbps speed, so I knew the problem was WiFi related.

    My setup was ISP > Modem > ISP Router (with WiFi disabled) > Amplifi HD > Devices. Exactly the same hardware setup as before moving with a separate ISP provided 2.4g/5g repeater hooked up to the ISP router for the digital TV box connection.

    First thing I tried wash running a survey to switch to open 2.4g and 5g channels. After trying several channels and seeing no difference in speed I done a factory reset and setup everything again including the mesh points. Then contacted support who advised switching again to free channels and running a separate dedicated 5g SSID to run tests with which made no real difference to the WiFi speed. I sent lots of details and speedtest results along with the support file downloads to Pearl in the support team.

    The following day I enabled A-MSDU and unplugged the 2.4g/5g repeater, disabling it and rolled back to version 2.9.5 but didn't see any real difference in speed. Support had also emailed me to suggest enabling A-MSDU which I'd already done and I switched back to 3.0.0. I then moved the Amplifi router a bit further away from the ISP hardware and a solid wall close to the ISP wall socket and noticed a bit of an increase in speed with the 2.4g/5g repeater also plugged back in. Later that day I got a cardboard Ikea box to place the ISP hardware in and located the Amplifi router and ISP hardware further away from the solid wall. This improved the speed to 150mbps.

    Based on this progress I dug out a much longer cat5 cable and relocated the Amplifi HD router much further away from the solid wall (approx. 4 metres from the wall and around 3 metres from the ISP hardware in the IKEA cardboard box). This fixed the issue and WiFi speed jumped to almost 500mbps.

    I'm sharing this because the location of the Amplifi HD router makes a huge difference to the WiFi performance. Ubiquity do recommend that this router be placed as close to the middle of a house as possible but most importantly moving the router away from the solid wall and ISP hardware made all the difference. I really couldn't believe the impact this had, running a bunch of tests around the apartment and seeing much much faster speeds.


  • Was the "solid wall" a masonry/brick wall or wooden frame/plasterboard wall? Masonry/brick walls are definitely a wifi/cellular signal killer.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.