Firmware v3.0.1


  • AmpliFi firmware v3.0.1 has been released
    Release notes:

    • Resolved guest network bridge mode issue
    • Improved security
    • Improved stability
    • Teleport improvements
    • Web portal enhancements

    We use gradual update rollout. It may take up to a week for your device to receive this update.

    Thank you!


  • Hi @ubnt-brett & @UBNT-Karlis - when I updated a HD Router which operates in Bridge mode, this release changed the WAN side MAC address prefix from f2 to f0 breaking its static IP assignment and causing a Teleport to fail to connect

    This WAN side MAC address flip-flopping bug for HD Routers in Bridge mode has been going on for over a year now, although it has been more stable recently


  • @ubnt-brett I updated yesterday, and it seems the router is now broken. After pressing on the display to update i waited 6 hours but it's stuck in boot some how. Tried to hold reset button, and i get normal display but the router has no ip and ethernet ports don't work. If i power cycle the router again is stuck in boot, and just display the logo. How can i do rollback of update when i'm not able to access the router with app?

    Cheers
    Lasse


  • @lasse-hansen I have sent you steps to try and manually install the latest FW. Please let me know if that worked.


  • @ubnt-brett Thanks Brett, this work like a charm and it's up and running again.

    Cheers
    Lasse


  • @UBNT-Brett Something must've gone very wrong here.. Measured speed on 2019-06-09 was 91,6 down and 9,6 up with 4 ms ping which is very good on a 100/10 line. After todays update I get 1,8 down and 0,6 up with 5 ms ping. Any ideas?


  • @marcus-bosse-söderberg There is a rollback feature available through the webUI. What I would recommend first it attempt to power cycle your network and see if performance returns. If you are still seeing reduced speeds then roll back to v3.0.0 and test again.


  • @ubnt-brett Did a full power cycle, no change, rolled back to 3.0.0, still no change.
    I will hook up my laptop directly to the fiber node tomorrow to ensure that nothing has gone wrong there before trying a factory restore on the AmplifiHD.


  • @marcus-bosse-söderberg If you rolled back and had no change then the FW update was more than likely not the cause for this drop. If you are performing a factory reset, I would recommend updating to v3.0.1 first, creating a backup of your configuration on the WebUI, then reset.
    Here is an article about Backing Up your configuration.


  • @ubnt-brett hi Brett, my upgrade to 3.0.0 went smoothly but 3.0.1 has not gone well. It was triggered by the main router via the screen (is there a way of hiding that so it only prompts via the app?). I have two AmpliFi HD (main one and a secondary one connected via power line) and a mesh point. The main AmpliFi HD applied the update and restarted and then a few minutes later said it needed the update again (I dismissed it as I found that strange). Everything seemed to be back up. Looking at the app is says my main AmpliFi HD is now on 3.0.1 (I didn’t reapply the patch) and my secondary AmpliFi HD (connected via power line) and is offline and the screen shows the “Connecting...” message. I will leave it overnight but I think something is wrong with it and I hope it resolves overnight.


  • @John-M If it prompted you to update a second time, it is because one of the nodes on the network failed to update. This very well could be your second AFI-R, and the screen you described is an indication if it no longer receiving data (like the ethernet cable is unplugged or something.)

    My recommendation is to move the secondary AmpliFi HD into the same room as the primary, connect the secondary directly to the primary to eliminate the possibility of the powerline adapter causing any issues, and make sure it connects. If it does, update and make sure it connects once the update is finished. If everything seems to be running smoothly, relocate to its original location and use the powerline adapter again. If it fails back in the original location we may have an issue with the powerline adapter.

    Rolling back firmware is an option as well, but you will want all nodes online before rolling back to make sure all stay on the same firmware.

    Oh, and to answer your question, no the LCD screen will show that there is an update without the ability to disable that feature. If you select dismiss, it will reappear the next day since it checks the servers daily for updates.


  • A power cycle got it back up and running and I ran the update over powerline once more as the powerline connection showed that it was fine. It applied this time around. Is it possible to add an option to the app/web to hide update messages from the AmpliFi HD screens to prevent accidental updates? Thanks for the quick response.


  • After the update, the devices will only connect to the router even if they are closer to the mesh point, any ideas?


  • @ubnt-brett Heh. I just came home and ran the ISP-test, got 106/10.3 now. And this with 3.0.1. Seems that it was a line-down at the absolute worst possible timing... Thanks for the support to try and help me! ☺


  • @aadil-allana Will additional SSID's created from the mesh points allow devices to connect? This is the first reported issue of this kind after the update. Maybe try power cycling the network including mesh points and for testing purposed disable router steering.


  • @marcus-bosse-söderberg What speeds do you expect from your ISP and what speeds were you getting before the update? If this comes at a bad time for you, I would recommend using the WebUI and roll back the FW so you have the performance you need. Also, thats a good test to see if it was indeed the update thats causing this issue.


  • @ubnt-brett I'm on a 100/10 connection and had 91.6/9.6 before the update, then afterwards I got 1.8/0.6. I did all the rollback but still only got 6.5/0.8. Updated again, but no change. Tested again this morning without any changes being done and received 25/2 and on arrival after work 106/10.3.
    This time I agree with you that it was the uplink and not the update that was the culprit.


  • I’ve just updated to 3.0.1 from 3.0.0 and my Amplifi HD is just stuck with updating on the screen for the last 20 mins. I’m reluctant to reboot the device during this time. The SSID is present but won’t let me connect (involved password is says).

    Any ideas what’s going on?


  • @ade-thompson You are safe to power cycle it at this time, and if it failed to update or corrupted during the process I can help you place it into a recovery mode to re-install the firmware.


  • @ubnt-brett ok so it eventually asked to update the main router again (I noticed the mesh points had updated) and this seemed to be through successfully. All working ok. Any idea why the update took so long and needed a second install?


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.