Teleport Incredibly Slow


  • I'm running Teleport on the latest firmware. Home network is Verizon FiOS, 1Gbps and the remote network I'm on is also at 1Gbps. However, when running speedtests on the devices I notice that I am only getting 5Mbps. Is there anything I can do to fix this?


  • Mine is also inherently very slow and I don't think much could be done apart from waiting for possible improvement with future updates.


  • Hi @steve-choi - is the AmpliFi router that your Teleport is paired with also your main router?

    I am not familiar with Verizon FiOS, but for testing purposes if you can run the AmpliFi router serving your Teleport in Bridge mode it can give you a better idea of what the platform is currently capable of

    As @Ali-Hadi stated, Teleport users are hoping for some performance improvements with the coming Teleport updates (primarily the implementation of a kernel mode VPN on the router side), but there has been no confirmation yet (please @UI-Brett?)

    I can obtain a very consistent 8 to 10 Mbps from the US to Asia in Bridge mode with peaks in the 12 to 15 range

    If your AmpliFi is also functioning as a router, it is a possibility that it may not have the cpu bandwidth to process packets for 1 Gbps service and do the VPN processing to manage more than the 5 Mbps you are currently getting

    I assume you have hardware NAT enabled, but QoS and WiFi processing are all eating up CPU time too

    A lot also depends on your internet connection at the remote end (latency and bandwidth) and the type and origin of the source data you are trying to send (internet sourced like Netflix vs. local served)


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.