IOS devices having trouble to stay connected in standby mode

  • I installed a month ago the Amplify HD, wireless coverage is absolutely great but I notice a strange behaviour on some of my IOS devices, an issue that I didn’t have before.

    Some of the devices (iPhone, iPad) do have trouble when in stand-by mode. They should stay connected for incoming messages and other back ground task. However they lose the connecting during stand-by. When I open the device it shows me an error message “no valid network” and it start searching for the network. No issues with reconnecting.

    Never had this issue before on my other routers (Asus, Netgear and Apple)
    I did some trouble shooting. Deleted the network profiles, restarted the devices etc. However this doesn’t work.
    What seems to help is to change the wireless channels on the Amplify router. For some reason it works for a couple of days and next the issue starts all over again.

    This happens on IOS 10 and IOS11 as well. Strange enough not on all my IOS devices.
    However this issue really started with the Amplify HD.
    I’ m not in a extremely crowded area with many wireless routers using the same channels.

    Any suggestions?

  • Hello Jacob! Thanks for reaching out. Have you by chance reached out to our support helpcenter with this issue? If so, what is your support ticket number so that I can take a closer look at your situation and help you further? If you have not yet reached out to our support teams, please do so HERE:

    Thank you again for participating in our AmpliFi community and look forward to finding a solution.

  • Hey Jacob, I´m facing the same problem.
    Some of my iOS devices just run fine, the other lose connection and connect to the cellular network instead, which really bothers my kids with their limited plan of 2 gb/month.

  • I have the same issue with Android devices. as soon as the screen turns off, the wifi seems to drop and when i put it back on i have to wait a moment for it to connect again. i thought it was just me. will watch this post for any solutions.


  • I haven’t had this problem myself (6 iOS devices within the home), but some other similar threads suggest doing a factory reset on the iOS device resolves the issue, obviously not ideal but might be worth a shot.

  • @tom-wood Have you checked the sleep policy? Settings > Wireless and networks > Wifi settings > Press menu and advanced

  • I submitted a ticket for this issue. I did a factory reset on one device, however this didn't solve the issue. I do have this issue on a iPad Air 2 and a iPhone 6s. However everything is fine on my iPad Pro 10.5 and iPhone 7.

  • Hi Jacob
    I experienced a similar problem with iOS devices. After submitting a ticket and lots of troubleshooting, I figured out that the main network security setting was set up for WPA2-PSK, while the guest network security was set up as WPA-PSK. I changed both to WPA2-PSK and since then the problem was completely resolved. No more disconnects from iOS devices. I hope this also fixes your problem.

  • @stefan-du-toit
    Thanks for the suggestion, however both networks are set to WPA2 PSK. Tried during trouble shooting with WPA PSK but didn’t help.

    However I have now both problematic devices connected to my guest network. I gave this network a new name, never used before, and till now both stay connected.
    So my next step will be to setup my home network with a new SSID (also never used before) and a new password.
    Not sure if there is any logic behind it, but I have to give it a try.

    Could also be that it solves the issue only temporary. Like what happened when I changed the channels.

    I got some suggestions from support, but this was to generic. Will contact them later again, if the steps above fail.

  • Interesting; I had the same issue - 100% consistently - with an iPad Air 2. All my other iOS devices are newer (iPad Pro 9.7 and 10.5, iPhone 7) have no problem at all (also consistently). All are on iOS 11 (and 10 prior). So at least in my environment it only seemed to affect the 'old' device...

  • @jacob-bakker
    Hi again Jacob. To my surprise the issues with iOS devices showed up again just about 12 hours later. My iMac and MacBook was connected to the wifi, but had no internet connection. I am kind of perplexed by this. Please let me know if you come up with a fix.

  • So finally changing the network name finally didn't solve the issue.

    I' m currently testing with the DHCP lease time. default is if I'm correct somewhere around 4 hours. I did now change it till 1 week.
    Last night the devices stayed connected.

  • Going back to support, because nothing seems to solve the issue. Sometimes it looks promising, but after a day it starts again.

    Summary of what I tried:

    • changed network names and passwords
    • checked authentication type WPA2 PSK and WPA PSK, and tried both
    • Turned on guest network and turned off. And tried the devices on the guest network instead of the home network.
    • changed DHCP lease time to 1 week
    • assigned static IP adresses.
    • IOS 10 and IOS 11
    • Changed network channels (from automatic to custom defined channels)

    Again I had in the last 2 years 3 routers and no issues at all, it started immediately with the Amplify router. Routers I had:

    • Asus RT-AC86U and Asus repeater
    • Netgear Nighthawk
    • Apple Timecapsule.

    Note that I'm extremely happy with the Amplify setup, the router with mesh points solved wireless coverage issues, the others couldn't. But this connection issue is annoying.

  • @jacob-bakker
    Yep, still having the same issues here too. I have tried basically the same settings than you. Strange that it only pops up after a while following a reboot. No similar problems noted on Synology and Netgear routers if reconnected to the same ISP. I hope a firmware update will fix this.
    Which service provider do you use?

  • @stefan-du-toit I’m using a service provider in the Netherlands with 300Mb download. (Cable) modem is in bridge mode.

    I got an answer from support saying that the developpers are aware of this issue and it will be fixed in a future update.
    So we’ ll have to wait, hopefully it will be fixed in the next update.

  • @jacob-bakker

  • Issue seems to be solved in the latest 2.40 firmware update. upgrade 2 days ago and didn't get any disconnects anymore.

    Great, now it is perfect!

  • @jacob-bakker
    Mine is working too and nomore disconnects from Meshpoints. Thanks Amplifi team!

  • @stefan-du-toit Mine seems to be better as well, which is great.
    I'm sure this isn't a coincidence, so I wonder why they didn't list this important point in the release notes.
    I also wonder why nobody from the Amplifi team has posted anything here recently (unless I've missed it).

  • @jeffreyh51 I don't think that they publish all fixes in the release notes. That's something you see more often.

Log in to reply