Kit Mesh Point Power Supply Dead


  • I have an HD kit (2 HD mesh points hard coded to router) and 1 HD mesh point failed to respond, and has no lights when plugged in. Swapped antenna with working power supply base and the antenna is okay. So, I guess the other power supply base failed.

    How can I get a new power supply base (since the antenna is linked to the router), or can the power supply be sent in for repair? I realize it's out of warranty but since the whole unit is a kit, I'd like to minimize cost without having to buy a whole new mesh point.

    Thanks.


  • @tony-st-clair-0 The test you performed is perfect for determining if it is the power supply or the mesh point. The mesh point is hardcoded to the router, the power supplies are just accessories that are not so I can ship you a replacement power supply. Please DM me your shipping information.


  • @ui-brett said in Kit Mesh Point Power Supply Dead:

    @tony-st-clair-0 The test you performed is perfect for determining if it is the power supply or the mesh point. The mesh point is hardcoded to the router, the power supplies are just accessories that are not so I can ship you a replacement power supply. Please DM me your shipping information.

    Wow! Thank you very much for the prompt reply and offer for replacement! I just sent you an email with my shipping info.

    Thanks again!


  • So this scenario gets a free, out of warranty replacement power supply but I have to buy a USB-C adapter for my dead micro-USB along with a janky adapter?

    Oh, I see.


  • Received replacement power supply and everything is back up and running! Thank you! Excellent customer service.


  • @eric-t, This scenario is involving the Mesh Point power supply, which is a magnet base the mesh point connects to, not the USB-C or Micro USB cable.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.