Teleport Constantly Going Offline Requiring Reconnect to WiFi in Last 24H

  • In the last 24 hours or so my Teleport has gone offline now 4 times dropping to the full blinking circle

    This is at a fixed remote location and unplugging the Teleport and plugging it back it does not reestablish a connection to the WiFi at the remote location (which happens to use a AmpliFi router)

    Must go through the setup process each time to get the Teleport working again

    All AmpliFi devices at all locations (Home network, Remote network and the Teleport) are still running 3.0.1

    It seems like ever since the 3.1.0 update became available to the AmpliFi HD routers at both ends (Home & Remote locations) the Teleport cannot stay connected - timing coincidentally matches the update availability rolling out to all routers

    Not really wanting to update to 3.1.0 at these locations I have to update in order to obtain Teleport stability again?

    Support Files from the Home Router, Remote Router and Teleport attached...




  • You beat me to it. I am experiencing the exact same behavior. Hopefully this gets fixed.

  • @derek-saville I have reported and will begin to investigate this

  • Thank you @ui-brett - just wanted to grab support files before I do any router reboots over the weekend since the MAC address might flip at the home location killing the Teleport until I can get someone over there to fix the port forwarding rule

  • Hi @ui-brett - any idea what might be going on here?

    My Teleport can't stay connected for more than 24 hours and I know if I reboot the home router there is very strong possibility that the MAC address will flip and kill my Teleport access until someone can fix the main router port least favorite option


  • @derek-saville Still investigating, nothing to report as of yet.

  • @derek-saville Out of interest Derek, does your parent router not allow you to bind a different (but fixed) IP address to the second MAC address when the flip happens so you end up with two fixed IPs depending on which MAC address is active? Can you then not forward the AmpliFi's port to both IPs and circumvent this problem? I haven't tried this as not come across the MAC changing issue yet.

  • @derek-saville another option would perhaps be for you to use a spare PC at home that you can remotely access from your work or travel destination when you need to change the home AmpliFi web UI settings or your parent router port forwarding rules if your teleport disconnects.

  • Hi @ali-hadi - thanks for the suggestions!
    It's a Comcast router and I haven't tried forwarding the port to both IP address - will see if that works
    And I was using the Teleport itself as my portal to the home to avoid the need to remotely access a PC
    As it is now I just have someone physically go over there to fix it

    Hoping the new Teleport App, once it works in Bridge mode with LAN access, will work without the port #, be more robust, or lead to a solution

    Hi @UI-Brett - when a router is in Bridge mode, which MAC address does AmpliFi expect to be published to the upstream router?
    The WAN MAC, or the LAN MAC?
    It would be really helpful to know which one should be correct

  • Hi @ali-hadi - unfortunately this router will not forward a port to two IP address simultaneously

    As it is now, I have 2 rules, one for each IP address, but only one can be marked active at a time

    But it was worth a shot - thanks

  • Hi @ui-brett - all devices updated to 3.1.0 and all modems & routers rebooted

    Teleport connection dropped in less than 8 hours

    Bridged HD router at the home network continued to publish the WAN MAC to the upstream Comcast router

    Please let me know if you want more Support Info files

  • @derek-saville It is interesting that your parent router is not doing that as the AmpliFi itself appears to have this facility allowing me to open the same port forward to two different IP addresses belonging to two different Syonology servers on my network. I have not yet used my teleport for long durations since the new firmware and might give it a try to see how long it will stay connected for over this weekend. I also take it that you have not tried your AmpliFi in any mode other than the bridge mode.

  • Hi @ali-hadi - this particular location is specifically for using Teleport with Comcast service which requires the Xfinity gateway and double NAT’ng isn’t an option either

    The gateway will not allow a single static IP to be assigned to two different MAC’s

    And I just tried activating both port forwarding rules (same port # different static IP’s) and it won’t allow it

    I believe if I have a different port # for each IP address and could change the Teleport port # selection in the app (instead of the web UI) via remote access, it would work and naked life easier

    UPnP probably fixes this eventually in the background for most users if the issue occurs, but not immediately

    When I originally used UPnP and the MAC would flip it would just kick back a UPnP error code if I was trying to reconnect right away
    That’s why I switched to static IP’s and port forwarding in the first place

    Only one other person has reported the issue of Teleport constantly disconnecting

    Usually this has something to do with their back end servers and I don’t believe it is coincidental that the problem started with the 3.1.0 firmware update and new Teleport App being released

    So you probably won’t experience the same problem

    The MAC address flipping between WAN & LAN has been reported by many people over the last year, but no luck getting it fixed

    If AmpliFi would just give us a MAC spoofing option in Bridge mode like they have in NAT mode it could be fixed easily, but such a feature is a low priority

    Unless the Teleport App suffers the same problem in Bridge mode with a lot of complaints, I would not expect the MAC problem to ever be fixed

  • @derek-saville I have updated to the latest firmware and this same issue has occurred with both my teleport units that are setup to separate routers.

  • Hi @damon-ross - do your home network AmpliFi routers that serve your two Teleports use Bridge mode?
    Or is one your primary NAT router?
    Or do either use a DHCP mode and double NAT?

    Do you have easy access to your home network?

    The first thing to check is log in to the web UI of the routers and see if they are reporting the same mode as what it should be
    For example, if you the router should be in Bridge mode, the web UI might report DHCP
    Be very careful in the web UI because if it reports the wrong state and you make a change, it will lock in that state

    In the mobile app, then also check the mode of the routers
    What I have done recently (and remotely) is toggle the Bridge mode setting a couple times, letting the unit reset each time, and ensure it is set correctly in the app and web UI
    Going through this process reset the MAC the right address and corrected whatever issues were occuring

    The same can be done with the IPv6 setting, which is also available in Bridge mode
    Toggle it a couple times and let the unit reset
    I have found Teleport to work best on Bridge mode routers with IPv6 off, but mine are doing nothing but serving the Teleport

    If you are using a primary router from your ISP and using port forwarding, you can also check if any port forwarding rules have been broken by MAC address changes
    The MAC will alternate between the LAN and the WAN
    So I have two port forwarding rules set up (one for each MAC) that I have to manually change when things go wrong

    @Ali-Hadi has also run into similar issues recently may have some additional advice

    The next beta firmware v3.1.1 is also supposed to fix some MAC issues and UPnP issues that have plagued the Teleport
    You can consider enabling the beta option in the web UI for the routers that are serving your Teleports or wait as I would expect it to be released soon

  • @damon-ross I have followed the advice given by @derek-saville but finally settled on using my main ISP's router as the one to handle all NAT and routing functions and left the AmpliFi HD router purely in (dumb) bridge mode giving full control to my parent router. My main router and gateway has also fortunately allowed me to setup two different portforwarding rules for both static IPs for the different MACs but to the same external AmpliFI's port and this would in theory open the port to my AmpliFi regardless of which MAC it is sending to the main router. I have not had any problems since but have also not noticed the MAC flipping again since upgrading to latest beta firmware and so hope that the team has actually completed fixing this issue once and for all

  • Just to clarify, I am not suggesting to switch from Bridge mode to a double NAT scenario

    I run my HD routers in Bridge mode to serve Teleport

    What I have found is that when Teleport starts behaving erratically, I can temporarily toggle the HD router out of Bridge mode into DHCP mode, let the unit reinitialize itself, and then immediately toggle the HD router back into Bridge mode

    This sort of acts as a “Bridge mode reset”, synchronizing it again with the main upstream ISP router and stabilizing it

    Sometimes I have also toggled the IPv6 setting in a similar manner to get the system fully “reset”

    While you are remote this is like doing a factory reset of just the server bits without doing an actual factory reset losing everything including remote access

Log in to reply