Mesh Router - Teleport


  • Morning all,

    Firstly, apologies as this seems to have been covered lots however I can't find the answer in any of the open topics thus far. And Chat Support has not be useful at all.

    The question is - what ports does Teleport need open/forwarding on my incoming Internet router to my Mesh Router which is in bridge mode; UPnP is off on purpose on the Internet router and there's already a lot of port forwarding configured; therefore, something currently configured may be causing the issues am getting with Teleport. Whereby it connects fine, but that's it - don't get any data transmitted over it and cannot correctly see my home network externally.

    If anyone happens to know these ports (TCP/UDP (or both)) I'd appreciate you sharing these with me.

    Many thanks in advance,
    Matt


  • Hi @matt-mcleary - you need set the Teleport port # manually in the bridged AmpliFi Router’s web UI if UPnP is turned off and then create a port forwarding rule in you main NAT router to forward that port # to the bridged AmpliFi Router

    It’s been a long time, so maybe the web UI shows a default port # - I don’t recall

    TCP & UDP need to be open

    If you haven’t set a static IP, you can find the bridged AmpliFi Router’s IP address on the LCD screen (tap to cycle thru) and access the web UI directly if amplifi.lan doesn’t work

    Let us know if you still have any issues


  • Hi Derek,

    Thanks for your reply.

    you need set the Teleport port # manually in the bridged AmpliFi Router’s web UI if UPnP is turned off and then create a port forwarding rule in you main NAT router to forward that port # to the bridged AmpliFi Router

    This only works within DHCP mode on the Mesh Router, not bridge mode.

    TCP & UDP need to be open

    The firewall is fairly liberal but my worry is I'm already using one of the ports Teleport needs for something else, therefore keen to identify what the base-range is or the default ports to ensure there's no conflicts on the network.

    If you haven’t set a static IP, you can find the bridged AmpliFi Router’s IP address on the LCD screen (tap to cycle thru) and access the web UI directly if amplifi.lan doesn’t work

    Yes, we have a static IP in the home as there's other services running off the back of it.

    Cheers,
    Matt


  • @matt-mcleary this post saved me and credit to whoever posted it (please give them thanks as well):
    https://community.amplifi.com/topic/838/stuck-on-pairing-step-3/5

    For some reason the ability to choose the external port on the Amplifi's Web UI was not initially showing up for me but it then turned up after several refreshes and logging in and out on my browser (may be try logging in using a different web browser as well). I will try and upload a screenshot-->0_1566121841509_2019-08-18_104540.png


  • This only works within DHCP mode on the Mesh Router, not bridge mode.

    Hi @matt-mcleary - as @Ali-Hadi shows (and beat me to it 🍺), the Teleport external port selection is definitely in the Web UI for Bridge mode...

    0_1566123365810_WebUI.jpg


  • Thanks both, very helpful - not sure why then as I can't get the external port option to load...

    Changed the password a couple of times and tried on three different browsers, so weird! Will keep at it and come back soonest if I can get it to show.

    Cheers again,
    Matt


  • not sure why then as I can't get the external port option to load

    Hi @matt-mcleary - can you upload a screen grab of your AmpliFi router's web UI settings page?

    When you initially go to the AmpliFi router's IP address, does it show both devices (router and paired Teleport)?

    And then when you click on the router, does it come up in Bridge mode or DHCP?

    Are you running the latest 3.1.0 firmware?

    The web UI can be flaky and will sometimes show DHCP instead of Bridge mode
    On more than one occasion I have gone in to enable/disable a setting like A-MSDU and failed to pay attention to the Connection Type, hit Save & Continue, and unknowingly activated DHCP creating a Double NAT
    Things then start breaking and only notice in the AmpliFi app that Bridge Mode was accidentally disabled
    The External Teleport Port setting should still be there, but things seem to randomly come and go in the web UI...


  • Running the latest version of the sofrare - Teleport info the Mesh access point via iOS App, not using the hardware solution.

    What I see when logging in:

    0_1566133529864_Screenshot 2019-08-18 at 13.18.45.png

    The Amplifi Teleport app connects, adds the profile fine on my iOS device but no actual data comes through at all... It's all a bit weird!


  • Hi @matt-mcleary - the Teleport app doesn't work for routers in Bridge mode yet!
    Compatibility for both Bridge mode routers and local home LAN access will be added later

    See this post from @UI-Brett...


  • This Teleport piece of **** is doing my head in. Keeps disconnecting every so often with no apparent reason (even with nothing connected to the darn thing). To top it all off, the ability to change the Amplifi's external port has now completely disappeared from the web interface no matter what I try.0_1566141802479_2019-08-18_160243.png


  • @matt-mcleary right, what I did was that I unpaired and then reset the blooming Teleport (twice), paired it again until I got the error where it go stuck on step 3 and then went back to the router's UI to find that the option to choose the external port has miraculously appeared again. A real pain the back side and I have a feeling all these problems are due to everything changing MAC addresses every single time something is changed or teleport is reconfigured even if to connect to the same upstream network. I really cannot understand why these changes happen every time I reconnect the teleport to the network. I was also shocked to see that even my meshpoints have changed their MAC addresses after a reboot! A receipe for complete instability for this system in my opinion.


  • This post is deleted!

  • @ali-hadi Was reading it all wrong, deleted my post.


  • Hi @ali-hadi - when you initially go to the AmpliFi router's IP address, do you always see the paired Teleport device listed?
    0_1566160986852_Web UI.jpg

    The web UI Settings page for the router can be erratic on what mode it thinks your router is in (DHCP vs Bridge) and what options it presents

    I believe the External Port For Teleport Connection option will only appear if the router thinks (in that moment) it is currently paired to a Teleport
    If have to often check the AmpliFi app to make sure there are no pending Teleport pairing requests to accept as doing a Teleport reset may or may not require the router to accept it again

    I have only seen the MAC address of the AmpliFi router flip-flop between the WAN MAC and the LAN MAC
    For me, the Teleport is more stable with the AmpliFi router in Bridge mode when the LAN MAC is seen by the upstream internet router
    It would be great if @UI-Brett could confirm which MAC address should be utilized in Bridge mode
    I assume the LAN MAC since the WAN MAC was only created in order to implement HW NAT, which doesn't exist in Bridge mode since no NAT is taking place in the router

    Which MAC address is 'active' when you do the Teleport pairing may be a factor that I haven't looked into

    I was recently experiencing frequent disconnects but was finally able to get it to stabilize by temporarily toggling Bridge Mode off in the app, letting it reset itself, and then turning Bridge mode back on
    I sometime also toggle IPv6 (which doesn't work for me) on and then off again, which will sometime flip the MAC
    There should only be the minimal set of feature options for a Bridge mode router, and if any more are present (like HW NAT), it means the router isn't totally configured properly

    My connection has been stable for over 24 hours now again, where for days it was constantly disconnecting

    One suspicion is that during router reboots or resets for configuration changes it temporarily goes into DHCP more before switching back to Bridge mode causing the MAC address changes which don't reset properly depending on what feature options may be defaulted in DHCP mode (like HW NAT being On)

    The Ubiquiti back-end servers that provide the connection information for the Teleports to find their home routers also have issues sometimes causing frustration, but eventually work themselves out

    Teleport is great when it works, and unfortunately pretty awful when it doesn't work


  • @derek-saville when I was trying to get to see the Amplifi's port on the web UI my teleport was disconnected as was having one of its frequent hissy fits. I had had to unpair, reset and then pair the teleport again before the setting showed up again. I had not changed anything from the router's side and so cannot really understand how the web UI can change so erratically and unpredictably. I also still do not understand the need for the Teleport to keep on changing its MAC address with every different connection and also cannot explain mesh points changing their MACs after a reset! The whole thing does not sound right at all.


  • Teleport to keep on changing its MAC address with every different connection

    Hi @ali-hadi - I was experiencing the same thing during the period of instability
    Every Teleport reconnect would grab a new IP address from my home Internet router based on a seemingly random MAC
    And I am guessing the DHCP lease expiring every 12 hours was causing the disconnects and then the Teleport couldn't reconnect without going through the setup again

    Only when I toggled some settings in the AmpliFi app for the bridged AmpliFi router serving the Teleport (Bridge Off & On, IPv6 On & Off) so that my router MAC was the LAN MAC and the Teleport connected with it's proper true MAC did stability return and everything seems to be working again

    Hi @UI-Brett - can you comment on the Teleport MAC craziness?

    On my Comcast gateway I can see 11 different recent IP address associated to my Teleport coming from different MAC addresses.

    The original entry with the correct MAC...
    AFi-T-02xxx
    F0:9F:C2:02:xx:xx

    ...now matches the stable connection:
    AFi-T-02xxxx-5
    F0:9F:C2:02:xx:xx

    But during the period of instability the Teleport had a number of different MAC addresses grab an IP for the Teleport:

    MAC Addresses
    86:DD:C4:94:75:58
    1A:45:4A:64:3D:4C
    AE:06:FD:35:62:37
    5A:04:57:DD:BB:34
    3A:20:09:EF:45:C6
    E6:7D:D8:A0:A8:08
    8E:14:25:C0:23:AC
    etc...

    Something went very wrong


  • @derek-saville many thanks indeed for confirming that "Teleport MAC craziness" because at one point I thought that it was me who was going crazy! I will reset the whole thing (router, mesh points and teleports) and then set the router to bridge mode prior to changing any other configuration and try the teleport next weekend to see if the connection will hold. Like you, I have had at least 10 different MAC addresses just by reconnecting to the same network.


  • @derek-saville you gave me an idea to look at my parent router's DHCP IP assignment table to find that my AmpliFi HD has indeed flipped its MAC address at one point this afternoon from 7A-8A-20-xx-xx-xx to 78-8A-20-xx-xx-xx for no obvious reason whatsoever. I have just bound the other MAC address to a second fixed IP and then created a port fowarding rule to that second IP address. I will see if this would keep the blooming Teleport connection from dropping.


  • Hi @ali-hadi - yes, the MAC flip can occur randomly for no apparent reason

    It may be something the ISP does which causes it, but I don’t know

    The flip will also occur with configuration changes or reboots, but not every time

    It is very frustrating and real, but unfortunately AmpliFi have never confirmed they can replicate it so they don’t acknowledge there is anything to actually fix


  • @matt-mcleary I think there was some confusion on which Teleport product was being discussed.
    The Teleport hardware will give you the option to manually assign the port being used, but this option will only appear when the network has a Teleport device paired. This is probably why you are not seeing this option in your WebUI.

    The Teleport App currently only works when AmpliFi is in router mode, so creating a port forwarding rule is not needed at this time.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.