Lag & stammer with wifi speakers


  • Hi! I'm using Amplifi mesh for a couple of months now with 1 base and 2 HD Mesh points. Also bought 2 wifi speakers from Urbanears. When playing via wifi to the speakers a lot of lag and stammering is heard. I already ran flawless with an other brand wifi speakers earlier. Testing aroung I noticed;

    • the new triubling speakers randomly connect to a meshpoint or router itself (router is nearest). Can I force a device to connect to a specific meshpoint or router which is the nearest?

    • are there any other options in the Amplifi configuration to improve audio streaming except the 'Optimezed for streaming' option on the wifi device which is already enabled?

    Thanks for supporting!

    Yvo


  • @yvo-van-wijk Are your speakers connecting through a MeshPoint or through the router directly? Can you see what the signal level of the speakers is from AmpliFi app?


  • @ui-jt Hi! They connect randomly. Sometimes direct to the router, sometimes to a Mesh point (which is further away). I'd actually bind a speaker to the router and a band specifically. (?)


  • Hi @yvo-van-wijk - have you tried creating a Separate SSID on whichever access point you prefer (router or mesh point) with only the band you want (5 or 2.4 GHz only) and connecting the speakers to that unique SSID?

    The Separate SSID option is individual to the access point it is created on and can be band specific as well


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.