Slow Wifi with FW 3.1.0 on Google Fiber


  • I'm seeing a lot of these posts so I thought I'd chime in. I'm running Google Fiber with a Trendnet gigabit switch and Amplifi as my wireless router. I am getting up to 800Mbps via ethernet.

    Wifi has been fine, but I'd noticed lag spikes in games to the point of disconnection in some cases. Speed tests on Wifi were coming back at 20/30Mbps max, and YouTube was playing back grainy and scaled down. I didn't think about it until this evening, but the changes were right around when I updated to 3.1.0. I changed all kinds of settings and made sure Hardware NAT was enabled.

    I reset phones, laptops, etc. Tonight I made two changes: I downgraded to 3.0.1, and I enabled Router Steering. At the moment wifi is back to 140-160Mbps download while upload is still pretty slow (~30Mbps).


  • @adam-reed you need to put the amplfii in bridge mode I swear half of the people with issues left it in router mode and put it behind a different main router.

    If you have the trend net as main the amplfii has to be in bridge other wise you are double routing and if you have an Xbox or PlayStation that would cause double Nat or double firewall.

    Also you need to disable WiFi on the trend net if you have not done so already.


  • @Edward-Dolezal my mistake, the TrendNet is a switch. I did Google router -> bridge-mode Amplifi previously and have had MUCH better performance using the switch -> Amplifi router mode. I do not have a double NAT, and have had no issues with Xbox port forwarding.


  • Wifi is back to 20-60Mbps. My AppleTV 4 on Wifi doesn't have a speed test, but even YouTube is timing out to the point the navigation icons aren't loading. Again, 800-900Mbps on ethernet from Fiber Jack -> TrendNet -> Amplifi -> Macbook.

    Still on 3.0.1. I have switched both 2.4 and 5 Ghz Wifi channels a few times with no change. I have tried 3 Macbooks and multiple speed tests.


  • Doing more and more reading - both mesh points have 5 lights representing the strongest signal. I removed one of them to remove any doubt about which configuration they're in. Still no improvement.


  • @adam-reed When you performed the wireless speed tests, are the devices connected to the mesh points or to the router?


  • @ui-brett I've been working with Live Chat since last evening and Tier 2 support via email today. I have now tested both mesh points and the router with the same speed results.


  • This is pretty frustrating - no streaming services will function and we cuts cords a long time ago. Ok, I can enjoy the quiet. My work VPN won't connect (everything relies on wireless now, thanks Apple), so that's shot. I have one laptop that will connect via ethernet and it's a 2012 model.

    I debated going full USG -> APs for a while and hoped that Amplifi would work for ease of setup - I already have a tech job and I don't want to come home and play Support. It has been great for a long time but this is basically a full outage.


  • @adam-reed I will gather the information from my Tier 2 and take over the ticket to help find a resolution.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.