Teleport app - Connected but can't do anything

  • When I run the teleport app on my android I'm able to connect to my Amplifi but whenever I try to do something it doesn't work.

    Trying to reach google gives this error message.
    "'s server IP address could not be found.

    Trying to access server on my home network using the IP also fails. Have tested pinging them using the Fing app but only get timeouts.

    I'm running pi-hole on my home network so my Amplifi is configured to use that as a DNS server. And not the one provided by my ISP.

    Any suggestion on what can be tried?

    Updating to 3.1.1 solved the problem

  • You'll need to enable "Local network" access for your phone if you're running a pi-hole for your DNS.


    Generate a code and try to connect your device, you won't get any internet access but it'll add the device as a client to the AmpliFi WiFi app. Turn Teleport off to re-gain your normal internet connectivity.

    Switch to the AmpliFi WiFi app, then you will see your phone listed under devices (along with your router and any mesh points), select your phone, then under Client Details there's an Access section, where you just have to turn on the "Local network" option. Switch it on.

    Go back to the Teleport app, and toggle the switch back to on, you should now have working internet access if all goes well.

  • Thanks for the tip. When I select my phone from the device list I don't have any option to turn on "Local network", the only thing that I can change is the name.


  • @peter-andersson With iOS at least, you needed to be running the non-beta version of the AmpliFi WiFI app a week ago for the option to appear, though I think the beta apps have been updated to support it since then.

    You also need to be running the 3.1.1rc0 (or higher - 3.1.1rc2 got released recently) firmware as LAN support was added with that, alternatively you can just wait til the 3.1.1 gets an official release.

    If you're not already enrolled and want the beta firmware you can follow these steps. PS. If http://amplifi.lan/ does not work for you, you can also access the same interface via the router's IP address in your browser e.g. etc.

  • Ok, I'm not running the beta firmware so I'm using 3.1.0, will wait for 3.1.1 to be released and try again.

  • Updating to 3.1.1 solved the problem

  • This issue seems to have returned with the 3.1.2 firmware, at least for me. I've tried a couple of different devices and the result is the same since the upgrade - "DNS_PROBE_FINISHED_BAD_CONFIG".

    Not running pihole or anything like that. "Local Access" is turned on, not that it should make any difference.

  • @jeff-laird If you rolled back to 3.1.1 do you no longer have this issue?

  • Thanks, Brett. I will attempt to test this over the weekend. I have set up an internal OpenVPN server for the time being...

  • Disregard, this was an issue related to my settings for Android for DNS over HTTPS. I completely forgot this was turned on and my OpenDNS config on the router was blocking all of the DNS requests under their 'proxy' rule.

  • Since instantiating my Pi-Hole, Teleport will not stay connected. I've had it forget the router, set the phone to use local network, to no avail.


  • @Christopher-Dubea

    Are you on the latest beta/RC version? I have the same issue since upgrading to 3.3.0 RC1. I also use Pi-Hole, Upstram DNS is on and allowed Local network.

  • @Dennis-Horn

    Latest beta/RC version of what? I'm confuzzled. All my devices, including my Amplifi are up to date software wise.

    I will do some testing this weekend to see if it truly the Pi-Hole or something else.

  • Well. I reset everything and it now works. Don't really know why. Told the clients to forget the routers, generated new codes, etc. Pi- is doing it's thing.

Log in to reply