Disabling DHCP server on a modem leads to No IP address error on the AmpliFi system


  • My home setup is this:

    1. TP-Link TL-WR840N modem that takes in the Internet signal to the WAN port
    2. AmpliFi router that is connected to the TP-Link modem

    After disabling the DHCP on the modem, the devices stop receiving IP addresses (obviously). However, it looks like AmpliFi router doesn't start its own DHCP server as it just sits on "No IP address" message.

    Well, that's obvious, as the AmpliFi system should generate it! The reason why I am so angry about the whole thing is that I have to use my AmpliFi in bridge mode - as enabling DHCP leads to download speed being exactly halved. I believe it happens because of 2 DHCP servers running in the network.

    So:

    Modem - AmpliFi

    DHCP - bridge = 100 MBit/sec
    DHCP - DHCP = 50 Mbit/sec
    DHCP off - DHCP = NO IP ADDRESS error

    What should I do? I have tried to troubleshoot this for 2 days now.


  • I would think that since you've turned off DHCP on the TP-Link, the Amplifi device is not getting assigned an IP address to use on the link between it and the TP-Link. You would need to either re-enable DHCP or manually assign the Amplifi device an IP address for its WAN link.

    I think you need to read this: https://help.amplifi.com/hc/en-us/articles/220979347-Enabling-Bridge-Mode as the Amplifi in bridge mode can not provide DHCP services. So both of your issues get solved by re-enabling DHCP on the TP-Link.


  • @fatalution said in Disabling DHCP server on a modem leads to No IP address error on the AmpliFi system:

    TL-WR840N

    I may be wrong, but looking at the manual for the TP-Link TL-WR840N it doesn't appear to be a Modem at all but just a router WIFI unit. unless you really need the TP-Link I would remove it and just connect the cable to the Amplifi Wan port.

    https://setuprouter.com/router/tp-link/tl-wr840n/manual-2194.pdf


  • The short answer is 'Yes.' The Amplifi is either a bridge, or the router.

    You can't disable DHCP on the Amplifi... You can turn Bridge mode on or off, which controls many other features aside from DHCP.

    Once you took the Amplifi out of bridge mode, but left your upstream router enabled, you invited all kinds of headaches including Double NAT. But more importantly, the WAN interface needs an IP address - and if it's set to DHCP .... it's looking for an IP address to be provided. (I can't remember the exact name, I'm in bridged mode right now.) So when you disabled DHCP on the TP link you also effectively disabled the WAN interface.

    You either need to enable passthrough on your TP-Link, and take the Amplifi out of bridged mode, or vice versa. You're trying to run your network in an invalid state.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.