Slow WiFi, great wired connections


  • I'm running an AmpliFi HD on version 3.1.1 for a week now - new unit. The family are going to kill me. I changed from another device which was working great because I like the look of this unit.

    On wired, all devices are working fine. Speed tests via Speedtest are showing around 85Mbps download (Speedtest on Apple TV), I'm on a 100Mbps plan, my ISP provides a modem/router which is in bridge mode and I connect the AmpliFi via LAN cable.

    On wireless devices, I don't get anymore than 25Mbps download. I have tried turning off band steering, I've tried creating a dedicated 2.4Ghz SSID, I've made sure r-fast BSS transition is off in the advanced settings (all recommendations from this forum). No change.

    Another issue is that on two Mac devices network access keeps "freezing" - renewing the lease seems to work as a fix.

    Any other ideas most welcome, I reckon I can tolerate the complaints for another week before I pack it in. Thanks


  • Bit of an update, in case it helps...

    My Mac laptop is getting around 70-80Mbps download speed on wireless, but the iOS device is only getting 25-30Mbps


  • @garry-voutos In regards to your Mac devices, I would suggest testing with A-MSDU turned off. I have had some reports of this feature causing some issues on Apple devices.

    Can you describe your setup for me with a little more detail?

    • What AmpliFi devices are you currently using? (AmpliFi HD kit, AmpliFi Instant, AmpliFi stand alone router?) and where are the devices placed? And how are then connected, wireless mesh or ethernet backhaul?
    • What modem are you currently using? Is bridge mode required on AmpliFI? Because some ISP's devices face issues when placed in a bridge.
    • A dedicated 2.4Ghz channel will perform at lower speeds, greater range. Did you test with a 5Ghz only band? What were those results?
    • Testing a wireless device extremely close to the main router (within 1-2 ft) will help us quickly determine if we are seeing any environmental interferences with wireless signal. What are you speeds next to the router, and have you used a WiFi scanner to see what bands are being used in your area?

  • @ui-brett Thanks for replying so quickly Brett. I'll add the info you asked for below, but I seem to have a much better experience today. I did two things: replaced the ethernet cable from my ISP's modem to the AmpliFi HD, and I moved the ISP modem about 15cm away from it.

    More importantly I deleted and re-created all the Wifi connections on Mac devices. When I installed the AmpliFi last week I used the same SSID and password for wireless as the previous device - so I would not have to re-create on all the devices in the home.

    I now get excellent speeds across wired and wireless connections on the AmpliFi, 95+ most of the time which is what I get if I plug straight into the ISP modem. Could have been a coincidence. May be this was a shortcut I took that has caused this pain. I'll give it a couple days and report back.

    Re the information you asked for:

    A-MSDU has always been off
    I'm using a single AmpliFi HD to cover a single storey masonry construction home. The device is in the hallway, right in the centre of the house. WiFi signal strength is pretty good across most of the common areas.
    The modem/router is supplied by my ISP, Optus. Its a Netgear CM500V-1STAUS. It is in bridge mode and wireless is turned off
    I did not test a 5Ghz only band
    There was very little difference in speed when testing an iOS device from about 15 metres away, or right next to the AmpliFi HD.

    Thanks again.


  • @garry-voutos Thank you for the update! Please let us know if you experience any other issues.


  • Wireless is working fine since the changes. I have one other issue which I will search for first, and post if nothing comes up. Thanks again


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.